OPKG Failed to download snapshot, wget returned 8

I've installed OpenWrt on a Belkin RT3200 following Linksys E8450 (aka. Belkin RT3200) instructions.

Everything works fine. Now I like to install a WireGuard server following WireGuard Server.

When I run opkg update I get:

Collected errors:
 * opkg_download: Failed to download https://downloads.openwrt.org/snapshots/targets/mediatek/mt7622/kmods/5.10.80-1-a3398c593d3440164c247a13bc67d164/Packages.gz, wget returned 8.

The other downloads are fine.

Running opkg install wireguard-tools I get:

The installed version of package kernel is not compatible, require 5.10.100-1-3e23c8b3… while 5.10.80-1-a3398c59… is installed

Under System -> Overview I can see the following information:

Firmware Version: OpenWrt SNAPSHOT r18125-b764cb9e5b
Kernel Version: 5.10.80

Do I need to perform the update of the Snapshot in some different way?

When you get the message “Cannot satisfy the following dependencies for…” it is most likely because you installed a snapshot version of OpenWrt.
Read here for possible solutions.

1 Like

To me it looks like the WireGuard kernel version is a head of the Firmware kernel version. Which makes we think that I need to update the Firmware to a more recent version but that step fails when I run the upgrade.

I might be interpreting this wrong.

You may have run into the time limit regarding snapshot build.

Main differences of buildbot snapshots vs. official stable releases:

snapshots are built daily, and that sets time limits to installing new packages with opkg. Due to kernel version checksums, you can only install “kmod” kernel modules and other kernel version dependent modules from the exactly same snapshot build. So, a few hours after flashing the firmware you may not be able to install new modules with opkg any more ...


Thanks. I updated to latest snapshot and it worked.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.