Opkg failed to download packages

I am trying to download LUCI using this instructions https://openwrt.org/docs/guide-user/luci/luci.essentials, but when I execute this command opkg update this message appears opkg_download: Check your network settings and connectivity.

How can I solve this problem?

the error message appears to be self-explanatory....

1 Like

The router has no access to WAN. Chech the WAN settings, or the connection.
Unless you use a snapshot, Luci is already installed.
If you use a snapshot, it is assumed that you know what you are doing.

What is the output of these commands?

Please run the following commands (copy-paste the whole block) and paste the output here, using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have

ubus call system board; \
uci export network; uci export dhcp; uci export firewall; \
head -n -0 /etc/firewall.user; \
ip -4 addr ; ip -4 ro li tab all ; ip -4 ru; \
ip -6 addr ; ip -6 ro li tab all ; ip -6 ru; \
ls -l  /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/* ; head -n -0 /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/*
1 Like

How can I install luci offline knowing that my router is tp-link td-w8970 v1 ?

transfer the packages from your computer to the router using winscp.

why can't you connect your w8970 to the existing internet connection,
directly, or via the primary router ... ?

packages can be found at the bottom of https://downloads.openwrt.org/releases/21.02.0/targets/lantiq/xrx200/ or
https://downloads.openwrt.org/releases/19.07.8/targets/lantiq/xrx200/

2 Likes

I have a problem that my router cannot reach internet, i try to edit /etc/config/network but still i didn't reach network

how are things connected ?

Main router connected to my openwrt router by cable on lan/wan port.
My openwrt router connect to my laptop by cable also.

ok, in that case, what's the IP on the w8970s WAN port ?

I assume the LAN IP still is 192.168.1.1 ?

Wan port I putted it 192.168.100.220 according to subnet of main router.
Lan port yes it still 192.168.1.1

if you manually set the IP 192.168.100.220 on the w8970, you also have to add the default GW and DNS yourself.

you could have just as well kept WAN as DHCP client, and let technology do the work for you :wink:

what version did you install anyway, 21.02 final should include Luci

Ok I will put it to dhcp.
But what is device in wan, because it is by default dsl0?
Yes last version.

probably need to read up on https://openwrt.org/toh/tp-link/td-w8970_v1#switch

last as in snapshot, or 21.02 stable ?

what's the intended use case anyway, router or AP ?