Opkg extras crashed Zyxel NBG6817

Hi.

I upgraded all of my routers to newest stable 21.02. My Netgear 7800 worked fine with opkg extras installation.

Additionally when I installed opkg extras to my Zyxel NBG6817 it crashed because opkg extras opened so many threads that there was no memory left anymore. Also I cannot execute opkg commands after the installation.

Does anybody facing this also? I done the package installation after a reset manually now but the script if very nice so I would like to use it also on my main router.

Installed it from here (like R7800 also): https://openwrt.org/docs/guide-user/advanced/opkg_extras

Cheers,
Nils

1 Like

Check the output:

sha256sum /etc/profile.d/opkg.sh \
/etc/hotplug.d/iface/*online* /etc/hotplug.d/online/*

If I install the script (like on the other routers) the Zyxel will not be available anymore after some seconds/minutes. So actually the script is not installed.

A simple "opkg save" command will not finish so perhaps that is the reason why it starts so many processes in background...

Installed the script without hotplug support and now it does not kill my main router :slight_smile: but it still does not work and opkg save hangs.

root@OpenWrt:~# sha256sum /etc/profile.d/opkg.sh \
> /etc/hotplug.d/iface/*online* /etc/hotplug.d/online/*
3186cfbfb62940aafbbac41e03d14ad3e8e35518ad73dc624cba8f9e138097e3  /etc/profile.d/opkg.sh
sha256sum: can't open '/etc/hotplug.d/iface/*online*': No such file or directory
633999932f5198dca33c0282655b417e3aec05938828fe46e659256bd9ca4fed  /etc/hotplug.d/online/50-opkg-restore
1 Like

There was a bug I have fixed just a few hours ago.
You should update the script to match the following hash:

428eec430b43ab088132418de4b6c7fa435d6a333c19db0abd470cc0ae437148  /etc/profile.d/opkg.sh
2 Likes

Solved my problem...perfect! Many thanks for the faster than light fix.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.