Operational OpenWrt 19.07.2 Factory Tar file for EdgeRouter X

It is possible to upgrade the boot loader from EdgeOS 2.x before flashing OpenWrt. I think it is worth following the instructions on the Ubiquiti website to do this if your ER-X came from the factory without it. It is much easier to recover a bricked ER-X back to factory firmware (and from there flash OpenWrt again) with the new boot loader. Perhaps water under your bridge at this point, but others may benefit.

If you set up VLANs to segregate IOT and guest interfaces on your home network, you might want to stay clear of the current OpenWrt snapshot and stick with 19.07.x stable for now. Snapshot has converted from swconfig to DSA to manage the switch, but it remains a work in progress with no Luci support yet. The physical ports were mapped back to the OEM factory defaults with the DSA conversion - so the reminder to move your cables to the right ports when going from factory to OpenWrt on an ER-X applies in reverse going from OpenWrt 19.07 to OpenWrt snapshot LOL. Additionally, if you want more ports to have access to the default lan interface, you'll need to change the config files to bridge them manually as they are not mapped to an interface by default in the current snapshot. It's been awhile, but as I recall, this too is consistent with the EdgeOS defaults.

I think you'll be happy with it. OpenWrt has worked really well on my ER-X as a home gateway (definitely better than Edge OS). Plenty of memory and flash (256MB each) to load it up with features, the CPU is just fast enough to handle SQM QoS on my 200/10 Mbps ISP connection, it is compact enough (downright tiny in fact!) to easily tuck inside my home telecom wall panel and it runs cool inside that small enclosed wall panel thanks to its low power draw.

1 Like

Thank you. I am not planning to try out snapshots since everyone at home is constantly using the network in the pandemic and wouldn't want any downtime. I switched to this one as a primary router with adblock and dns over https. I think in the last few hours I can already see my network become more stable since my previous router was AC68U with Merlin which is fine for home use but definitely not as good as ER-X with OpenWRT. Especially with encrypted DNS this is better since that used stubby and the config didn't work great. In fact sometimes it had major issues and would have to reboot. I also think ISP modem could be an issue because right now with or without SQM my bufferbloat is 2000ms+ (wired) which is just insane and it might not even be correct. Maybe something is wrong with the config (though SQM config is simple from openwrt website and hwoffload is off which is unsupported with sqm anyway). I can't do much about the modem or ISP so I might have to try few configs to see what works. With ASUS Merlin i've seen as low as 50ms in the past but the modem is unreliable and I have seen something as high as 200ms sometimes as well. I might have to limit something to 10-20mbps for my 50/10 connection since currently the networks here are all over the place because of increased demand.

My LAN setup is very simple and I plan on ordering a decent access point swapping it for AC68U since that is currently my AP and I don't think i'll be setting up VLANs anytime soon. Maybe for guests if I can get a decent AP with guest access but again since I am sticking to stable builds for now. Thanks for the heads up on bridging. I haven't needed more than 5 ports for my simple home setup so far but I have already used 3 now and will be adding another AP (tossing the AC68u and replacing with 2APs else it would have been fine as an AP as well) so with 4 ports I might have to buy a new switch. The ER-X on stock used to heat up for some reason probably cause it was in a closed space without much ventilation but I think I will move that somewhere better exposed to fresh air.

I think except for bufferbloat (cable modems suck) overall this was a good decision to switch to OpenWRT (assuming its this stable 24x7). EdgeOS really wasn't great.

I didn't know about the bootloader. I think ill have to flash to stock v1 using serial method then flash to v2 on stock and then reflash to this again to get the new bootloader? Is there something about the newer bootloader that would be beneficial? Or should I not care too much at this point.

This. Might as well wait to do what you outlined (back to stock on serial, upgrade, then back to OpenWrt) until if and when it is necessary. Which could be never.

I've gotten consistent "A" bufferbloat on dslreports running CAKE SQM on my ER-X with both 40/2 DSL and 200/10 cable ISP options (I rotate every 12 months when the introductory price increases). Based on that, I'd suspect your modem, ISP or settings. You might try dropping the speeds you have set for SQM until and if you see an improvement. Cable speeds can bounce around a bit - with luck you may just need to give SQM a little more head room to work with.

Thanks. Managed better bufferbloat with better tuning. Not the setup's fault though, ISP acting different during different times probably too much pressure on networks currently.

Personaly, I recommand upgrading to EdgeOS 2.x before installing OpenWrt. The bootloader is better, and later on, it's way much easier to reinstall the original EdgeOS if you want to get rid of OpenWrt.

1 Like

Hi! I'm hoping you see this and can assist me in flashing openwrt onto my edgerouter x. It's currently running stock edgeos firmware (1.*).

I'm a complete noob when it comes to these things, I've read your post but still don't understand any of the commands. I've also read the wiki for the edgerouter x but there's so much info jumbled up I don't know what is what. Are you able to provide step by step instructions so I don't mess anything up? Keep in mind I've never done anything like this before. At the moment all I have downloaded is PuTTY which will be my first time using as well. Appreciate any help, thank you.

1 Like

This saved my bacon today. Thanks for the reference. I ended up putting a usb-ttl adapter on the internal pins of my ERX to get a serial console. I setup a tftp server and followed the recovery process successfully.

Currently I have gone back to latest v2 and plan on flashing back to openwrt to 19.07.4 ... Is there a new tar for it ? The safest method I find is using your tar to go to 19.07.2 then using sysupgrade of same version then using the latest sysupgrade afterwards.

I have managed to create the TAR factory file for the SFB edgerouter. Let me know if someone wants it. Happy to post

I'd appreciate some help here as I am quite inexperienced with OpenWRT. I have a couple of Edgerouter X boxes and decided to install OpenWRT so I can run Wireguard on them

I tried with a box running EdgeOS 2 something and installed the short receipt image from stman's repository. The upgrade went fine. The problem is that I don't think Luci got installed as when I go to 192.168.1.1 there is no login screen. However, SSH to the same address does produce a login (I changed the root password already).

So I tried to install Luci and typed

opkg update
opkg install luci

Luci install fails as I get an error message that there is not enough space.

Using username "root".
root@192.168.1.1's password:


BusyBox v1.30.1 () built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 19.07-SNAPSHOT, r11072-af667c73c5
 -----------------------------------------------------
root@OpenWrt:~# opkg update
Downloading http://downloads.openwrt.org/releases/19.07-SNAPSHOT/targets/ramips/mt7621/packages/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_core
Downloading http://downloads.openwrt.org/releases/19.07-SNAPSHOT/targets/ramips/mt7621/packages/Packages.sig
Signature check passed.
Downloading http://downloads.openwrt.org/releases/19.07-SNAPSHOT/packages/mipsel_24kc/base/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_base
Downloading http://downloads.openwrt.org/releases/19.07-SNAPSHOT/packages/mipsel_24kc/base/Packages.sig
Signature check passed.
Downloading http://downloads.openwrt.org/releases/19.07-SNAPSHOT/packages/mipsel_24kc/luci/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_luci
Downloading http://downloads.openwrt.org/releases/19.07-SNAPSHOT/packages/mipsel_24kc/luci/Packages.sig
Signature check passed.
Downloading http://downloads.openwrt.org/releases/19.07-SNAPSHOT/packages/mipsel_24kc/packages/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_packages
Downloading http://downloads.openwrt.org/releases/19.07-SNAPSHOT/packages/mipsel_24kc/packages/Packages.sig
Signature check passed.
Downloading http://downloads.openwrt.org/releases/19.07-SNAPSHOT/packages/mipsel_24kc/routing/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_routing
Downloading http://downloads.openwrt.org/releases/19.07-SNAPSHOT/packages/mipsel_24kc/routing/Packages.sig
Signature check passed.
Downloading http://downloads.openwrt.org/releases/19.07-SNAPSHOT/packages/mipsel_24kc/telephony/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_telephony
Downloading http://downloads.openwrt.org/releases/19.07-SNAPSHOT/packages/mipsel_24kc/telephony/Packages.sig
Signature check passed.
root@OpenWrt:~# opkg install luci
Installing luci (git-21.018.57536-6ba9740-1) to root...
Collected errors:
 * verify_pkg_installable: Only have 0kb available on filesystem /overlay, pkg luci needs 1
 * opkg_install_cmd: Cannot install package luci.
root@OpenWrt:~#

So I am stuck here :frowning: I cannot logon to Luci and perform the upgrade to 19.07.6. Some help will be very much appreciated.

Try installing the upgrade from the command line. Download or transfer the upgrade file into the /tmp directory on the EdgeRouter. Then run the following command:

sysupgrade -v imagefilename

Where you replace imagefilename with the name of the downloaded upgrade file.

SCP + sysupgrade -v worked beautifully. Now happily running the full 10.07.6. Thank you everyone so much for this forum!!!

Hi all, just got an EdgeRouter X SFP - what's the best way to proceed? I understand from the above I shouldn't try to use this factory tar from OP since it's slightly different?

Oh yes please!

The best way to proceed is probably the link below, at least until OpenWrt 21.02 releases which will have a lot of improvements.

https://firmware-selector.openwrt.org/?version=19.07.7&target=ramips%2Fmt7621&id=ubnt-erx-sfp