OpenWrt won't install on Archer A7 (19.07.06)

Installing via the TP-Link update firmware web interface.
(TP-Link file: a7v5_us-up-ver1-1-2-P1[20210125-rel39623].bin)
Starts normally, but fails after about 10 seconds w/ "Invalid File format" error.
Renaming the OpenWrt file doesn't work.
I tried to downgrade the TP-Link firmware to earlier versions and they fail with the same "Invalid File Format" error.
Reinstalling the newest file works fine.
Would using TFTP installation get around this?
(I'm not that confident w/ that method.)

Helped a buddy of mine with his A7 recently, it also would not take any OpenWrt factory file, renamed or not from WebUI, we've had to use TFTP.

Well, I was afraid of that. :neutral_face:
The router is quite difficult to get to, and is in use for school for most of the day.
I was hoping for a "change this value" answer. :wink:
Looks like a late night project.
Thanks very much!
Marking this solved.

The flashing was a success.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.