OpenWrt with Rpi Cm4 on Dual LAN board

Wondering if anyone can help, I bought this board and a Raspberry pi CM4 from Amazon to build a home router but the OpenWrt images from the Waveshare site do not work, they are unpingable from the IP address's (192.168.14.1 or 192.168.1.1).
I tried a multitude of options with and without DHCP but nothing was pingable and I was never allocated an IP.

I would also prefer an image direct from openwrt.org but I think compiling my own is beyond me.

However the stock CM4 image from openwrt.org does work but the second USB RTL8153 built in adaptor is not available when I try to add another connection (for the WAN).

Ideally it would be great if anyone could send me a link to a working image with the drivers pre-installed or some method of adding them to an OpenWRT router without internet.

can't ping from 192.168.1.1, that's the default openwrt lan side IP.

are both seen by lsusb ?

Thanks for your rapid reply.

I have given up on the Waveshare supplied images so not worried about the ping issue. With stock OpenWrt I can access vis ssh and Luci no problem, just no USB. I do have

dtoverlay=dwc2,dr_mode=host

in config.txt in the boot sector.

Once I log in via SSH and try to "lsusb" I get this result;

BusyBox v1.36.1 (2023-10-09 21:45:35 UTC) built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 23.05.0, r23497-6637af95aa
 -----------------------------------------------------
root@OpenWrt:~# lsusb
-ash: lsusb: not found

need to install the usbutils package, to get lsusb.

It seems I do not have "usbutils" and cannot download and install them as I cannot access the network without the USB. I may now try to change the Router IP to something other than 192.168.1.1 (as this is my existing home router IP), turn off DHCP and connect to the internet via LAN to download the packages.

1 Like

Now a further barrier;

Unable to execute opkg update command: PermissionError: Exec permission denied

It appears even though I am logged in as user "root" I do not have permissions either via Luci or ssh. This is somewhat tedious at this point.

OK, managed to install usbutils, I hadn't set a DNS server and it wasn't using the gateway's suggestion.
lsusb gives ;

Bus 002 Device 002: ID 0bda:8153 Realtek USB 10/100/1000 LAN
Bus 002 Device 001: ID 1d6b:0003 Linux 5.15.134 xhci-hcd xHCI Host Controller
Bus 001 Device 002: ID 2109:3431  USB2.0 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux 5.15.134 xhci-hcd xHCI Host Controller

Still no "device" available to create a new interface

Thanks frolic, discovered the issue, just needed to "update lists" again and then install kmod-usb-net-rtl8152. Now the adaptor is available, thanks for all your help, let the fun commence !

Great,

Then they weren't identical, the two USB NICs ?

No, sorry, perhaps I wasn't clear, eth0 was the inbuilt CM4 network adaptor and eth1 was a USB LAN adaptor built into the board.

Heh, then the 1st reply I made, then changed, was the correct one :slight_smile:

Once again, thanks for your help !