[OpenWrt Wiki] Use Build System Page needs adjustment!

Under Building Images you have the following

Skipping failed packages
IGNORE_ERRORS=1 make <make options>

I have been trying to compile for days and always getting failed errors so did a make -h it would seem the ignore error switch has changed to:

Skipping failed packages
make -i  <make options>

Might be worth if this is only effecting Snapshots (which i am using currently) to add this in as a note or if its globally changed maybe adjust the page to reflect this.

1 Like

Everyone's free to register an account on the wiki (you can even use your GitHub one if you don't like creating a new one) and add or correct pages.

That being said, some actual error output would be handy to asses your statements - so both output with IGNORE_ERRORS=1 make and make -i.


I don't want to mess the page up.

The errors i was getting below this was with the IGNORE_ERRORS=1 and IGNORE_ERRORS=m

However after checking the make -h manual and changing it to make -i <make options> it completed the compile.

Before my script used to be

IGNORE_ERRORS=1 make -j$(($(nproc)+1)) V=sc ; echo -e '\a'


IGNORE_ERRORS=1 make -j$(($(nproc)+1)) V=sc ; echo -e '\a'

Both didn't work showing the same error in the picture

however changing it to

make -i -j$(($(nproc)+1)) V=sc ; echo -e '\a'

It compiled without issue and not stopping on errors.

Please copy/paste your error, screenshots aren't searchable and they have no added value when it's only text.

The errors you are getting are about conflicting packages, while the wiki instructions you are referring to relate to ignoring packages breaking during compilation. The packages themselves just built fine, but they are fighting over identical files, when you read more closely. There's nothing wrong with the instructions on the wiki.


Sorry about that, i took the screenshot when i was erroring out so i could make .config changes if make -h didn't come up trumps, then i made the change to my command line and it no longer showed errors as its getting ignored properly with the correct command switch.

However once i have finished the current compile set i will re-run the compile with the IGNORE_ERRORS=1 flag again and log it to a log file for you.

Basically it would seem that the IGNORE_ERRORS= flag is no longer working with make to ignore errors however make -i works for that sole purpose.

Edit: Yes i know its a conflict of packages and they was built correctly however the IGNORE_ERROR's flag used to simply ignore that error, which it seems it no longer does unless you use make -i.

I simply thought i would mention it just incase others are having the same issue and spending days trying to get OpenWRT to compile when adjustment to the command is all that was required.

It's working as intended, it's just not what you seem to think it is. The errors you're seeing are at the firmware assembly stage, not the package compilation stage.


Ok, just thought i'd mention it.

Just strange that both switches are meant for the same job yet one seems not to work (As i used to compile with the IGNORE_ERROR's flag before) which continued to make it passed the assembly stage, but all of a sudden stop working like that and requires make -i to be used instead to do the same thing.

I got that same libustream error when compiling, found out the RPi4 Im building for picks wolfssl automatically, but when I added the luci-app I picked openssl so got that error as it's trying to make the same file twice... Instead of trying to ignore the error, find the cause and remove the duplicate.

I compile all packages on my build as I share with others that's the reason why I have the error. But thanks for your input.

I've updated the paragraph as this option might be useful in the context.
The combination of both should be possible as well.
Further edits are welcome if someone can clarify the info.

1 Like

I can try both commands on my next compile and will let you know of the outcome.

Thanks for updating Wiki.

1 Like


ran a new compile with IGNORE_ERRORS=1 make -i without issues.
So it could be put in as if your planning to compile all packages use


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.