OpenWrt & WHS 2011

Recently had my Tomato based router die and had an Archer C7 v2 sitting in my closet that I had flashed to v19.07.2 just to play with. I have it setup and running as my dhcp server and internet access with no issues. I also have PiHole running on Raspberry Pi for DNS and adblocking as well. My issue is I have a server running WHS 2011 and had it setup for remote access via provided by MS, with my Tomato router, WHS just configured it and it worked.

I am having no success in getting this to setup with OpenWrt. One error was UPnP was not enabled and I found a thread regarding installing miniupnpd which I was able to do. Not being familiar with this software, I am not sure what next step should be. Could someone point me in the right direction, or tell me if it is even possible to do this? I am thinking I may need some type of DDNS to make it work as well.

I have been pleasantly surprised with the improvement in 5GHz connectivity with this unit over my old router and would like to continue using it if I can get my server back online.


I have used WHS 2011 in the past but long moved onto Server 2016 Essentials but hopefully can advise.

I always got uPnP warnings from WHS 2011 on DD-WRT before moving to OpenWrt but by then changed to Windows Server 2012 R2 Essentials and then 2016. For OpenWrt I don't even think uPnP is enabled by default and requires installation of additional packages not in the base firmware image. You don't need uPnP though, you can open the ports manually. For IPv4 you'll need a NAT rule and for IPv6 (if you have it) an allow rule in the firewall.

I've seen some posts in the past with issues with the domain service, it might still be operational despite WHS 2011 being no longer supported, but you'd have to confirm. However, you'll need to allow communication with port 80 and 443 before the homeserver.domain can update the DNS record pointing to your external IP.

I think the main issue is the fact previous router may have automatically configured port forwarding for you, where as here you will need to add the required NAT rule yourself. For security you really shouldn't use uPnP though anyway. However if you want to enable uPnP, here's some info: