OpenWrt usb extended flash memory stopped working after 5-7 reboots

Sagecom FAST2704N (openwrt 19.07.3-8)
i tried on few firmware and use 2 diffrent flash drive and use ex4 FS
opkg install block-mount kmod-usb-core kmod-usb2 kmod-usb-ohci kmod-usb-storage kmod-fs-ext4 blkid
after setting up that usb like swap and overlay evrything works fine i succesfully installed Asterisk and it worked
after few reboot the additional overlay dissapers
i reinstall evrything at least 5 times the result is the same!
at the end i took FAST2704V2 wich is diffrent model and everything works fine alredy rebooted 10 times
what can it be ? have you heard about this problem?

Try to enable check_fs and specify delay_root:


i tried again

config 'global'
	option	anon_swap	'0'
	option	anon_mount	'0'
	option	auto_swap	'1'
	option	auto_mount	'1'
	option	delay_root	'22'
	option	check_fs	'1'

config 'mount'
	option	target	'/overlay'
	option	uuid	'5ace2d8b-700b-434b-ad38-9c375022b466'
	option	enabled	'1'

config 'swap'
	option	uuid	'c0b734d8-8d10-482c-8866-c1923e64b266'
	option	enabled	'1'

config 'mount'
	option	target	'/mnt/sda3'
	option	uuid	'c0740533-2889-4559-bb3f-1af864183d4d'
	option	enabled	'1'

delay_root was 5 i made it 22
the same 2 times rebooted normaly after i installed asterisk i see only 3 Megabites in my storage insted of 64

after reboot i try to mount the overlay partition and i get this

 mount /dev/sda2 /mnt/sda2
mount: mounting /dev/sda2 on /mnt/sda2 failed: I/O error

1 Like

Package e2fsprogs must be installed in order for check_fs to work on an ext4 filesystem. The back-end binary is fsck.ext4

Does the drive work properly on a desktop Linux? I/O Error usually means failure to communicate on the USB bus, or an unrecoverable error in the flash media.

Don't unplug the power to reboot, use the reboot command.

[  442.009124] JBD2: Invalid checksum recovering block 8629 in log
[  442.037973] JBD2: Invalid checksum recovering block 401 in log
[  443.462018] JBD2: recovery failed
[  443.465514] EXT4-fs (sda2): error loading journal
[  494.547592] JBD2: Invalid checksum recovering block 8629 in log
[  494.577011] JBD2: Invalid checksum recovering block 401 in log
[  494.673835] JBD2: recovery failed
[  494.677324] EXT4-fs (sda2): error loading journal

I have installed e2fsprogs f2fsck
but i didnt find fsck.ext4 in opkg there were others but no for ext4 (openwrt19.7)
ive notice strange behavior:
Afrter first boot with new disc attched evrythig fine !but if i check blkid /dev/sda2 (this partition attached to overlay) it has diffrent uid not like it was before first boot

So at the end the result in the table , 3 router and 3 flash drives (FD)


FD            Router 1    Router 2     Router 3

fd1.            V            X              X  
fd2.            V            V              X
fd3.            V            V              X

V - works stable
X - few reboots and it brakes

So nothing helped me and I decided to change power supply got 2A 12V and it actually worked , the USB hard drive works stabl but speed is not stable when write , reading is good , next I changed the hard drive from Hitachi 500 G 5V 1A to WD 500 G 5V 0.44A and now it is perfect

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.