OpenWrt unable to set PPPoE MTU tag

Hello

I have been trying to increase the PPPOE MTU for my OpenWRT 21.02.1
I am able to manually set the MTU in openwrt side (using ip link set dev eth1.835 mtu 1540) but not for the
dynamically created pppoe-wan interface (still at 1492)

What prevents me to successfully establish a session with MTU > 1500 is that the PADI
packets (regardless of my setting) send by OpenWrt. They include the tag PPP-Max-Payload = 1500
The network provider in my case needs this value to be > 1500 otherwise reverts back to 1500 for PPPoE and 1492 for PPP MTU.

Has anyone been successful in modifying the value of PPP-Max-Payload sent during PADI request ?

I have been experimenting with different config MTU values but always using tcpdump I see that the PPP-Max-Payload value sent in PADI is 1500

My config is very basic

config interface 'wan'
        option ifname 'eth1.835'
        option proto 'pppoe'
        option username 'xxxxx@y.y.y.y.com'
        option password 'pass'
        option keepalive '10 30'
        option mtu 1540

The result is:

eth1.835  Link encap:Ethernet  HWaddr 0C:6A:F7:63:00:01  
          inet6 addr: fe80::e6a:f7ff:fe63:1/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1540  Metric:1
          RX packets:16 errors:0 dropped:0 overruns:0 frame:0
          TX packets:27 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1059 (1.0 KiB)  TX bytes:2155 (2.1 KiB)

pppoe-wan Link encap:Point-to-Point Protocol  
          inet addr:10.0.123.51  P-t-P:85.100.125.103  Mask:255.255.255.255
          inet6 addr: fe80::d4c9:a310:76f8:9e1e/128 Scope:Link
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
          RX packets:8 errors:0 dropped:0 overruns:0 frame:0
          TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3 
          RX bytes:563 (563.0 B)  TX bytes:718 (718.0 B)

Thak you all

The ISP must also support this. Anyway this works for me on Globe Fiber (GPON, with their modem in bridge mode) in the Philippines with OpenWRT 22.03.0-rc6 on a Linksys E8450.

EDIT: sorry, I misread the request. You are asking for MTU 1532 (pppd automatically subtracts 8 from what's set in the UCI config), not 1500 - which is indeed a strange configuration, likely a misunderstanding.

Configuration:

config interface 'wan'
	option proto 'pppoe'
	option username 'xxxxxxxx@visayas.globelines.com.ph'
	option password 'xxxxxxxx'
	option peerdns '0'
	list dns '8.8.8.8'
	list dns '8.8.4.4'
	option metric '80'
	option mtu '1508'
	option ipv6 'auto'
	option device '@modem'

config interface 'modem'
	option proto 'static'
	option ipaddr '192.168.254.2'
	option netmask '255.255.255.0'
	option defaultroute '0'
	option delegate '0'
	option device 'wan'
	option mtu '1508'

Interface MTU and addresses:

# ip a
...
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1512 qdisc fq_codel state UP group default qlen 1000
    link/ether xx:xx:xx:xx:xx:xx brd ff:ff:ff:ff:ff:ff
    inet6 fe80::xxxx:xxxx:xxxx:xxxx/64 scope link 
       valid_lft forever preferred_lft forever
...
7: wan@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1508 qdisc noqueue state UP group default qlen 1000
    link/ether xx:xx:xx:xx:xx:xx brd ff:ff:ff:ff:ff:ff
    inet 192.168.254.2/24 brd 192.168.254.255 scope global wan
       valid_lft forever preferred_lft forever
    inet6 fe80::xxxx:xxxx:xxxx:xxxx/64 scope link 
       valid_lft forever preferred_lft forever
...
105: pppoe-wan: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UNKNOWN group default qlen 3
    link/ppp 
    inet 10.40.xxx.xxx peer 10.205.78.123/32 scope global pppoe-wan
       valid_lft forever preferred_lft forever
    inet6 2001:fd8:xxxx:xx:xxxx:xxxx:xxxx:xxxx/64 scope global dynamic noprefixroute 
       valid_lft 2591998sec preferred_lft 604798sec
    inet6 fe80::xxxx:xxxx:xxxx:xxxx peer fe80::xxxx:xxxx:xxxx:xxxx/128 scope link 
       valid_lft forever preferred_lft forever

Yes it took several auto-retries to connect:

Tue Aug 30 13:45:46 2022 daemon.notice pppd[30310]: pppd 2.4.9 started by root, uid 0
Tue Aug 30 13:45:46 2022 daemon.debug pppd[30310]: Send PPPOE Discovery V1T1 PADI session 0x0 length 18
Tue Aug 30 13:45:46 2022 daemon.debug pppd[30310]:  dst ff:ff:ff:ff:ff:ff  src xx:xx:xx:xx:xx:xx
Tue Aug 30 13:45:46 2022 daemon.debug pppd[30310]:  [service-name] [host-uniq  66 76 00 00] [PPP-max-payload  05 dc]
Tue Aug 30 13:45:50 2022 daemon.debug pppd[30310]: Recv PPPOE Discovery V1T1 PADT session 0x2167 length 0
Tue Aug 30 13:45:50 2022 daemon.debug pppd[30310]:  dst xx:xx:xx:xx:xx:xx  src xx:xx:xx:xx:xx:xx
Tue Aug 30 13:45:50 2022 daemon.debug pppd[30310]:
Tue Aug 30 13:45:51 2022 daemon.debug pppd[30310]: Send PPPOE Discovery V1T1 PADI session 0x0 length 18
Tue Aug 30 13:45:51 2022 daemon.debug pppd[30310]:  dst ff:ff:ff:ff:ff:ff  src xx:xx:xx:xx:xx:xx
Tue Aug 30 13:45:51 2022 daemon.debug pppd[30310]:  [service-name] [host-uniq  66 76 00 00] [PPP-max-payload  05 dc]
Tue Aug 30 13:45:52 2022 daemon.debug pppd[30310]: Recv PPPOE Discovery V1T1 PADO session 0x0 length 67
Tue Aug 30 13:45:52 2022 daemon.debug pppd[30310]:  dst xx:xx:xx:xx:xx:xx  src xx:xx:xx:xx:xx:xx
Tue Aug 30 13:45:52 2022 daemon.debug pppd[30310]:  [AC-name LHG_BNG-002] [host-uniq  66 76 00 00] [PPP-max-payload  05 dc] [service-name globelines] [service-name] [AC-cookie  c9 99 76 dd 03 15 54 21 59 07 7d 7b 30 44 b8 b5]
Tue Aug 30 13:45:52 2022 daemon.debug pppd[30310]: Send PPPOE Discovery V1T1 PADR session 0x0 length 38
Tue Aug 30 13:45:52 2022 daemon.debug pppd[30310]:  dst xx:xx:xx:xx:xx:xx  src xx:xx:xx:xx:xx:xx
Tue Aug 30 13:45:52 2022 daemon.debug pppd[30310]:  [service-name] [host-uniq  66 76 00 00] [PPP-max-payload  05 dc] [AC-cookie  c9 99 76 dd 03 15 54 21 59 07 7d 7b 30 44 b8 b5]
Tue Aug 30 13:45:52 2022 daemon.debug pppd[30310]: Recv PPPOE Discovery V1T1 PADS session 0x3fa length 53
Tue Aug 30 13:45:52 2022 daemon.debug pppd[30310]:  dst xx:xx:xx:xx:xx:xx  src xx:xx:xx:xx:xx:xx
Tue Aug 30 13:45:52 2022 daemon.debug pppd[30310]:  [service-name] [host-uniq  66 76 00 00] [PPP-max-payload  05 dc] [AC-name LHG_BNG-002] [AC-cookie  c9 99 76 dd 03 15 54 21 59 07 7d 7b 30 44 b8 b5]
Tue Aug 30 13:45:52 2022 daemon.debug pppd[30310]: PADS: Service-Name: ''
Tue Aug 30 13:45:52 2022 daemon.info pppd[30310]: PPP session is 1018
Tue Aug 30 13:45:52 2022 daemon.warn pppd[30310]: Connected to xx:xx:xx:xx:xx:xx via interface wan