OpenWrt UI Change has led to bricked device


I am trying to follow this tutorial here to configure my device (TP-Link Archer A7 V5) as a Wi-Fi repeater/extender. However, at 7:56 the video creator instructs to go to LAN > Edit > Physical Settings and to uncheck the "Bridge Interfaces" option. This video tutorial was created on LuCI version 19 something and I am running the current latest version (21 something) and thus of course there is no longer a Physical Settings tab. This is confirmed here. Another user was similarly confused about the missing Physical Settings tab in this post here and wrote that instead they would go to the new LuCI > Network > Interfaces > Devices area and simply uncheck the corresponding LAN device. I did this and now I can no longer access my router. Apparently there is an auto-roll-back feature but I wasn't aware of this and have already rebooted my router several times. I've tried entering FailSafe mode and the light blinks rapidly like it normally does when I've entered FailSafe mode before but I still cannot access the router interface via LuCI nor via SSH. Have I bricked my router? I don't have a serial cable. How can I access my router/reset it to default? And what is the correct procedure that would be equivalent to unchecking the "Bridge Interfaces" on the no longer existing Physical Settings tab that would allow me to continue forward with this tutorial and would not lock me out of my router?

In failsafe mode the device should revert to Have you tried connecting your client to it directly? If it's still part of your network you might have conflicts with your main router also listening on

Thanks for replying :slight_smile:

I do believe the router is successfully in FailSafe mode (I held down the reset button during boot-up and the power LED is the only light on and is rapidly blinking). I tried to access via LAN on each ethernet port one by one but it times out. I also tried manually setting my computer's IP address to the static address of and then again tried connecting via the ethernet port but it just times out :frowning:

I also tried turning off the Windows 10 firewall just to be safe but it still won't connect.

Try setting your client to or something, anything but .1.

No luck :frowning:

I tried flashing the firmware again via TFTP using this guide and it showed the file was successfully transferred but now the router is literally "boot-looping" over and over again about once every 8 seconds or so :frowning: Ugh.

That sucks. The serial header isn't soldered but if you get male pin headers to wedge into the holes (you can bend the lower ends then push down the plastic to jam them against the board), you don't need to solder. You will need serial though to get it going again probably (and you'll be able to see what exactly is going wrong as well).

See the holes on the bottom right. Serial pinout is documented (see wiki page).

Thank you very much for this info - I'll definitely hold on to it!
In good news, I was able to TFTP-flash the stock TP-link firmware and then from there was able to re-flash OpenWRT once again :heavy_check_mark::raised_hands:t2:

Now I just have to figure out how to finish the tutorial in my OP that was made for an older version of LuCI firmware. I'm supposed to uncheck the "Bridge Interfaces" option from the "Physical Settings" tab but that tab no longer exists.

1 Like

I'd recommend following the OpenWrt wiki over some video someone put online at some point. As you found out the hard way that video is outdated and the wiki has more chance to be up to date. People often don't bother updating videos...

Thanks! I started there though several weeks ago and have been trying for some time and have gotten nowhere :-/

Unfortunately the information on the wiki where I had been looking also seemed to be out of date/stated the information provided was not the preferred and current way to do it but then didn't provide an updated link or method :frowning:

The wiki page that you have linked to seems to be more in line with what I am trying to accomplish however it seems like the setup described here requires multiple OpenWrt devices and that is not something I can make happen as I only have one flashable router available. I have my stock ISP-provided garbage fiber-optic modem/router combo "gateway" device (ARRIS BGW210-700, AT&T) and I am trying to use one available OpenWrt-flashed TP-Link Archer A7 v5 router as a repeater/relay device. This wiki article instructs me to edit the "/etc/config/wireless" file of my access point but I doubt the AT&T device even has the same file structure and of course I have no way to directly edit files saved on the internal storage of my stock-AT&T router :-/

Edit: This looks to be more like what I'm trying to accomplish... I'll give this a go. Thanks again!!

Unfortunately though, it still seems I'm facing the same/a similar challenge in that the syntax provided in the wiki is out of date and has changed in the current/newer OpenWrt release. :frowning:

I think relayd might be a better option, the link I gave only works if both devices use the same wireless stack and (more or less) FOSS drivers - ie ath9k, ath10k, mt76, ... those are the ones you'd need on both ends to make it work.

If you have a spare device that you can flash with OpenWrt, it would be better to put that behind your ISP hardware to act as a wireless bridge with your A7 v5.

1 Like

Thanks! The only other spare device I have is ancient/garbage and I don't think it's even capable of running OpenWrt, lol.
I do have two AirTies mesh Wi-Fi extenders however they belong to AT&T/have been locked to only work with the AT&T router/gateway and cannot be used with any other device. Someone attempted to unlock/flash one here but didn't get very far.

Edit: I do also have a second Arris BGW210-700 gateway/router from AT&T that I was supposed to have returned like over 2 years ago or supposedly would receive an invoice for $250 on my bill at some point but then a tornado permanently destroyed the UPS Store where I was supposed to have dropped off the router to send it back to AT&T and I've just never gotten around to coordinating sending it back to them/they've never charged me for it lol. I don't think the device would be useful anyway as I'm pretty sure it's totally locked to AT&T and can't easily be flashed.