OpenWrt support for Xiaomi AX9000

I also have to replace the .bin otherwise it didn't work (radio3 on ax9000)

Have one new problem:

Problem disassociated Wifi AX9000 / AX3600 802.11R use

Wi-Fi disconnections, and constantly this warning/error in the openwrt log:

Tue Apr 16 08:55:44 2024 daemon.notice hostapd: phy2-ap0: AP-STA-DISCONNECTED
Tue Apr 16 08:55:44 2024 daemon.info hostapd: phy2-ap0: STA IEEE 802.11: disassociated
Tue Apr 16 08:55:45 2024 daemon.info hostapd: phy2-ap0: STA IEEE 802.11: deauthenticated due to inactivity (timer

It causes all my devices to constantly disconnect and connect (I have smart plugs, echo, firetv, etc...) and they constantly lose connection

Hello everyone, ax9000 international version, firmware 3.0.40
i managed to get telnet password and also enabled ssh.
I have usb serial adapter 1.8v but can't stop the boot process no matter what i type.
uart_en is set to 1
i soldered and resoldered the pins to be sure already 3 times, the rx is working, also i looped tx into rx in the usb adapted to check cables and it echoes, so it must be the router ignoring uart_en
Given the ssh access, can i still flash openwrt without uart?

If you have access to ssh, you could flash from there...

Unfortunately it still doesn't work, from SSH i've been able to ubiformat only one of the two rootfs as the other was in use for the system, and then at reboot the system hangs.
in nvram i've set ATF to 1, but if i try to boot via tftp a "non ufficial" firmware it stops, the 3.0.40 international instead go through every time (i managed to unbrick already a few times).
What can i try to do to unlock the uart tx?

had the same problem, from SSH (original firmware) I issued as instructed:

nvram set uart_en=1
nvram set boot_wait=on
nvram commit

if it not works - resolder cables maybe ?

Morning !

My AX9000 Chinese version just arrived and got already up and running with OWRT, thanks to the Wiki !

I'm trying to set up wifi radios in a proper way, but didnt find any thread or guide specific nor with an ideal config, just the BDF workaround that already installed

I'm sharing my actual config, since (I think) I'm getting pretty nice results:

Is there a thread for the fan driver I can start with ?

I finally managed to install openwrt, i think it was the component labeled r78 but my soldering skills, and my eyes, are less then optimal so i managed to blunder and remove the little fella and his neighbour...
at this point i said to myself f**k it and bridged straight from the uart pin and luckily it finally worked

thanks everyone for the work done

Well.... I'm happy that it works now for you :slight_smile:

Hi! After looking through the topic, I realized that there were difficulties with the BDF file, but they were solved and now all the radios are working? I'm from the RAX120 branch and now either all the radios are not working, or there is no 160 HT, or the signal is very low. We are trying cal files from different routers, if anyone has the opportunity to post the cal-ahb-c000000.wifi file, it would be very helpful. It is located in lib/firmware/ath11k/IPQ8074/hw2.0

This is the cal file that gets generated for me. I am using this BDF file for the 160MHz on radio3.

Hello,
I am having an issue with continuous reboot in loop after flashing the AX9000 (international version) using UART flashing method. So right now, after doing sysupgrade of squashfs-sysupgrade.bin it reboots and continuously prompts for UART stop. Every time it loads into not a OpenWrt firmware.

Edit:
I haven't noticed it in comments before. Running the command below before the sysupgrade helped. Should we add this into documentation?

fw_setenv atf 1