OpenWrt support for Xiaomi AX9000

I don't have one of those PCBs, but I guess it's outputting 3.3V.
Datasheet says TTL level is what you input in Vccio pin:

Indeed, I just measured the voltage and its 3.3V.
Funny how its been working just fine on like 5+ boards

Only had a 3.3V UART too and I used This circuit, though had to modify it, on the first picture I skipped R4 because the router didn't receive any input.

The output voltage was around 3.2V, but it was working, though its not too good, be careful with it!

@robimarko I think the resistors on the board do enough limiting maybe

I have been waiting my uart from ali for almost three weeks. Yesterday I ordered this (5, 3.3, 1.8):

https://www.amazon.de/dp/B07WX2DSVB/ref=pe_27091401_487024491_TE_item

Expected delivery this week friday.

1 Like

If we remove the jumpers and connect Vccio to the board, we get 1.8V TTL level?

Connect Vccio to where?

In the datasheet schematic, remove the jumper, then you need to use a 1.8V LDO to supply 1.8V to vccio. LDO will get input voltage from 5V USB Vcc. It's all described in the FT232RL datasheet.

Also it's never guaranteed that the PCB you have will exactly implement the schematic we see in the datasheet.

I mean connecting the Vccio of the converter with the Vcc of the router's UART port: https://openwrt.org/inbox/toh/xiaomi/ax9000#how_to_connect_to_the_serial_port_uart
Is the Vcc output of the UART port 1.8V?

VccIO name implies it's the FT232R IO circuit power supply.
I don't know how much current it uses, don't know if the datasheet specifies, I only looked at the schematic to find where it was getting the 3.3V (it's a internal LDO).

More important I don't know how much current the router Vcc pin can supply, if there's any protection, so there's a real risk we can burn it.

In this case, as we are in the same boots, I will wait for your response, I don't want to risk frying my board with 3.3v...
My ax3600 serves the purpose beautifully, I am in no rush :slight_smile:

It happened to me the on the first attempt as well.
Was able to recover it using using the TFTP recovery method and the official image.
Enabled again SSH and re-tried flashing OpenWRT and this time it worked as a charm :slight_smile:

I tried around 8 times, with different builds and version.
The same behavior all the time, as described above :confused:

Chinese or International version ?

Have you tried the miwifi recovery tool. That way you can get back to stock then start all over again? I've bricked this router a few times and I just use that tool to start all over again. I was just running Robi's build for example and upgraded to the snapshot and something didn't play nice and caused the router to not boot.

the AX10g is out

sports a IPQ9574 + QCN9224
Qualcomm quad core A73 2.2GHz
2GB memory

incredibly about the same price as the ax9000

A bit ridiculous without 6 GHz support though (at that price point and with those hardware specs).

2 Likes

china doesn't allow 6ghz ... but the kit supports it ... it is using the new ath12k firmware

I'm aware of the Chinese regulatory aspects, but guesstimating from ath11k and its fun with internal regdb and secure boot, I wouldn't take that (ath12k's abilities) for granted.

you are right with the secure boot (got burned with that ...) ... however the ath12k has an externel regdb available

1 Like

And its about the worst device you can get to start working on IPQ9574 as you are gonna be going in blind, first needed to root the damn stock FW and then Xiaomi doesn't want to give GPLv2 sources etc

5 Likes

acwifi's teardown confirmed its amplifier/filiter doesn't support 6GHz, so forget about it

1 Like