OpenWrt support for Xiaomi AX9000

Well, quite simple, export them and modify to apply on backports.

This is not correct, 5.15.18 bacports are used and everything up to and including:
ath11k: add ath11k_qmi_free_resource() for recovery

Has been backported on top, so only the most recent stuff is missing, once I have time that will get backported as well.

The only way is to keep them as patches in the mac80211 package.

I was wondering if there is a way "to influence/request" releasing newer version of backports :slight_smile:

There is, do it yourself and send patches upstream or ping Hauke.
But note that he intentionally always tracks LTS kernels, next backports version should be 5.20 for the 5.15 based OpenWrt release.

1 Like

I can't seem to get the fan running on latest builds, am I to interact with i2c devices or will hwmon give me some information in sysfs? I dont seem to be having much luck either way

There is no driver for it currently, its one of the TODO things

PCI support is just being a pain, I cant get it to work and it used to work fine on its own


well keep up the good work, keep on seeing your name littered around the community, a lot of this stuff is real educational, hopefully i can figure out how to get the fan running
I thought that compiling the patch in to the kernel would help with getting the device to show in sysfs

1 Like

Please give the command to do this, I've just got an Chinese version manufactured in 2022.02.

Any joy with fixing PCI?

Nope, I am trying to upstream tsens and apss clocks so no time for anything else


I just want to say thanks, this is the best for the EU version, this should be added to the openwrt page tbh

I was able to get ssh access on the ax9000 but unlink the ax3600 I get just a "1" as output for:

# nvram get flag_boot_rootfs

So I'm not quite sure which partitions to flash .. Is there any other command to find out?

EDIT: Actually from what I read It seems we are still very far from having this in a state that it's at least as workable has AX3600, and I did get the EU version, so I think I'll keep it with stock for now, and follow this for updates, I got say you guys have a lot of patience, I just don't get how somehow can just make something based on OpenWRT and not share source, violate a license and all and simply get away with it....

One thing I liked about Asus routers is that the at lease make thing "easier" (some parts are still locked ofc) by sharing the source, and following GPL.

I can't even image the sweat and tears that have dropped to get this to where is for both 3600 and this one.

1 Like

hi Robimarko, I also get this error message.have made several attempts already, could't seem to get around this. Is there anything else you would suggest I try?

Whats the stock FW version?

version for miwifi system? was initially using 1.0.56, then changed it to 1.0.55 and then changed again to 1.0.41. But still returns "code":1643

Well, on 1.0.41 the exploit worked fine for me, I cannot say that I saw that error message

I noticed you have added support of AX9000 in github's code,may I ask can QCN9024 works? whitch means can 160mhz 4804Mbps works NOW?

No, it does not.
It was working as standalone but even that got broken

Am I right @robimarko that we have 2 main issues with ax9000?
a) Ath11k driver (QMI) currently does not supports multiple soc
b) Kernel changes broke PCI QCN9074 implementation (via ath11k driver)

Yeah, that sums it up.