OpenWrt support for Xiaomi AX9000

I have booted an initramfs image on an AX9000, compiled from the AX3600-5.10-restart branch. The uplink doesn't appear to work, the green led blinks every second on the 2.5G port but nothing comes back in.
The switch at the other end of the link reports only bad packets received, one for each DHCP request. I have checked the speed/duplex/... status at both ends they are the same.
May I have missed something in the configuration of the image ?

I know, after the last kernel update it happens to me as well but no time to debug it though.

FYI, with AX6 it works fine, so it is likely limited to the 2.5gig eth.

Haha thank you for the tip. I have forced the port to 100M/Full on the switch side and it works! At 1G it doesn't.

Interesting finding flebourse :slight_smile:
How do you find this router? (WiFi speed/range, memory leaks, etc.)
Please do share your observations :slight_smile:

I haven't much to say for the moment, I have used it very little. I have observed the same memory leak everyone is writing about. The wifi signal gives a very long range compared to the other devices I have.

Is there any unstable/betas you guys have made yet? I'm very interested in trying this out. As the stock firmware is extremely lacking. :crossed_fingers: I've used Openwrt on previous routers so it wouldn't be my first just usually stable builds

Got my AX9000 today. I tried the wiki method to obtain SSH, using AX3600 with QSDK-based Chinese "OpenWRT" with luci. Got a similar issue to the one @flebourse experienced. Finally, I gave up and attempted exploit OpenWrt support for Xiaomi AX9000 - #179 by bruda, and it worked like a charm.

I discovered we can use xqrepack to patch rootfs, we just need to append --data argument to ./, just as described in the for RM1800:

for RM1800:

 ./ ubifs-root/miwifi_rm1800_firmware.../...kernel.ubifs \
              ubifs-root/miwifi_rm1800_firmware.../ \

xqflash also works fine (I didn't attempt a manual upgrade, just scp'ed xqflash along with the patched image to router's /tmp).

Maybe this will be useful for someone :slight_smile:


Thanks for sharing!
Could you share your observations how this device is behaving - range, stability, performance, etc... More details the merrier :slight_smile:
I am seriously considering purchasing it, and your feedback could help me making a decision

You're welcome :slight_smile:
AX9000 performance with Xiaomi FW is actually off-topic here: the thread is about adding OpenWRT support for the device. That being said, I can't tell you much, since I'm using the router as a wired AP, until proper OpenWRT support. As for wifi performance, it's really good, but I haven't tested it at max power, I patched the firmware and manually set txpower to 26db. I only need it to cover one room properly, other rooms have their own wired APs (actually AX3600) connected to the main router.

Ok, so I finally had some time to rebase this mess onto master.
The 2.5G port is still not working in 1G mode, 100M works fine.

I quite literary have no idea what broke it.

1 Like

From ethtool eth4, 100M works fine but it is in half duplex the switch at the other end is set to 100Full but reports 100MF and link down! Go figure ...
Just after "bootm" the serial line says "Starting kernel ... Jumping to AARCH64 kernel via monitor" then nothing during ~25 seconds followed by the normal boot messages.
This 25 seconds delay doesn't occur when booting the xiaoqiang firmware. Is there something specific to set in the kernel serial parameters ? I suspect many boot messages to be missing.

Hmm, now it magically worked at 1G.

Something is seriously broken if you are seeing that delay, for me, UART works immediately.
You shouldn't need to set anything as the UART port is set as default in the DTS itself.

Switch set at 1000F, ethtool eth4 says 1000 Full but no answer from ping. As before the RxGoodPkt counter doesn't move the RxBadPkt counter increases.

I had that before, now it just magically works at 1000M full duplex


So maybe rebase did help?
Are there any outstanding important issues? Or this device should be OK to start initial/early tests with OpenWRT own compiled image?

1 Like

I have done a full rebuild using the rebase, the UART 25s delay has disappeared but the 1G magic didn't work for me still 100Half only from ethtool eth4. Some progress anyway, at least the switch now reports 100MF not Link Down ...

hello to all friends,
I'm buying on Spanish site the router AX9000, they tell me that it is the global version and not the Chinese one.
Do you know that there are 2 versions such as for the AX3600 model? for the latter I have personally seen that the Chinese version has no power limits while the global version is limited and difficult to unlock.
Thank you

And again :face_with_raised_eyebrow: This thread about OpenWRT on AX9000, not about your problem to choose which model should I buy!!! There are better threads/forums for that!

If you be so kind and use Google or whatever else, it was discussed so often!!! A lot of newbie one of the first question are this! And this not useful info here at all! Here are much higher level and you are not ready for that :wink: