OpenWrt support for Xiaomi AX9000

No secret agenda robi :slight_smile: No need to get that defensive :slight_smile:
As the Qualcomm driver doesn't currently work (allow us to get only 100M with full duplex at the moment) maybe the netdev community driver could be used instead, even if it would mean no SSDK nor NSS?

But its just the ethernet PHY driver, you need SSDK and NSS-DP for the switch and ethernet controller.
PHY doesn't do anything on its own

Thanks for the explanation :slight_smile: I was not aware of that :slight_smile:

Yes, both the switch and ethtool -S eth4 display increasing rx_fcserr counters. Either the clocks are not correct or the line encoding/decoding don't match. Strange, both ends are able to autoneg 1000 full ...

To me, it smells like a clock is missing or the serdes needs tuning.
Well, autoneg is up to the PHY and since its working fine it will autoneg without an issue

1 Like

Clearly offtopic here: the thread is about OpenWrt for Xiaomi AX9000, not patching Xiaomi crappy firmware to disable parts.


I found the 2 screws below the label. But it seems the case is still very stable. Is there a trick or a video how to open the case without demolition?


Yeah, don't forget them rubber feet. There should be like a dozen of screws in total.

I admit the video doesn't show that part too well.

There is a lot of screws hidden, I think there is 10 in total you need to take out.
There are high res photos here:

Yeah, 4 times (e.g. per rubber feet) 2 pieces plus the two behind the middle label.

Unfortunately, there doesn't really seem to be a nice picture showing that neither. But in the video at second 26 one can see the rubber feet glue with the two screw holes in the lower part of the footage.

Thank you all! I'll try this evening.

Opening the device worked fine. I used the exploit #179 and gained root.
I installed robimarko's branch and was surprised that 2.5GB WAN is working with 1GB and also 2.5GB. Also wifi comes up. :grinning:

1 Like

Just to clarify - all four wifi are up? (IoT, 2.4Ghz, 5Ghz & 5.8GHz)?
Also ... do you mind sharing memory usage after a few hours of typical use - is memory a problem after a few hours? (Infamous memory leak)

The QCN card isnt working, thats for sure

Yepp, QCN is missing. Was a bit too optimistic. As soon as I have more results, I will share.

1 Like

Has anyone tested this patch for ath11k specifically for the ax9000? Seems it possibly could also be applicable for the ax3600 etc?

I honestly have no idea what is that supposed to do at all.
Whoever sent it probably had no idea as well

Did you read what's in the patch?
It's just one of the ath11k optimization patch from QCA and they removed it.

Does it change anything that now we have kernel 5.15 backported?

Yeah, it helps a lot.
I can tell you that I am working on it, but its gonna take time and testing as I cant get the card to load the FW despite backporting QRTR changes to start the channels which worked before 5.15