OpenWrt support for Xiaomi AX3000T

Thanks for sharing that Remittor's version works.

It looks like that build was done in March 2024. Have you tried the latest SNAPSHOT sysupgrade.bin after applying Remittor's .ubi file?

Have you tried the latest SNAPSHOT sysupgrade.bin after applying Remittor's .ubi file?

Sorry, no.

try my build:
https://github.com/openwrt/openwrt/issues/15662#issuecomment-2156507790

Thanks for suggesting that.

I had some success with the ax3000t-snapshot-r26580-dd6bbbabd3-mediatek-filogic-xiaomi_mi-router-ax3000t-squashfs-sysupgrade.bin file.

Then I saw a video to try to update the uboot with hanwckf's web recovery. It applied correctly to the mtd4 (FIP) and I was able to boot into the recovery.

But for some reason I was not having much success flashing sysupdate.bin files. I tried uploading your initramfs-factory.ubi file through uboot, and it did update correctly. Reboot was successful, but when I tried to apply the sysupdate.bin file, I wasn't able to boot from it.

Fearing it was the uboot, I uploaded my backup FIP.bin partition through uboot.html. Now I have a steady orange light -> about 5-10 seconds of rapid blinking orange, then steady orange.

I probably soft-bricked it? I guess I'll have to try the tftp tonight.

each set of build , have different partition table assignment, please do not mix.

I think I'm learning it the hard way.

hanwckf's was supposed to support the default partition and I was using your normal (not uboot version), but I guess there is some incompatibility.

Not sure why I wasn't having much success with openwrt-snapshot builds either. Looks like there's a little bit of a learning curve here.

I use hanwckf's u-boot with openwrt-snapshot builds, but the latest github version is broken.

Thanks for sharing that.

I'm assuming you used the 20231124 release?

Messing around with the bootloader gives me palpitations.

Have you been successful with recent openwrt-snapshots (regular not the uboot-mod) with hanwckf's 20231124 uboot+webrecovery?

Just for the record, had success with hanwckf's 20231124 uboot + webrecovery as well as the 7/10/2024 openwrt snapshot. I added luci-ssl and luci-app-dawn but that was about it. Booted up appropriately!

EDIT: Okay, so it boots appropriately but I'm having some trouble with the wifi transmit power. So not quite perfect yet.

hi..
i installed openwrt in my router using XMiR-Patcher and upgraded to official snapshot.
after this i tried to change to OpenWrt U-Boot following the instruction from here https://github.com/openwrt/openwrt/pull/14054 . During the process after 4th step i.e Add recovery boot feature power cut happened and my router rebooted.
after reboot i was unable to access the router so i used xiaomi repair tool but after flashing with repair tool router doesnt boots, blue light keeps blinkin and blinking..
Please suggest me solution to this..

hi, where i could check why my ax3000t running snapshot r26812 crashes and reboot router from time to time?

It may relate to Low memory issues - #7 by kiraryu
This patch cause 256mb device crashes.
I try to reduce rx dma size a month ago and it is working just fine.

Some more wierdness:

On Luci, it says my TX power seems limited - on 2.4 ghz its 3 dBm. on 5 ghz its 5 dBm. They are supposed to be set to 15 dBm and have tried both higher and lower.

I have set it to US where I am located both in Luci and on command line:

iw reg set US

Strangely, my output of iw phy frequencies seem okay:

iw phy | grep -i  dBm
                        * 5180 MHz [36] (23.0 dBm)
                        * 5200 MHz [40] (23.0 dBm)
                        * 5220 MHz [44] (23.0 dBm)
                        * 5240 MHz [48] (23.0 dBm)
                        * 5260 MHz [52] (24.0 dBm) (radar detection)
                        * 5280 MHz [56] (24.0 dBm) (radar detection)
                        * 5300 MHz [60] (24.0 dBm) (radar detection)
                        * 5320 MHz [64] (24.0 dBm) (radar detection)
                        * 5500 MHz [100] (24.0 dBm) (radar detection)
                        * 5520 MHz [104] (24.0 dBm) (radar detection)
                        * 5540 MHz [108] (24.0 dBm) (radar detection)
                        * 5560 MHz [112] (24.0 dBm) (radar detection)
                        * 5580 MHz [116] (24.0 dBm) (radar detection)
                        * 5600 MHz [120] (24.0 dBm) (radar detection)
                        * 5620 MHz [124] (24.0 dBm) (radar detection)
                        * 5640 MHz [128] (24.0 dBm) (radar detection)
                        * 5660 MHz [132] (24.0 dBm) (radar detection)
                        * 5680 MHz [136] (24.0 dBm) (radar detection)
                        * 5700 MHz [140] (24.0 dBm) (radar detection)
                        * 5720 MHz [144] (24.0 dBm) (radar detection)
                        * 5745 MHz [149] (28.0 dBm)
                        * 5765 MHz [153] (28.0 dBm)
                        * 5785 MHz [157] (28.0 dBm)
                        * 5805 MHz [161] (28.0 dBm)
                        * 5825 MHz [165] (28.0 dBm)
                        * 5845 MHz [169] (27.0 dBm) (no IR)
                        * 5865 MHz [173] (27.0 dBm) (no IR)
                        * 5885 MHz [177] (27.0 dBm) (no IR)
                        * 2412 MHz [1] (26.0 dBm)
                        * 2417 MHz [2] (26.0 dBm)
                        * 2422 MHz [3] (26.0 dBm)
                        * 2427 MHz [4] (26.0 dBm)
                        * 2432 MHz [5] (26.0 dBm)
                        * 2437 MHz [6] (26.0 dBm)
                        * 2442 MHz [7] (26.0 dBm)
                        * 2447 MHz [8] (26.0 dBm)
                        * 2452 MHz [9] (26.0 dBm)
                        * 2457 MHz [10] (26.0 dBm)
                        * 2462 MHz [11] (26.0 dBm)

This sort of reminds me of the a different router I had were OpenWrt was unable to access the calibration data. Anyone here encounter this yet?

Using hanwckf's 20231124 uboot + webrecovery. Tried both RadioOperator's firmware as well as yesterday's OpenWrt-Snapshot (with luci-ssl added through firmware selector)

When xiaomi tool finish flashing the router will blink fast forever, just remove power and repower, it will boot up fine again

1 Like

try the immortal files, i wasted two days of my life with the broken daily builds...

Thank you for the suggestion. Can confirm the wifi tx limit to 3 dBm and 5 dBm is a software issue - when I reset to default OpenWRT settings, the TX power was back to normal.

How is immortalWRT different from OpenWrt-Snapshots?

It is like a private build, as far as I can see.
If you trust them- you will be fine.
However, they contribute a lot to the official OpenWrt builds and the community.
As far as I can tell, is mainly focused on China users, as it contains packages which are usefull for China out of the box if you install their builds.
Kr
PS: I strongly suggest to stick to the wiki when going to OpenWrt. These are the official steps and you may get proper help in the forum.

it worked.
Thankyou very much.

i went back to older kernel 5.x and it is more stable + has much more free ram available. no self reboots in the middle of the day.

The openwrt v23.05.4 pre-release, already be ready to use:
https://downloads.openwrt.org/releases/23.05.4/targets/mediatek/filogic/