OpenWrt support for WAX206

wpad-mbedtls, wpad-openssl and wpad-wolfssl are a superset of wpad (full). Ie. all features present in wpad (full) are also present in the variants which are built against a crypto library.
The wpad-basic-{mbedtls,openssl,wolfssl} variants do not have all features.
The wpad-{mbedtls,openssl,wolfssl} variants do.

1 Like

The DAWN guide gave the instruction to install wpad (full).

But after some searching I found where I read about the 'other' packages which are supposed to work okay: https://github.com/berlin-open-wireless-lab/DAWN

Thank you @daniel , that gave me the confirmation on what I already suspected but was unable to verify earlier.

I just tried to build a new image with wpad-openssl to see if that would suffice to have both DAWN and WPA3 work as intended. The image build did not fail on a package dependancy, so that's something already. I will report back once I have flashed and tested it.

Rebuilt the image with wpad-openssl on both the WAX206 and the EX6120.

According to the guide, in 21.xx there is an issue with the umdns config. Though the snapshot build for the WAX206 does not have an issue with that particular config, umdns in 22.xx on the EX6120 does. The config file does not differ in any way... :man_shrugging:

After moving that away on the EX6120 and restarting umdns and dawn services, DAWN started to work again after I had enabled WPA3 on my SSID's.

Everytime I try to compile a master for the WAX206 I get this error, anyone know what is it?

 make[3] -C package/libs/openssl compile
    ERROR: package/libs/openssl failed to build.
a53_musl/packages/gdbm.list && cp -fpR /home/opc/wax206/openwrt/tmp/stage-gdbm/* /home/opc/wax206/openwrt/staging_dir/target-aarch64_cortex-a53_musl/; '; fi
rm -rf /home/opc/wax206/openwrt/tmp/stage-gdbm
touch /home/opc/wax206/openwrt/staging_dir/target-aarch64_cortex-a53_musl/stamp/.gdbm_installed
make[3]: Leaving directory '/home/opc/wax206/openwrt/feeds/packages/libs/gdbm'
time: package/feeds/packages/gdbm/compile#14.47#2.30#16.78
make[2]: Leaving directory '/home/opc/wax206/openwrt'
make[1]: *** [package/Makefile:110: /home/opc/wax206/openwrt/staging_dir/target-aarch64_cortex-a53_musl/stamp/.package_compile] Error 2
make[1]: Leaving directory '/home/opc/wax206/openwrt'
make: *** [/home/opc/wax206/openwrt/include/toplevel.mk:231: world] Error 2

Thanks

The wpad-mash-* packages work with DAWN. I tested wpad-mesh-wolfssl and that works.

How do you all solve the problem on this device that it has no USB port? E.g. if due to package installations the internal storage is not enough? With USB port you could expand the internal storage. How do you do that or is the space enough for you all?

Hi @GM I'm seeing same issue trying to compile WAX206 master

I run mine as APs, space is never an issue.

Ok thanks. When I look on the site https://openwrt.org/toh/hwdata/netgear/netgear_wax206 the device should have 256MB flash MB and 512MB RAM right?
But when I do df -h I can only see for root 18.3MB? And Memory I can not see with df -h right? I thought this would be tmpfs but I am not sure..... with free -m I can see the 512MB RAM.

Filesystem                Size      Used Available Use% Mounted on
/dev/root                 4.0M      4.0M         0 100% /rom
tmpfs                   245.0M      1.1M    243.9M   0% /tmp
/dev/ubi0_1              18.3M      1.2M     16.1M   7% /overlay
overlayfs:/overlay       18.3M      1.2M     16.1M   7% /
tmpfs                   512.0K         0    512.0K   0% /dev

As i understand it my persistent storage is only 18.3MB?

This question have been covered in the past, scroll up, but you won't ever get more than 50% of full flash space, since it's a dual flash device, and you still have to subtract the uboot specific partitions, etc.

Start by doing a cat /proc/mtd

Openwrt never alters the original layout of the flash.
If there's tons of unused space, openwrt won't claim it.

1 Like

In case anyone is interested in the solution to :point_up_2:

I ended up ditching relayd and moved to a fully routed setup for a media bridge (without a wifi AP) and speeds are back to normal :partying_face: Retransmissions have also dropped from triple digits to single and lower double when conducting iperf3 tests over a lacp link and CPU usage now maxes out at 45~48%

More importantly, and putting iperf3 testing aside, things/browsing feels snappier whether it's on the wan or lan side.

I also compiled a fresh build from Master and the bridge's bitrates are now fluctuating between 2100Mbps and 2400Mbps rx/tx (8 to 10m with 1 corner) ... not sure what changed there but I'll take it.

Openwrt rocks :metal:

@patient0 Thanks again for the helpful testing.

Screen Shot 2023-02-27 at 7.10.02 AM

Adding iperf3 results over lacp

Screen Shot 2023-02-27 at 7.28.22 AM

Forgot to mention - To cut/lower the retransmissions, I enabled flow control on the 2.5G WAX link (switch side)

2 Likes

I don't know what is the issue because there's no explicit errors, I used the Attended Sysupgrade to grab the last image without issue (but without custom kernel), maybe the error will be fixed in some new releases? I also tried to change some libraries but I'm still unable to complete the compilation.

openssl is a necessary library but...

make[3] -C feeds/packages/lang/luarocks host-compile
    ERROR: package/libs/openssl failed to build.
 make[4] scripts/config/conf

Works fine for me with latest master, do you compile with make -j1 V=s to make sure that you see all the information regarding this error? And if you got the time (the compile takes) clean the directory with make distclean. That will remove all the building files including the .config file.

After that :

  • ./scripts/feeds update -a
  • ./scripts/feeds install -a
  • make menuconfig and choose WAX206 and packages you want
  • make -j $(nproc) toolchain/install to create and install the toolchain
  • make -j $(nproc) to create the image. If that fails then run
  • make -j1 V=s, that ensures that parallel building is disabled (-j1) and is more verbose
2 Likes

Thanx - all is working fine now - starting all over and using standard procedures fixed it all

Yes this fixed the compilation issue but I had to reconfigure all the options, I didn't want to do that, I'm lazy :slight_smile:

Thanks anyway.

With the help from ./scripts/diffconfig.sh > ~/openwrt-backup-config-WAX206.config you can save only the diff from you configuration for later use.

Then later after the feed update and feed install you copy that file back as .config and run make defconfig and all your selected options and packages are back.

1 Like

I get the openssl error again,

ERROR: package/libs/openssl failed to build

after a 100% clean build from a new folder, here's the output in -j1 V=Sc

make[3]: Entering directory '/home/opc/wax206/openwrt/package/libs/openssl'
rm -f /home/opc/wax206/openwrt/build_dir/target-aarch64_cortex-a53_musl/openssl-3.0.8/.configured_*
rm -f /home/opc/wax206/openwrt/staging_dir/target-aarch64_cortex-a53_musl/stamp/.openssl_installed
(cd /home/opc/wax206/openwrt/build_dir/target-aarch64_cortex-a53_musl/openssl-3.0.8; ./Configure linux-aarch64-openwrt --prefix=/usr --libdir=lib --openssldir=/etc/ssl --cross-compile-prefix="aarch64-openwrt-linux-musl-" -I/home/opc/wax206/openwrt/staging_dir/toolchain-aarch64_cortex-a53_gcc-12.2.0_musl/usr/include -I/home/opc/wax206/openwrt/staging_dir/toolchain-aarch64_cortex-a53_gcc-12.2.0_musl/include/fortify -I/home/opc/wax206/openwrt/staging_dir/toolchain-aarch64_cortex-a53_gcc-12.2.0_musl/include -L/home/opc/wax206/openwrt/staging_dir/toolchain-aarch64_cortex-a53_gcc-12.2.0_musl/usr/lib -L/home/opc/wax206/openwrt/staging_dir/toolchain-aarch64_cortex-a53_gcc-12.2.0_musl/lib -znow -zrelro -Wl,--gc-sections shared no-tests no-blake2 no-chacha no-poly1305 no-async no-ec2m no-err no-tls1_3 no-aria no-sm2 no-sm3 no-sm4 no-camellia no-idea no-seed no-mdc2 no-whirlpool no-cms no-rfc3779 -DOPENSSL_SMALL_FOOTPRINT no-engine no-dtls no-comp no-nextprotoneg no-psk no-srp no-asm && { [ -f /home/opc/wax206/openwrt/build_dir/target-aarch64_cortex-a53_musl/openssl-3.0.8/.configured_e4fa0b4c0522674788327c31d6ffb5db_d5e6dec162df0b4c1bcc85c8735dee4e ] || make clean; } )
make[3]: Leaving directory '/home/opc/wax206/openwrt/package/libs/openssl'
time: package/libs/openssl/compile#0.20#0.04#0.22
    ERROR: package/libs/openssl failed to build.
make[2]: Leaving directory '/home/opc/wax206/openwrt'
make[1]: Leaving directory '/home/opc/wax206/openwrt'

Here's the full output log: https://ufile.io/sbdmw5l8

I don't see anything in that error message that gives a hint.

And I can't download the log file, it want's me to enable browser notifications to download the file? Can you use a pastebin service like https://pastebin.com where I don't have to sacrifice my firstborn to see the log?

Me neither, this is why I'm asking, I don't have any concrete error, so I don't know where to debug...

Pastebin has a 512Kb size limit, the full output is 4.7Mb, this is why I used a random online upload service. Try this (it works because it's my cloud space): https://dsc.cloud/40973c/kernel_build_fail.txt

Ok, didn't know about the pastebin limit, thanks for the link.

Line 3609: aarch64_cortex-a53_musl/linux-mediatek_mt7622/packages/.pkgdir/kmod-crypto-acompress/lib/modules/5.15.94/ ; else echo "ERROR: module '$mod' is missing." >&2; exit 1; fi; done;

Not sure why but try grepping for 'ERROR' or 'failed'

Maybe connected to a package you selected, what is your compile host (Ubuntu, Arch, ...)?