Thanks for followup! I'll keep an eye on this (it's not happening all the time and, interestingly, last couple if times I tried it did not happen).
I run builds from your branch as of 9/25, and did not rebase due to recent instability. Do you think branch is stable now and, more generally, do you plan to have any kind of releases?
For the most part it's been pretty stable across multiple devices. That is mac80211 version 6.11, and latest upstream.
As for releases, it's hard to say for sure as upstream OpenWRT has not branched off yet for a stable release on the qualcommax branch. Though I do tend to create branches anytime mac80211 package is updated, as that is the primary source for breakages in NSS (wifi). The main kernel is luckily on 6.6 so that will be that way even during their branching off, and patches for those have been stable for sometime.
Connected to phy1-1 (this would usually be point when DHCP might fail - but it worked OK)
Tried to connect to phy2-0 - FAIL. I saw device connected in MX4300 GUI, but client (pixel7) was stuck in getting DHCP. After flipping Wi-Fi on phone it got connected. This might be the way client behaves though.
STA [MAC:ADDRESS] WPA: pairwise key handshake completed (RSN)
Tue Oct 8 00:13:13 2024 daemon.notice hostapd: phy2-ap0: EAPOL-4WAY-HS-COMPLETED [MAC:ADDRESS]
Tue Oct 8 00:13:32 2024 daemon.notice hostapd: phy2-ap0: AP-STA-DISCONNECTED [MAC:ADDRESS]
Tue Oct 8 00:13:32 2024 daemon.info hostapd: phy2-ap0: STA [MAC:ADDRESS] IEEE 802.11: disassociated
Tue Oct 8 00:13:33 2024 daemon.info hostapd: phy2-ap0: STA [MAC:ADDRESS] IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
Tue Oct 8 00:13:43 2024 daemon.info hostapd: phy1-ap1: STA [MAC:ADDRESS] IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
Tue Oct 8 00:13:51 2024 daemon.info hostapd: phy2-ap0: STA [MAC:ADDRESS] IEEE 802.11: authenticated
Tue Oct 8 00:13:51 2024 daemon.info hostapd: phy2-ap0: STA [MAC:ADDRESS] IEEE 802.11: associated (aid 1)
Tue Oct 8 00:13:51 2024 daemon.notice hostapd: phy2-ap0: AP-STA-CONNECTED [MAC:ADDRESS] auth_alg=open
Tue Oct 8 00:13:51 2024 daemon.info hostapd: phy2-ap0: STA [MAC:ADDRESS] RADIUS: starting accounting session C06197F0116DA15F
Tue Oct 8 00:13:51 2024 daemon.info hostapd: phy2-ap0: STA [MAC:ADDRESS] WPA: pairwise key handshake completed (RSN)
Tue Oct 8 00:13:51 2024 daemon.notice hostapd: phy2-ap0: EAPOL-4WAY-HS-COMPLETED [MAC:ADDRESS]
Tue Oct 8 00:14:09 2024 daemon.notice hostapd: phy2-ap0: AP-STA-DISCONNECTED [MAC:ADDRESS]
Tue Oct 8 00:14:10 2024 daemon.info hostapd: phy2-ap0: STA [MAC:ADDRESS] IEEE 802.11: disassociated
Tue Oct 8 00:14:11 2024 daemon.info hostapd: phy2-ap0: STA [MAC:ADDRESS] IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
Tue Oct 8 00:14:29 2024 daemon.info hostapd: phy2-ap0: STA [MAC:ADDRESS] IEEE 802.11: authenticated
Tue Oct 8 00:14:29 2024 daemon.info hostapd: phy2-ap0: STA [MAC:ADDRESS] IEEE 802.11: associated (aid 1)
Tue Oct 8 00:14:29 2024 daemon.notice hostapd: phy2-ap0: AP-STA-CONNECTED [MAC:ADDRESS] auth_alg=open
Tue Oct 8 00:14:29 2024 daemon.info hostapd: phy2-ap0: STA [MAC:ADDRESS] RADIUS: starting accounting session FC2F6BD39F0C9958
Tue Oct 8 00:14:29 2024 daemon.info hostapd: phy2-ap0: STA [MAC:ADDRESS] WPA: pairwise key handshake completed (RSN)
Tue Oct 8 00:14:29 2024 daemon.notice hostapd: phy2-ap0: EAPOL-4WAY-HS-COMPLETED [MAC:ADDRESS]
Tue Oct 8 00:14:47 2024 daemon.notice hostapd: phy2-ap0: AP-STA-DISCONNECTED [MAC:ADDRESS]
Tue Oct 8 00:14:48 2024 daemon.info hostapd: phy2-ap0: STA [MAC:ADDRESS] IEEE 802.11: disassociated
Tue Oct 8 00:14:49 2024 daemon.info hostapd: phy2-ap0: STA [MAC:ADDRESS] IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
I installed lytr's build via the web ui, rebooted, connected the device to my modem & PC, SSH'ed in to install luci and found that the device could not ping domains/ip addresses.
Can someone help me get out of this predicament? I believe I just need help setting an IP/DNS.
In an attempt to try to help whoever is willing to assist, I found a useful set of commands on a different thread:
ubus call system board; \
ping -c 2 1.1.1.1; uci export network; \
uci export dhcp; uci export firewall; \
ip -4 addr ; ip -4 ro li tab all ; ip -4 ru; \
ls -l /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/* ; head -n -0 /etc/resolv.*
I'll post their results for me here:
{
"kernel": "6.6.43",
"hostname": "OpenWrt",
"system": "ARMv8 Processor rev 4",
"model": "Linksys MX4300",
"board_name": "linksys,mx4300",
"rootfs_type": "squashfs",
"release": {
"distribution": "OpenWrt",
"version": "SNAPSHOT",
"revision": "r0-2540ea6",
"target": "qualcommax/ipq807x",
"description": "OpenWrt SNAPSHOT r0-2540ea6"
}
}
PING 1.1.1.1 (1.1.1.1): 56 data bytes
ping: sendto: Network unreachable
package network
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd04:4c7:b516::/48'
config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
config device
option name 'lan1'
option macaddr 'd8:ec:5e:95:1c:07'
config device
option name 'lan2'
option macaddr 'd8:ec:5e:95:1c:07'
config device
option name 'lan3'
option macaddr 'd8:ec:5e:95:1c:07'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
config interface 'wan'
option device 'wan'
option proto 'dhcp'
config interface 'wan6'
option device 'wan'
option proto 'dhcpv6'
package dhcp
config dnsmasq
option domainneeded '1'
option boguspriv '1'
option filterwin2k '0'
option localise_queries '1'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option nonegcache '0'
option cachesize '1000'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
option nonwildcard '1'
option localservice '1'
option ednspacket_max '1232'
option filter_aaaa '0'
option filter_a '0'
config dhcp 'lan'
option interface 'lan'
option start '100'
option limit '150'
option leasetime '12h'
option dhcpv4 'server'
option dhcpv6 'server'
option ra 'server'
option ra_slaac '1'
list ra_flags 'managed-config'
list ra_flags 'other-config'
config dhcp 'wan'
option interface 'wan'
option ignore '1'
config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'
option loglevel '4'
package firewall
config defaults
option syn_flood '1'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
config zone
option name 'lan'
list network 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
config zone
option name 'wan'
list network 'wan'
list network 'wan6'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'
config forwarding
option src 'lan'
option dest 'wan'
config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'
config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'
config rule
option name 'Allow-IGMP'
option src 'wan'
option proto 'igmp'
option family 'ipv4'
option target 'ACCEPT'
config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-MLD'
option src 'wan'
option proto 'icmp'
option src_ip 'fe80::/10'
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-IPSec-ESP'
option src 'wan'
option dest 'lan'
option proto 'esp'
option target 'ACCEPT'
config rule
option name 'Allow-ISAKMP'
option src 'wan'
option dest 'lan'
option dest_port '500'
option proto 'udp'
option target 'ACCEPT'
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
7: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qle n 1000
inet 192.168.1.1/24 brd 192.168.1.255 scope global br-lan
valid_lft forever preferred_lft forever
192.168.1.0/24 dev br-lan scope link src 192.168.1.1
local 127.0.0.0/8 dev lo table local scope host src 127.0.0.1
local 127.0.0.1 dev lo table local scope host src 127.0.0.1
broadcast 127.255.255.255 dev lo table local scope link src 127.0.0.1
local 192.168.1.1 dev br-lan table local scope host src 192.168.1.1
broadcast 192.168.1.255 dev br-lan table local scope link src 192.168.1.1
0: from all lookup local
32766: from all lookup main
32767: from all lookup default
lrwxrwxrwx 1 root root 16 Aug 4 20:20 /etc/resolv.conf -> /tm p/resolv.conf
-rw-r--r-- 1 root root 47 Aug 4 20:20 /tmp/resolv.conf
-rw-r--r-- 1 root root 0 Aug 4 20:20 /tmp/resolv.conf.d/reso lv.conf.auto
/tmp/resolv.conf.d:
-rw-r--r-- 1 root root 0 Aug 4 20:20 resolv.conf.auto
My two laptops with ax wifi 6e cards would not connect to 5G wireless (actually they connect but then immediately disconnect.
My older PCs with ac wifi cards would connect to 5G just fine.
After playing with various parameters I found that unchecking the Disassociate On Low Acknowledgement option for 5G wireless in luci (which was checked by default) resolves this problem.
(I'm on Arix latest non-NSS build if that matters)
Sorry if this issue was already mentioned earlier in this long topic.
Hi all. This is my first post here. I have been using lytr's openwrt build (august 4) with great success on one ln1301/mx4300 unit. Yesterday, I got a second unit from the Woot sale and have been trying to flash it the same way I did the first one, uploading the [mx4300-squashfs-factory.bin], but I run into an Invalid firmware file error. I have a screenshot linked.
I have tried:
Be sure the factory.bin file is not corrupt by checking the hash or download several times to be sure the file is complete. If sure then ignore the Linksys complaints about flashing Openwrt firmware. I haven't tried to flash the Linksys prod.img to the 215382 factory install so that error is mysterious. The 215382 img is the original and so far only firmware published by Linksys for the MX4300.
So as long as the Openwrt firmware was downloaded correctly just ignore the Linksys complaints.
I did not see any hashes online for either the original linksys firmware or the lytr openwrt build, so I downloaded the 2 files on another pc and transferred (verifying hash with teracopy) and checked hashes of files with winmerge and they are identical, so I don't believe the file is corrupt. As far as I know, there is no way around this prompt.
The router obviously checks the firmware file to ensure the file is a proper Linksys firmware file so the Openwrt firmware will always fail. I followed these instructions and was able to power through the warnings: OpenWrt support for Linksys MX4200 - #1644 by davidlucking
Yes, i followed that guide both the first and second time. It worked perfectly the first time but not this time.
Both times the first image I flashed was the lytr OpenWRT and it worked first try on the first one, but this second one is giving me issues. The router itself works fine
Precisely I am stuck at step 5:
Click start. Ignore all the prompts and warnings by click βyesβ in all the popups.
This error comes up after clicking yes twice, I click close, and then nothing else happens
The strange thing is the router seems to reject its own firmware from Linksys for a mx4300