OpenWrt support for Linksys MX4200

Update: I just install the current build: r26363-2b8e875a85 (May 20th). Everything is working again. I blamed Myself, bad flash, bad release, everything. Anyhow the current works again.

Woot has MX8000 for $80 now. That's a two pack of MX4200 if any one wants more of these.

Can someone repost instructions for removing the ISP lock?
SpectreDev posted a link but it no longer works.

Answered my own question, install Starhub firmware followed by stock.

I don't suppose you have a compiled version you could share with NSS fork? Running v2

Anybody else having issues with wifi since a week or 2? Kernel 6.6.33 is working flawlessly, but since the snapshot is based on 6.6.35 devices do connect to wifi but have no internet. Wired devices connected to the AP do have internet, so it must be something with the wifi. Reverting back to the other partition (kernel 6.6.33) fixes the issue immediately. Any ideas?

Nice to see some progress here

Here https://github.com/SpectreDev1/Flash-Retail-FW-on-mx4200-community-fibre

The more I think about the MX4200 it's basically just become a better Eero Pro 6. Same hardware afaik but obviously better software.

Has anyone tried these to simulate how a tri band system would be via 802.11s or WDS? e.g. Have backhaul on the 4:4 5Ghz and client having access to the other 5Ghz band and 2.4Ghz?

The issue seems to be resolved. Still not sure what caused it, but I did a clean install of the latest snapshot over the weekend (6.6.36 kernel). Wifi is working as expected again and is stable.

A variant of this device, the Linksys LN1301 (MX4300), is on sale at Woot for $25. I don't know what the hardware differences might be.

https://computers.woot.com/offers/linksys-ln1301-wifi-6-router-3

And at Walmart

https://www.walmart.com/ip/Linksys-LN1301-Triband-AX4200-WiFi-6-Router/5645414143

And Amazon if you have Prime

I just dug through the DTS of it, and it appears to be identical to the MX4200v1 (512MB). The initramfs of the MX4200 should at least boot.

1 Like

fw layout is a little bit different. kernel size is 8mb instead of 6m according to the fw binary i found

Hi all,

Can anyone else with a mx4200 v1 comment on how much ram is available? I just got a set of mx4200 V1's and installed the latest snapshot. The available ram (363.89 MB) seems to be a bit lower than what I expected for a 512MB device:

/tmp is stored in memory, it'll allocate some RAM.

1 Like

ipq807x needs to reserve quite a bit of memory for the hardware, that's the way how these SOCs are designed. For ipq807x, 512 MB RAM is not exactly plenty.

1 Like

One other thing I observed which I thought was unusual, if you are in partition #1 and upgrade the firmware via Luci, the router reboots back into the same partition rather than partition # 2 with the upgraded firmware. The only way to get into partition #2 is by doing so manually(/usr/sbin/fw_setenv boot_part 2 && reboot). Is this a bug?

I asked to see if the mx4200 V1 can be supported in luci-app-advanced-reboot. Early indications seem promising. Not sure if the V2 would require different parameters. Will post here once I find out more.