OpenWrt support for Linksys MX4200

Sorry, I wasn't clear in my wording.
I corrected my post

With this I wanted to point out that the arix's recommendation how to update the MX4300 keeping the stock firmware on second (alt) partition was working OK and as expected. I really wanted to keep the stock for recovery purpose.
For the compilation speed optimization part it's a little longer topic. I've just mostly followed the recommendations and advices in Qualcommax NSS Build thread. It's difficult to summarize because I follow it and build for over a year. But there is an excellent starting point in @qosmio repo.

1 Like

I remember facing this issue at one point, but can't remember now exactly how I solved it. Below are the configs for the base router, 802.11s mesh client/bridge and then dump AP wired to the mesh client.

This is currently deployed on qualcommax-nss-snapshot-r28199-1bdb6d8404
Uptime : 5days+

Hope it helps!

Base Router

==========================
/etc/config/network
==========================

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'xxxxxxxxxxxx'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	option ipv6 '0'

config device
	option name 'lan1'
	option macaddr 'xxxxxxxxxxxxxxx'

config device
	option name 'lan2'
	option macaddr 'xxxxxxxxxxxxxxx'

config device
	option name 'lan3'
	option macaddr 'xxxxxxxxxxxxxxx'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '10.75.75.1'
	option netmask '255.255.255.0'
	option delegate '0'
	list dns '10.75.75.1'

config interface 'wan'
	option device 'wan.xxx'
	option proto 'pppoe'
	option username 'xxxxxxxxxx'
	option password 'xxxxxxxxxx'
	option ipv6 '0'
	option delegate '0'
	option peerdns '0'
	list dns '10.75.75.1'
	option sourcefilter '0'

config device
	option name 'wan.100'
	option type '8021q'
	option ifname 'wan'
	option vid '100'
	option ipv6 '0'
	option multicast '0'

config interface 'vx0'
	option proto 'vxlan'
	option force_link '1'
	option peeraddr '239.168.100.200'
	option ipaddr '10.75.75.1'
	option port '4789'
	option vid '41'
	option tunlink 'lan'
	option delegate '0'
	option ipv6 '0'

config device
	option type 'bridge'
	option name 'br-guest'
	option bridge_empty '1'
	list ports 'vx0.30'
	option ipv6 '0'
	option mtu '1440'

config interface 'guest'
	option proto 'static'
	option device 'br-guest'
	option defaultroute '0'
	option delegate '0'
	list ipaddr '192.75.75.1/24'
	list dns '192.75.75.1'

==========================
/etc/config/dhcp
==========================

config dnsmasq 'LAN'
	option domainneeded '1'
	option localise_queries '1'
	option rebind_protection '0'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option cachesize '1000'
	option authoritative '1'
	option leasefile '/tmp/dhcp.leases'
	option localservice '1'
	option ednspacket_max '1232'
	list interface 'lan'
	option port '54'
	option localuse '0'
	option noresolv '1'

config dhcp 'lan'
	option interface 'lan'
	option start '50'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option dhcpv6 'disabled'
	option instance 'LAN'
	list dhcp_option '6,0.0.0.0'
	list dhcp_option '42,10.75.75.1'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

config dnsmasq 'GuestDHCP'
	option local '/guest/'
	option domain 'guest'
	option expandhosts '1'
	option rebind_protection '0'
	option localservice '1'
	option domainneeded '1'
	option localise_queries '1'
	option port '54'
	option ednspacket_max '1232'
	option cachesize '1000'
	option leasefile '/tmp/dhcp_guest.leases'
	option noresolv '1'
	list interface 'guest'
	list notinterface 'loopback'
	option localuse '0'

config dhcp 'guest'
	option interface 'guest'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option dhcpv6 'disabled'
	option instance 'GuestDHCP'
	list dhcp_option '6,0.0.0.0'
	list dhcp_option '42,192.75.75.1'
	list dhcp_option '26,1440'

==========================
/etc/config/wireless
==========================

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/soc@0/c000000.wifi'
	option band '5g'
	option channel '48'
	option disabled '0'
	option country 'US'
	option cell_density '2'
	option htmode 'HE80'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/soc@0/c000000.wifi+1'
	option band '2g'
	option channel '11'
	option country 'US'
	option cell_density '2'
	option htmode 'HT40'
	option noscan '1'
	option greenfield '1'

config wifi-device 'radio2'
	option type 'mac80211'
	option path 'platform/soc@0/c000000.wifi+2'
	option band '5g'
	option channel '157'
	option disabled '0'
	option country 'US'
	option cell_density '2'
	option htmode 'HE80'

config wifi-iface 'wifinet0'
	option device 'radio1'
	option mode 'ap'
	option ssid '2.4Ghz Wifi AP'
	option encryption 'psk2+ccmp'
	option key 'wifikeyhere'
	option network 'lan'
	option dtim_period '3'

config wifi-iface 'wifinet1'
	option device 'radio0'
	option mode 'ap'
	option ssid '5Ghz Wifi AP 2x2'
	option encryption 'psk2+ccmp'
	option key 'wifikeyhere'
	option network 'lan'
	option dtim_period '3'
	option ieee80211r '1'
	option mobility_domain 'd00b'
	option reassociation_deadline '20000'
	option ft_over_ds '0'
	option ft_psk_generate_local '1'
	option ieee80211k '1'
	option bss_transition '1'

config wifi-iface 'wifinet2'
	option device 'radio2'
	option mode 'mesh'
	option encryption 'sae'
	option key 'wifikeyhere'
	option network 'lan'
	option dtim_period '3'
	option mesh_id '5Ghz Wifi Backhaul 4x4'
	option mesh_fwding '1'
	option mesh_rssi_threshold '0'

config wifi-iface 'wifinet3'
	option device 'radio1'
	option mode 'ap'
	option ssid '2.4Ghz Wifi AP Guest'
	option encryption 'psk2+ccmp'
	option key 'wifikeyhere'
	option network 'guest'
	option isolate '1'

==========================
/etc/config/firewall
==========================	
	
config defaults
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option synflood_protect '1'

config zone
	option name 'lan'
	list network 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'

config zone
	option name 'wan'
	list network 'wan'
	list network 'wan6'
	option input 'DROP'
	option output 'ACCEPT'
	option forward 'DROP'
	option masq '1'
	option mtu_fix '1'

config forwarding
	option src 'lan'
	option dest 'wan'
	
config forwarding
	option src 'lan'
	option dest 'guest'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config include 'qcanssecm'
	option type 'script'
	option path '/etc/firewall.d/qca-nss-ecm'

config include 'bcp38'
	option type 'script'
	option path '/usr/lib/bcp38/run.sh'

config zone 'guest'
	option name 'guest'
	option network 'guest'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option mtu_fix '1'
	option log '1'

config forwarding 'guest_wan'
	option src 'guest'
	option dest 'wan'

config rule 'guest_dns'
	option name 'Allow-DNS-Guest'
	option src 'guest'
	option dest_port '53'
	option proto 'tcp udp'
	option target 'ACCEPT'

config rule 'guest_dhcp'
	option name 'Allow-DHCP-Guest'
	option src 'guest'
	option dest_port '67'
	option proto 'udp'
	option family 'ipv4'
	option target 'ACCEPT'

config redirect 'dns_int'
	option name 'Intercept-DNS'
	option family 'any'
	option proto 'tcp udp'
	option src 'lan'
	option src_dport '53'
	option target 'DNAT'

config redirect 'dns_int2'
	option name 'Intercept-DNS-Guest'
	option family 'any'
	option proto 'tcp udp'
	option src 'guest'
	option src_dport '53'
	option target 'DNAT'

config rule 'dot_fwd'
	option name 'Deny-DoT'
	option src 'lan'
	option dest 'wan'
	option dest_port '853'
	option proto 'tcp udp'
	option target 'REJECT'

config rule 'dot_fwd2'
	option name 'Deny-DoT-Guest'
	option src 'guest'
	option dest 'wan'
	option dest_port '853'
	option proto 'tcp udp'
	option target 'REJECT'

config rule 'guest_ntp'
	option name 'Allow-NTP-Guest'
	option src 'guest'
	option dest_port '123'
	option proto 'tcp udp'
	option target 'ACCEPT'

config redirect 'ntp_int'
	option name 'Intercept-NTP'
	option family 'any'
	option proto 'tcp udp'
	option src 'lan'
	option src_dport '123'
	option target 'DNAT'

config redirect 'ntp_int2'
	option name 'Intercept-NTP-Guest'
	option family 'any'
	option proto 'tcp udp'
	option src 'guest'
	option src_dport '123'
	option target 'DNAT'

config rule 'guest_mdns2'
	option name 'mDNS This Device'
	option proto 'udp'
	option src 'guest'
	option src_port '5353'
	option dest_ip '224.0.0.251'
	option dest_port '5353'
	option target 'ACCEPT'

config rule 'guest_mdns_igmp'
	option name 'mDNS IGMP This Device'
	option family 'ipv4'
	option proto 'igmp'
	option src 'guest'
	option dest_ip '224.0.0.251'
	option target 'ACCEPT'

config rule
	option name 'ICMP Allow Guest to Lan'
	list proto 'icmp'
	option src 'guest'
	option dest 'lan'
	option target 'ACCEPT'

config rule
	option name 'ICMP Allow Guest to Device'
	list proto 'icmp'
	option src 'guest'
	option target 'ACCEPT'

config rule
	option name 'iperf guest'
	list proto 'tcp'
	option src 'guest'
	option dest_port '5201'
	option target 'ACCEPT'
	option family 'ipv4'

config rule 'guest_2lan'
	option name 'Block Guest to LAN'
	option src 'guest'
	option dest 'lan'
	option target 'REJECT'
	list proto 'all'

config rule 'guest_2device'
	option name 'Block Guest to Device'
	list proto 'all'
	option src 'guest'
	option target 'REJECT'

Mesh Client

=======================
/etc/config/network 
=======================

#dnsmasq is disabled on the mesh client
#ododhcpd is disabled on the mesh client
#firewall is disabled on the mesh client, since there no guest network here

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'xxxxxxxxxxxxx'

config device
	option name 'br-lan'
	option type 'bridge'
	option ipv6 '0'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'wan'

config device
	option name 'lan1'
	option macaddr 'xxxxxxxxxxxxxxx'

config device
	option name 'lan2'
	option macaddr 'xxxxxxxxxxxxxxx'

config device
	option name 'lan3'
	option macaddr 'xxxxxxxxxxxxxxx'

config interface 'lan'
	option device 'br-lan'
	option proto 'dhcp'
	option delegate '0'

=======================
/etc/config/dhcp
=======================

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option cachesize '1000'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'
	option ednspacket_max '1232'
	option filter_aaaa '0'
	option filter_a '0'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

=======================
/etc/config/wireless
=======================

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/soc@0/c000000.wifi'
	option band '5g'
	option channel '48'
	option htmode 'HE80'
	option disabled '0'
	option country 'US'
	option cell_density '2'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/soc@0/c000000.wifi+1'
	option band '2g'
	option channel '11'
	option htmode 'HE40'
	option disabled '1'

config wifi-device 'radio2'
	option type 'mac80211'
	option path 'platform/soc@0/c000000.wifi+2'
	option band '5g'
	option channel '157'
	option htmode 'HE80'
	option disabled '0'
	option country 'US'
	option cell_density '2'

config wifi-iface 'wifinet1'
	option device 'radio0'
	option mode 'ap'
	option ssid '5Ghz Wifi AP 2x2'
	option encryption 'psk2+ccmp'
	option key 'wifikeyhere'
	option network 'lan'
	option dtim_period '3'
	option ieee80211r '1'
	option mobility_domain 'd00b'
	option reassociation_deadline '20000'
	option ft_over_ds '0'
	option ft_psk_generate_local '1'
	option ieee80211k '1'
	option bss_transition '1'

config wifi-iface 'wifinet2'
	option device 'radio2'
	option mode 'mesh'
	option mesh_id '5Ghz Wifi Backhaul 4x4'
	option mesh_fwding '1'
	option mesh_rssi_threshold '0'
	option encryption 'sae'
	option key 'wifikeyhere'
	option network 'lan'
	option dtim_period '3'

=======================
/etc/config/firewall
=======================
	
config defaults
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option synflood_protect '1'

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	list network 'lan'

config include 'qcanssecm'
	option type 'script'
	option path '/etc/firewall.d/qca-nss-ecm'

Dump APs

=======================
/etc/config/network 
=======================

#dnsmasq is disabled on the Dump APs
#ododhcpd is disabled on the Dump APs
#firewall is **enabled** on the Dump APs since there is a guest network here

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'xxxxxxxxxxxxxxx'

config device
	option name 'br-lan'
	option type 'bridge'
	option stp '0'
	option ipv6 '0'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'wan'

config device
	option name 'lan1'
	option macaddr 'xxxxxxxxxxxxx'

config device
	option name 'lan2'
	option macaddr 'xxxxxxxxxxxxx'

config device
	option name 'lan3'
	option macaddr 'xxxxxxxxxxxxx'

config interface 'lan'
	option device 'br-lan'
	option proto 'dhcp'
	option delegate '0'

config interface 'vx0'
	option proto 'vxlan'
	option force_link '1'
	option peeraddr '239.168.100.200'
	option ipaddr '10.75.75.45'
	option port '4789'
	option vid '41'
	option tunlink 'lan'
	option delegate '0'

config device
	option type 'bridge'
	option name 'br-guest'
	option bridge_empty '1'
	option macaddr 'xxxxxxxxxxxxx'
	option ipv6 '0'
	list ports 'vx0.30'
	option mtu '1440'

config interface 'guest'
	option proto 'dhcp'
	option device 'br-guest'
	option defaultroute '0'
	option peerdns '0'
	list dns '192.75.75.1'
	option delegate '0'

=======================
/etc/config/dhcp
=======================

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option cachesize '1000'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'
	option ednspacket_max '1232'
	option filter_aaaa '0'
	option filter_a '0'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

=======================
/etc/config/wireless
=======================
config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/soc@0/c000000.wifi'
	option band '5g'
	option channel '48'
	option htmode 'HE80'
	option disabled '0'
	option country 'US'
	option cell_density '2'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/soc@0/c000000.wifi+1'
	option band '2g'
	option channel '11'
	option htmode 'HT40'
	option disabled '0'
	option country 'US'
	option cell_density '2'
	option noscan '1'
	option greenfield '1'

config wifi-device 'radio2'
	option type 'mac80211'
	option path 'platform/soc@0/c000000.wifi+2'
	option band '5g'
	option channel '157'
	option htmode 'HE80'
	option disabled '0'
	option country 'US'
	option cell_density '2'

config wifi-iface 'wifinet0'
	option device 'radio1'
	option mode 'ap'
	option ssid '2.4Ghz Wifi AP'
	option encryption 'psk2+ccmp'
	option key 'wifikeyhere'
	option network 'lan'
	option dtim_period '3'

config wifi-iface 'wifinet1'
	option device 'radio0'
	option mode 'ap'
	option ssid '5Ghz Wifi AP 2x2'
	option encryption 'psk2+ccmp'
	option key 'wifikeyhere'
	option network 'lan'
	option dtim_period '3'
	option ieee80211r '1'
	option mobility_domain 'd00b'
	option reassociation_deadline '20000'
	option ft_over_ds '0'
	option ft_psk_generate_local '1'
	option ieee80211k '1'
	option bss_transition '1'

config wifi-iface 'wifinet2'
	option device 'radio2'
	option mode 'ap'
	option ssid '5Ghz Wifi AP 4x4'
	option encryption 'psk2+ccmp'
	option key 'wifikeyhere'
	option network 'lan'
	option dtim_period '3'

config wifi-iface 'wifinet3'
	option device 'radio1'
	option mode 'ap'
	option ssid '2.Ghz Wifi AP Guest'
	option encryption 'psk2+ccmp'
	option key 'wifikeyhere'
	option network 'guest'
	option isolate '1'
	option dtim_period '3'

=======================
/etc/config/firewall
=======================

config defaults
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option synflood_protect '1'

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	list network 'lan'

config include 'qcanssecm'
	option type 'script'
	option path '/etc/firewall.d/qca-nss-ecm'

config zone
	option name 'guest'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option mtu_fix '1'
	list network 'guest'

config forwarding
	option src 'lan'
	option dest 'guest'

config rule
	option name 'icmp 1'
	list proto 'icmp'
	option src 'guest'
	option dest 'lan'
	option target 'ACCEPT'

config rule
	option name 'icmp 2'
	list proto 'icmp'
	option src 'guest'
	option target 'ACCEPT'

config rule 'guest_2lan'
	option name 'Block Guest to LAN'
	option src 'guest'
	option dest 'lan'
	option target 'REJECT'
	list proto 'all'

config rule 'guest_2device'
	option name 'Block Guest to Device'
	list proto 'all'
	option src 'guest'
	option target 'REJECT'

1 Like

I'm using the MX4300 with qualcommax-nss-24.10.0-rc2-r28161, I have 2 questions:

  1. My secondary 5G Wi-Fi cannot be enabled. I have already tried running sysupgrade -n -v ***.bin, but it didn’t resolve the issue.
  2. What is the usable storage size on the MX4300? OpenWrt recognizes only 118MB of space, but the MX4300 is said to have 512MB of built-in flash storage divided into two partitions. Does this mean each partition can use approximately 256MB of space?
root@openwrt-mx4300:~# df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/root                12.8M     12.8M         0 100% /rom
tmpfs                   933.9M      1.4M    932.4M   0% /tmp
/dev/ubi0_1             117.7M     88.7M     24.3M  78% /overlay
overlayfs:/overlay      117.7M     88.7M     24.3M  78% /
tmpfs                   512.0K         0    512.0K   0% /dev

Is it possible to copy settings between partitions directly, without downloading/uploading a backup?

Here is my scenario. I am remotely managing a router and screwed up settings. In this case I probably would be able to fix them if I were at the location but I can't connect remotely. Luckily, with this router I could simply have it restarted to the second partition. But now the only way I know to restore the first partition to the previous state is by flashing the firmware with "keep settings" selected. It would be simpler if I could just copy the settings to the other partition. So is this possible?

The answer is No.

@arix possible to implement this for your nss builds? https://github.com/qosmio/openwrt-ipq/commit/96e7315a547bd4c8c65a0a36d2c875b69919a112

2 Likes

I saw that commit and I had an intention to ask if it works correctly. Has anyone tried it successfully. I compile from qosmio's branch but I upgraded two times from second boot (stock firmware) using factory.bin because I wanted to keep the stock firmware on second partition.

??? it's not in foss but already in nss.

1 Like

Why not? Many PRs are pending for months before being officially merged for different reasons.
NSS has many (mainly NSS) commits that will never be part of vanilla OpenWrt.
We are lucky we have NSS (thanks to @qosmio) working at all and we even can complain about different NSS stuff not working, etc.

Because I want to match foss with official build, nothing more(except mx4300 support of coz) nothing less. Consider foss build as a vanilla version.

5 Likes

i have same issue here, 2nd 5G radio can not be enabled.

From my understanding, MX4200 and MX4300 are totally different models with different partition layout.

Set the radio2's channel to some fixed lower channel like 149.

2 Likes

this fixed the issue. thanks!

This may affect more than just the MX4300. I upgraded a DL-WRX36 to 24.10rc2 this weekend and noticed "auto" was choosing a channel higher than 165 (I think it was 173, but don't recall exactly - suffice to say it was out of the allowed 5 GHz range for the location specified and it did not work). I set it to a proper fixed channel instead, just as you suggest, and that took care of it.

Edit: looks like it's actually tailscale "Use Tailscale Subnets" that's breaking this for me, please ignore

I have multicast to unicast enabled and on some devices after a week or so, I still cannot access the local device on wifi. Will flash again to latest NSS build, but wondering if anyone else is still running into this problem like me.

You can also set the country code to Australia, which will disable channels higher than 165 and "auto" will work.

1 Like

@qosmio I've been out of the loop for couple of months and see that there tons of commits by you and others. Appreciate your steadfast support for this awesome device. :slight_smile:

I synced the fork completely and started a build this morning and it generated images for a different device: arcadyan_aw1000.

This is the workflow that I have been using before and for some reason, it's generating for a different device now. Any ideas what changed? TIA

name: Build MX4300 NSS

on: workflow_dispatch

jobs:
    build:
        name: Build MX4300 NSS firmware images
        runs-on: ubuntu-latest
        permissions:
            contents: write
        steps:
            - name: Install packages
              run: |
                  sudo apt-get update && \
                  sudo apt-get install -y \
                      build-essential \
                      clang \
                      flex \
                      bison \
                      g++ \
                      gawk \
                      gcc-multilib \
                      g++-multilib \
                      gettext \
                      git \
                      libncurses-dev \
                      libssl-dev \
                      python3-distutils \
                      rsync \
                      unzip \
                      zlib1g-dev \
                      file \
                      wget && \
                  sudo apt-get clean

            - name: Checkout
              uses: actions/checkout@v4

            - name: Update feeds
              # run:  make package/symlinks
              run: cp feeds.conf.default feeds.conf 
               && echo "src-git custom_packages https://github.com/RainGater/OpenWRT-Packages" >> feeds.conf
               && scripts/feeds update -a 
               && scripts/feeds install -a

            - name: Generate MX4300 NSS Config
              # run: sh mx4300_nss_config.sh 
              run: cp nss-setup/config-nss.seed .config 
               && echo "CONFIG_ATH11K_THERMAL=y" >> .config 
               && echo "CONFIG_KMOD_ALL=y" >> .config 
               && echo "CONFIG_PACKAGE_collectd-mod-thermal=y" >> .config 
               && echo "CONFIG_PACKAGE_luci-app-temp-status=y" >> .config 
               && echo "CONFIG_FEED_custom_packages=n" >> .config

            - name: Build Config
              run: make defconfig V=s -j$(nproc)

            - name: Build Images
              run: make V=s -j$(nproc)

            - name: Get SHORT SHA 
              run: echo "SHORT_SHA=`echo ${GITHUB_SHA} | cut -c1-8`" >> $GITHUB_ENV

            - name: Release
              uses: ncipollo/release-action@v1
              with:
                tag: mx4300-nss-${{ env.SHORT_SHA }}
                artifacts: bin/targets/qualcommax/ipq807x/openwrt-qualcommax-ipq807x*.bin,bin/targets/qualcommax/ipq807x/openwrt-qualcommax-ipq807x-linksys_mx4300.manifest,.config

You need to fork from "24.10-nss-mx4300", not "24.10-nss".

This is what I forked from (qualcommax-6.x-nss-mx4300) and it was working before. Is this NOT for MX4300 as the branch clearly says it is?

image