OpenWrt Support for D-Link DAP-X1860

I think it can be stated as supported by now, even if this is only within the next release.
Many devices just list "snapshot" in the version / supported since column. When the release is out, we can still add the links for the final factory images etc.

2 Likes

Now supported by 22.03.04: https://firmware-selector.openwrt.org/?version=22.03.4&target=ramips%2Fmt7621&id=dlink_dap-x1860-a1

6 Likes

gluon folks did a backport to 22.03 (and fixed BMT remap-range to exclude UBI partition) :+1:

3 Likes

I wanted to thank all the developers for adding support for this device. It's cheap, pretty fast, compact, and already the snapshots have been rock solid for me. Now running 22.03.4 without issues.

4 Likes

It is currently available at MediaMarkt in Germany for € 13,99, even lower than initially (still limited to two devices) :innocent:

4 Likes

The only issue is that is has just one ethernet port and no external antenna. - But maybe we could start some tuning of the device for that price. - BTW... I just ordered yesterday 1 for 17,99€ and was angry, that after Easter-Monday the price rose from 15€-17,99€ and dropped today to 13,99€. I will try to send back the device for 17,99€. - At the moment I still compare the device with the Xiaomi RM1800 and need to say the Xiaomi-Device with the IPQ6018 chipsets is still nearly double the speed of the nice DAP- X1860. - So hopefully the drivers for the MT7915 will get an development-Improvement.

1 Like

This topic was intended for adding support for this specific device.
Since official 22.03 images are available now, I will set a timer for this topic to close.

Why?

Because specific problems for this device with official releases are better handled in separate topics, in order to make finding relevant information easier. Who is going to read the previous 100-something postings, if he has a specific problem with 22.03 and wifi?

Therefore: Please open new topics for any open issues with this device.

Thanks! :slight_smile:

2 Likes

Hi i just tried to flash the Version 22.03.4 using Chrome and Edge and i get to the Screen Upgrade complete! Rebooting ... but nothing happened for about 10 Minutes. I tried to reload the page and then it said Upgrade failed.
What i am supposed to do on the Upgrade complete! page?

Hi @Tiraga. If you followed this flash procedure, then LuCI should come up at http://192.168.1.1
Simply refreshing the page will not work, as you have to change your clients IP adress to something like 192.168.1.x (instead of 192.168.0.x).

Also, if this was your first time flashing the device, I hope you have used the factory.bin file.
Was this a downgrade from snapshot?

I used the first and not the second file from the firmware selection page... Now it worked, thanks!

1 Like

I think the dts could be wrong here.
GPL source from D-Link says (see twproduct.h):

GPIO_LED_POWER_OK=16
GPIO_LED_POWER_NG=8
GPIO_LED_INTERNET_OK=3
GPIO_LED_INTERNET_NG=4

GPIO_BUTTON_WIFI_ONOFF=7
GPIO_BUTTON_RESET=15
GPIO_BUTTON_WPS=18

whereas OpenWrt dts says:

		led_power_red: power_red {
			label = "red:power";
			gpios = <&gpio 7 GPIO_ACTIVE_LOW>;
		};

		led_power_orange: power_orange {
			label = "orange:power";
			gpios = <&gpio 8 GPIO_ACTIVE_LOW>;
			default-state = "on";
		};

		rssihigh {
			label = "green:rssihigh";
			gpios = <&gpio 22 GPIO_ACTIVE_LOW>;
		};

		rssimedium {
			label = "green:rssimedium";
			gpios = <&gpio 23 GPIO_ACTIVE_LOW>;
		};

		rssilow_orange {
			label = "orange:rssilow";
			gpios = <&gpio 26 GPIO_ACTIVE_LOW>;
		};

		rssilow_green {
			label = "green:rssilow";
			gpios = <&gpio 27 GPIO_ACTIVE_LOW>;
		};

I might have missed it, but do you have the URL for the GPL source for the DAP-X1860 at hand?

https://dlink-gpl.s3.amazonaws.com/GPL2100068/COVR-X1860_A1_V1.01B05_GPLCode_20211119.tar.gz

(from here: https://tsd.dlink.com.tw/)

1 Like

Thanks, I could only find the various manuals when searching for DAP-X1860 (and wasn't sure about COVR-X1860).

Sure.
Check FCC documents; they often use the same hardware with different model names (for different regions).

1 Like

hmm, I'm not sure this one is identical. external photos are quite different...
https://fccid.io/KA2COVRX1860A1

That was my problem here, as there are differences (two ethernet ports, different for factor of the PCB). There is certainly some family resemblance, but it doesn't appear to be identical (I did see source for the DAP-1860 (802.11ac) as well, which is probably closer). But neither of my attempts got me closer to finding the GPIO for the green power LED so far (I did try the known ones used by similar devices already).

maybe ask D-Link for sources?

I had asked D-Link for sources already (using the form on the technical support download site mentioned above) for DAP-X1860, hoping they might accidentally forget a private key for firmware signing in there.

COVR-X1860 is indeed a completely different device, manufactured by SGE/T&W (thus twproduct.h), while DAP-X1860 is made by Acelink/Edimax. The only thing they have in common is the chips used, otherwise the structure of the source code should be quite different.
I have support for COVR-X1860, but still hope the image could be encrypted (all details are known), but this might require a different format and lots of hacks, to make the UBI image be accepted by the OEM updater (which is based on OpenWrt sysupgrade).

Again: There is no green power/status LED in DAP-X1860. They incorrectly populated orange for green.
Just open the device and check the LEDs on the PCB :slightly_smiling_face:
Maybe an issue of communication with the Chinese manufacturer ("but we want it to be red in that case, and orange in that case" -> not knowing that orange would be achieved by illuminating green and red at the same time (this is how all the other DAP wall plug repeaters do it), they apparently populated red and orange, to satisfy the customers demands :innocent: )

// edit: this requires further investigation, see posts below

2 Likes

Weird, I was almost certain that the LED could be green (but I only had the OEM firmware running for a basic functionality check, less than half an hour - marvelling how bad an OEM webif could be) and videos about it on youtube seemed to confirm that. Thanks for confirming that there is no green LED.