OpenWrt Support for D-Link DAP-X1860

Can confirm. Retained my configuration and all is working fine so far. Gotta do some iperf tests tomorrow :slight_smile:


Today I got two slightly used DAP-X1860 from amazon for 30€ a piece. Flashed the latest snapshot, used Win11 edge, everything went smoothly. Using 802.11s meshes with both radios without hickups. Thank you all. Nice small router.


Just saw this post

D-Link DAP-X1860
OpenWrt SNAPSHOT, r22071-3c66ac7e22
root@AP_Varasto:~# iperf3 -s -D && iperf3 -c
Connecting to host, port 5201
[ 5] local port 47342 connected to port 5201
[ ID] Interval Transfer Bitrate Retr Cwnd
[ 5] 0.00-1.01 sec 76.1 MBytes 635 Mbits/sec 0 1023 KBytes
[ 5] 1.01-2.01 sec 76.1 MBytes 633 Mbits/sec 0 1023 KBytes
[ 5] 2.01-3.00 sec 75.0 MBytes 637 Mbits/sec 0 1023 KBytes
[ 5] 3.00-4.00 sec 65.0 MBytes 544 Mbits/sec 0 1023 KBytes
[ 5] 4.00-5.01 sec 68.8 MBytes 572 Mbits/sec 0 1023 KBytes
[ 5] 5.01-6.01 sec 76.0 MBytes 639 Mbits/sec 0 1023 KBytes
[ 5] 6.01-7.01 sec 78.8 MBytes 658 Mbits/sec 0 1023 KBytes
[ 5] 7.01-8.01 sec 72.4 MBytes 611 Mbits/sec 0 1023 KBytes
[ 5] 8.01-9.01 sec 67.5 MBytes 562 Mbits/sec 0 1023 KBytes
[ 5] 9.01-10.01 sec 67.5 MBytes 572 Mbits/sec 0 1023 KBytes

[ ID] Interval Transfer Bitrate Retr
[ 5] 0.00-10.01 sec 723 MBytes 606 Mbits/sec 0 sender
[ 5] 0.00-10.01 sec 723 MBytes 606 Mbits/sec receiver

Does this mean that the dap x1860 is bottlenecked by RAM?

This looks like the same result that other devices with MT7621 have achieved, not sure if iperf3 is indeed running single-threaded as some suggested, but it's a lot faster than qca9563 for example.

It looks like iperf3 uses mostly one processor which peeks.

1 Like

If somebody is looking for this device, it’s again available for 15€ at Mediamarkt/Saturn in Germany


I just installed the latest snapshot and it's working well, the only thing I miss is 160MHz support. Is it theoretically possible?

no not possible

Since this type of information is indeed missing, maybe we should add further information to the table of hardware. Docs are here about how to do it.

Hey, I'm trying to enter recovery, but unfortunately, I stuck on the boot process, I think.

I took the needle, pressed the reset button during plug-in, but red indicator is blinking, it's not going to orange, IP address is unrecognised, when I'm connecting the ethernet. Is it a hardware problem or Am I doing something wrong?


Red indicator blinking means the device has successfully entered recovery mode, orange color would indicate the firmware booting normally.

Maybe you need to assign a static IP address to your network interface, if you had not previously connected to the device while it was running running OEM firmware (which has DHCP enabled I think).

Just pick something like with netmask, and you should be able to access the recovery at Upload works better with Chromium than with Firefox.

1 Like

That worked, thanks.

Was trying to assign it without router value, will try to flash it tomorrow or next week.

Additional information: on my devices, there is no ping response from the router in recovery mode. Looks like there is no ICMP support included. But the web interface for flashing the firmware was available.


Yes, the fact that it doesn't respond to ping cannot be emphasized enough — knowing this will save people a lot of time. :slight_smile:

Thank you for all your work on the DAP-X1860 @RolandoMagico!


Since LED's are not working similarly to OEM for this device,

maybe following info will help anybody who might be interested in adding these features (I have no intention to add this myself and i do not think that led's are very important, but who knows. Maybe somebody else has a desire to make them work):

We have all the allvailable LED GPIOs declared in the dts, they are controlled by the MT7621 directly, i.e. not addressable or requiring any separate driver (like e.g. Ubiquiti AirCube devices).

Except for the bootup blinking sequence, there is not much default LED behaviour in OpenWrt, except for Ethernet ports or (single band) wireless radios. Since this device has no separate LEDs for 2.4 / 5 GHz, I think there is currently no way of e.g. having a throughput indicator that covers both bands with a single LED. Also that is not what the OEM firmware would do, I think the Power / Status LED is just permanent on in normal operation?

What is the expected LED behaviour you would like to see in OpenWrt?

Just for the record. As I said, LED behaviour is low priority in my opinion, but if anybody were to work on this, then the following would be kinda expected: LED is green, instead of orange, if wifi is on/connected. Green is a signal colour for "everything is alright", whereas orange/red is a signal colour for "look out".

When i was running this device with OEM software, there were two things that stood out:

  1. When wifi was on (2.4 and 5 GHz were automatically configured to be on the same SSID), the leds were constantly shining in green light (no blinking, if i remember right. Just constantly on).
  2. There were blinking patterns for resetting and recovery mode (orange light)

Now with OpenWrt:

  1. When wifi is on; LEDs are constantly on, but with orange light.
  2. I would need to check, if blinking patterns for resetting and recovery mode changed, but i don't want to reset my current config :smiley:

This refers to the RSSI bargraph LEDs, not the main / status LED with OEM firmware?

According to the OEM manual (and consistent with other DAP devices) there should have been a reg/green status LED, but for this device, there is only red / orange. The same is for the lowest bargraph display, it should have been red / green, but it was populated incorretly as well.
So only the upper two bargraph indicators can actually produce green light.

Maybe they will fix this in later versions? But I don't believe there will ever be another version of this one, and if they had fixed the LEDs with newer batches, you would see green instead of orange already.

In the meantime, just get a soldering iron and a bunch of 0603 green LEDs :sweat_smile:

1 Like

Ah, got it. Thanks for the explanation!

I updated the preliminary device page to include the flash procedure, a picture and more hardware specs for this device . I also updated the "techdata" page to include more details and added wifi capabilities, which triggered an update of the table of hardware (toh). Is this enough to mark this device as "supported"?