OpenWrt support for Asus RT-AX53U

Does anyone know what the difference is between RT-AX53U and RT-AX1800U? They look exactly the same to me, even the downloadable fw is the same. But when I check the prices, RT-AX1800U only costs half as much.

1 Like

The comparison view on their site lists the RT-AX1800U as Dual-core but the RT-AX53U as Dual-core (4 VPE). It also seems to mistakenly (?) imply the RT-AX1800U does not support "AX Technology" but maybe that's some sort of goofy Asus thing.

I could not resist, bought one for $39+tax. Same router. The "802.11ax / WiFi 6 mode" option is there. Still 80mhz, so not the fastest. It replaces a TL-WDR4300, so a nice upgrade for me.

ok, the curious thing is the mesh work fine between QCA9560 802.11bgn wireless device from my tp-link archer c7 v5 and MT7915E 802.11axbgn wireless device from asus RT-AX53U, in mode N, chanel1, 40 Mhz, i have average 150-160 Mbps download and upload
It is between MT7915E 802.11axbgn from asus and QCA9880 802.11nac from archer c7 that's not work well (see my previous post)

unable to find prices for the rt ax1800u model. Only rt-ax53u is available.

What is 4 VPE?

Could be a regional thing. It's available here in Hungary AX1800U vs AX53U. Only since May.

that is firmware driver problem change that. ath10k non ct

i replace kmod-ath10k-ct by kmod-ath10k, it doesn't change anything my ath10 app are ath10k-board-qca988x ath10k-firmware-qca988x. Curious thing, putting my asus as a repeter wi-fi, the bandwidth is correct (250-260 Mbps) i really don't understand

Should we still be flashing to "Kernel" partition instead of "linux"? I can see the wiki entry still says to flash to "linux" but i wasn't sure if that was because it just hasn't been updated to reflect this thread or things had moved on?

This router has just featured on HotUKDeals well discounted and with Open-WRT as a selling point, so I expect it will be getting a few more users this week!

With rc6 and current stable 22.03.0, i have very good WiFi perf between my iPhone12 and RT-AX53U AP

With WiFi problem, ** always ** check channel usage, and change configuration setting if necessary:

lucy / Status / Channel Analysis

22.03.0 was release but it seems to me that /overlay partition still @ 33 MB in this version ?

After flashing I noticed the switch menu in luci is missing, and the hardware overview has a ¿ for the 'vlan' entry. Is there any known information on whether this device supports VLAN?

1 Like

I noticed that too. Maybe it's under Network/Interfaces/Devices, br-lan Configure.../Bridge VLAN filtering. There if you click the Add button, you can configure the VLANs very similary.


Yep, that solved it. Took a while to figure out the new interface, here is a conversion guide for anyone looking for it:

1 Like

I was looking at this failed patch

It seems it did not go through because of formalities, but it also would have allocated rootfs till the end of the nand, overwriting the bad block (?) area, which is necessary for the bootloader.

Alisa900 also suggested to add mediatek,nmbm;

Is the current firmware even safe to use without the kernel initalizing NMBM? Whatever that may be.

Submitted a new patch, hopefully it gets approved this time. Having more space is nice, no need for extroot with this much, the single USB port can be used for something else.


What am I doing wrong? I install according to the OEM easy installation instructions, I reboot from the web interface, but nothing but the router does not load, the wifi lights do not even light, and I cannot log in via ssh

Have you tried with a lan cable on (user: root, pw: nothing)

The machine you are connecting from should also have a similar IP from the same network. ie. IP, gateway, mask

yes, it turned out the second time, I didn't understand what the problem was.

This topic was intended for adding support for this specific device.
Since official 22.03.0 images are available now, I will set a timer for this topic to close.


Because specific problems for this device with official releases are better handled in separate topics, in order to make finding relevant information easier. Who is going to read the previous 100-something postings, if he has a specific problem with 22.03.0 and wifi?

Therefore: Please open new topics for any open issues with this device.

Thanks! :slight_smile: