OpenWrt Support for Armor G5 (NBG7815)

thanx for your help. but it dont work. i have internet but it dont install.
image

I'm sorry.
I forgot to say opkg update before install.

Thank you very much. now it works. than foor your help.

Hi! I just updated to @asvio s new build, and I do have a problem. Now, a bit of context I am using my device only as a "dumb" AP, and have been using it as this on @psychowood s builds before without a problem.

I have a problem where all WIFI interfaces only accept 2 devices - the devices that try to connect after these 2 will not get an IP from the DHCP server (they get only a fe80 IPv6, although I do not have IPv6 configured on the AP at all). This has been working fine before, and I did not change anything with the DHCP server. Now, when I set a static IP onto the devices that did not receive an IP, they work fine.

I will provide logs, but I am not sure which yet. Please excuse my explaining, I am really bad at it.
Thank you!

@avsio I haven't been able to do other connection tests but I wanted to restore first the original firmware but... I wasn't able to have any result with the change_boot_partition.sh script.

There is no option for qualcommax/ipq807x in the conditions and I am not sure what would be the best option to restore it.

Anyone has any clue on what to do for restoring the original firmware with qualcommax/ipq807x openwrt_type?

Search the thread. There are several ways to do it.
The tftp method is the one I have always used.

Hey, Asvio,
First I d'like to thank you for your great work. Your build works great ( 6.)1 r23880+54-8554a4a7e3 -. There is just one thing that doesn't. Wireguard is unstable and slow. Let me know if can provide logs. Which logs would you need?

1 Like

I've just installed the same build, and while it looks like everything is working, I notice very slow download speed, the speedtest is stuttering quite a lot in download (tops at 20Mbps out of a 1Gpbs connection threat usually gives at least 300Mbps) while is ok in upload (250-ish).

@asvio do you think you could share a non-NSS build with the same baseline and build settings, to allow some debugging/comparison?

1 Like

Is your Speedtest test results over vpn?
Over wifi or wired?

In a few minutes you will have it.

EDIT: nbg7815-230803 without nss. Drirect Link to sysupgrade file

2 Likes

I need to do more tests, but right now it's both wired and wireless, even when running the speedtest from the router itself. Keep in mind that my configuration is a bit unusual, my ISP has a native ipv6 connection with a MAP-E 4in6 encapsulation.

If problems is only on the nss-build firmware try different ecm config parameters.

uci set ecm.@general[0].enable_bridge_filtering='0'

and restart service ecm and network.

You can also try with

uci set ecm.@general[0].disable_offloads='1'

and restart services

Verify Packet Steering is off on nns network/interfaces/global network options config.

I would like issues that affect only the nss version to be discussed in the ipq807x nss offloading thread.

2 Likes

A dirty flash with the lastest non nss-build fixed the issue, thanks.
I'll report back on the other thread as soon as I'm able to reflash w/ nss.

i have the 230821 and no problem at all with the wifi (800+mbps), packet steering is disabled and my ecm content is this;

config ecm 'global'
	option acceleration_engine 'auto'

config general
	option enable_bridge_filtering	'1'
	option disable_offloads '1'
	option disable_flow_control '0'
	option disable_interrupt_moderation '0'

My ecm is the same except for offloads that were not disabled.

config ecm 'global'
	option acceleration_engine 'auto'

config general
	option enable_bridge_filtering	'1'
	option disable_offloads '0'
	option disable_flow_control '0'
	option disable_interrupt_moderation '0'

Would you mind updating to 230803? Regardless of the name is newer than yours.

Let's move on the other thread as per asvio's request :+1:

230803 it was a typo I didn't realize until this morning. It sould had been 230903

This parametres has no influences at all on wifi.

I can't understand why sometimes works and sometimes doesn't without change anything.

And only with some ax clients: iPhones, intel.. Fire stick 4k max work without problems

My ac clients always works fine and better than on netgear r7800 that is one of the best ac router.

I've reached 625 Mbits dowload with this zyxel on 2x2 ac clients.

I have always thought that it has been a problem with the board2.bin together with the ath11k firmware.

1 Like

While reading this (translated) review of the G5 on koolcenter, I noticed the build they where using had both NSS and 160MHz bands working, so I tried to look around to see if I could find that build source.

Long story short, it should be the one available on openwrt.ai, build can be customized on demand or can be downloaded a standard build here..

It looks like even sources with patches are available, kernel included.

Who dares to try it? :kissing:

1 Like

yes the link was posted about a year ago in the first replies of this thread by @evlo, never tried it though

I flashed it to my device. I Immediately rolled back. There was no problem returning.

  • Wi-Fi not work.
  • Led driver is not included.
  • There are plenty of bloatware packages.

Hi! So I've flashed in on my router. There are a few interresting things about this build, I will go over those in a bit.
Keep in mind that I have done a clean flash, and manually deleted the whole /etc/config directory, just to be safe. Also keep in mind that I did not test anything outside the "dumb" mode, so I do not know if NSS works.

I also customised my build a little bit on their website. This is what I set:


(Underlined text is important for wifi to appear in LUCI ... for some reason)

I found some interresting things.

  • To get this out of the way, I could not get 160MHz to work, it had the same behaviour as other forks on this forum. However, this might just be that my router is somehow defective? I actually never got my phone or my quest 2 to discover the 160MHz wifi even on the stock firmware.

  • You can for some reason select 160MHz on the second 5GHz radio as well, but when you apply these settings, the interface just gets disabled.

  • 5GHz radio 1 performance seems to be terrible for some reason. I only got 180Mbps at best with my Nothing Phone 2

  • If you build the firmware like I did, there is very little bloatware, the only apps installed seem to be just some LUCI config addons for stuff like DNSmasq, and some weird system upgrade feature that does not work.

  • The 5GHz radio 2 seems to work fine but is limited to channels 44 and 48.

  • LED control does not work.

  • I could not get it to control the fan, even the way that is described on the forum (that would be through the LED configuration - the only LED option is mmc0:: )

  • You can change the CPU governor and frequency through LUCI - CPU Freq Settings

  • Also, one more thing, I had problems with assigning IPs to my devices when using the router in "dumb" mode (when using the latest forks on this forum). On this fork, it seems to work fine.

This is about all that I found, remember that I really do not know anything about the OpenWRT code/kernel, I just tested what I understood.
If you have any more questions, I would be happy to test them.