Openwrt strange behavior

OpenWrt 18.06.9 installed on TP-Link TL-WR841N/ND v9.

The router is functioning properly when connected to router A wirelessly as an internet source.

However, when i commect to router B, internet connection will get disconnected from time to time, Luci access will be lost from time to time, WiFi signal will be lost also from time to time.

Everything will be ok when i reconnect back my router to router A.

Any solution or idea for what is happening?

This version is long since EOL and unsupported. There are many known security vulnerabilities, so you should consider upgrading to modern versions of OpenWrt.

This is a 4/32 unit, so it's not capable of running a more recent version of OpenWrt. As a result, you should probably be considering new hardware -- especially because it is possible that the issue is failing hardware.

That said, we can take a quick look at your config (but keep in mind -- you'll get at best a best-effort attempt at debugging here as the version is so old that the syntax has changed materially in the ensuing 4 major releases):

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
1 Like

With a STA and an AP running on the same radio, the STA must have a connection to its AP (upstream device you call A) before the local AP can be started up and go on the air. If the connection is lost, the local AP will go off the air until the STA is able to reconnect. This is true of all versions and different hardware.

There is a workaround provided by the travelmate package which will detect the loss of connection and disable the STA function so that the local AP can continue to work. As the name suggests it is intended for use where the router is moved from place to place. If you are using this at a fixed location and the AP-STA link is still intermittent, it would help to move closer or improve the signal strength with better antennas.

"kernel": "4.9.243",
"hostname": "OpenWrt",
"system": "Qualcomm Atheros QCA9533 ver 1 rev 1",
"model": "TP-Link TL-WR841N/ND v9",
"board_name": "tl-wr841n-v9",
"release": {
"distribution": "OpenWrt",
"version": "18.06.9",
"revision": "r8077-7cbbab7246",
"target": "ar71xx/tiny",
"description": "OpenWrt 18.06.9 r8077-7cbbab7246"
}
}

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd8f:f185:416a::/48'

config interface 'lan'
option type 'bridge'
option ifname 'eth0.1'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'

config interface 'wan'
option ifname 'eth1'
option proto 'dhcp'

config interface 'wan6'
option ifname 'eth1'
option proto 'dhcpv6'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '1 2 3 4 0t'

config interface 'wwan'
option proto 'dhcp'

config interface 'wwan11'
option proto 'dhcp'

config wifi-device 'radio0'
option type 'mac80211'
option hwmode '11g'
option path 'platform/qca953x_wmac'
option htmode 'HT20'
option country 'US'
option legacy_rates '1'
option channel '3'

config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'OpenWrt'
option encryption 'psk2'
option key '20001000'

config wifi-iface
option network 'wwan'
option ssid 'Dragon'
option encryption 'psk2'
option device 'radio0'
option mode 'sta'
option bssid '08:40:F3:23:5F:D1'
option key '28872887'

config wifi-iface
option network 'wwan11'
option ssid 'Noor'
option encryption 'psk2'
option device 'radio0'
option mode 'sta'
option bssid 'C8:3A:35:16:EE:00'
option key '50005050'
option disabled '1'

config dnsmasq
option domainneeded '1'
option boguspriv '1'
option filterwin2k '0'
option localise_queries '1'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option nonegcache '0'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.auto'
option nonwildcard '1'
option localservice '1'

config dhcp 'lan'
option interface 'lan'
option start '100'
option limit '150'
option leasetime '12h'
option dhcpv6 'server'
option ra 'server'

config dhcp 'wan'
option interface 'wan'
option ignore '1'

config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'
option loglevel '4'

config defaults
option syn_flood '1'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'

config zone
option name 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
option network 'lan'

config zone
option name 'wan'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'
option network 'wan wan6 wwan wwan11'

config forwarding
option src 'lan'
option dest 'wan'

config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'

config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'

config rule
option name 'Allow-IGMP'
option src 'wan'
option proto 'igmp'
option family 'ipv4'
option target 'ACCEPT'

config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option src_ip 'fc00::/6'
option dest_ip 'fc00::/6'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-MLD'
option src 'wan'
option proto 'icmp'
option src_ip 'fe80::/10'
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-IPSec-ESP'
option src 'wan'
option dest 'lan'
option proto 'esp'
option target 'ACCEPT'

config rule
option name 'Allow-ISAKMP'
option src 'wan'
option dest 'lan'
option dest_port '500'
option proto 'udp'
option target 'ACCEPT'

config include
option path '/etc/firewall.user'