OpenWrt "sta" mode clients timeout (fixed by rebooting AP)

I have a few OpenWRT (ath9k) 19.07.x devices in "sta" mode that stopped authenticating :

daemon.notice wpa_supplicant[1465]: wlan0: CTRL-EVENT-SSID-REENABLED id=0 ssid="db120"
daemon.notice wpa_supplicant[1465]: wlan0: SME: Trying to authenticate with a0:f3:c1:xx:yy:zz (SSID='db120' freq=2462 MHz)

kern.info kernel: [  595.438668] wlan0: authenticate with a0:f3:c1:xx:yy:zz
kern.info kernel: [  595.454667] wlan0: send auth to a0:f3:c1:xx:yy:zz (try 1/3)
kern.info kernel: [  595.610047] wlan0: send auth to a0:f3:c1:xx:yy:zz (try 2/3)
kern.info kernel: [  595.730054] wlan0: send auth to a0:f3:c1:xx:yy:zz (try 3/3)
kern.info kernel: [  595.840044] wlan0: authentication with a0:f3:c1:xx:yy:zz timed out

daemon.notice wpa_supplicant[1465]: wlan0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="db120" auth_failures=10 duration=90 reason=CONN_FAILED

All my Fedora "sta" mode devices auth OK (ath9k & iwl7265).

The "access point" is running OpenWRT (ath79) 19.07.7. It's was up for 17 days. I don't see any info in logread to explain the auth time outs. When I reboot the access point, all the OpenWRT "sta" mode clients authenticate. I did not see this behavior in previous versions of OpenWRT.

I would guess this is some kind of hostapd bug (wpad-basic 2019-08-08-ca8c2bd2-5).

Are there any debug flags I could use to isolate this. Or workarounds ? I suppose I could reboot the AP every 17 days or revert to OpenWRT 19.07.5 ...

Now that I think about it ... the AP is "dual band", so it's likely that all there was a problem w/ the 2.4 GHz radio / hostapd and the other "sta" clients (Fedora & Android) were using 5 GHz ...