Openwrt Speedtest issue when using passwall

Hey guys, I have a Linksys MR8300 with OpenWRT installed on it (OpenWrt 23.05.3 r23809-234f1a2efa / LuCI openwrt-23.05 branch git-24.073.29889-cd7e519).
The topology is this. I have a Huawei modem which is fiber optic with a speed of 200mbps, and I connected my Linksys to my Huawei. When I connect to Linksys with my MacBook and do a speed test, it gives me 20mbps speed, but when I connect to Huawei with my MacBook, it gives me 200mbps. I use both cable and Wi-Fi. What is the problem with this Linksys and OpenWRT?
Also, another weird thing is that when I connect to Linksys with my iPhone, it gives me 80mbps. I also searched a lot and enabled options like (packet steering or software flow offloading), but nothing happened.
If you need any special data or config, please let me know.

Passwall is not from openwrt.org, ask where you got it from.

The issue is not about Passwall. This problem is about OpenWRT.

then uninstall passwall, or reset router, and redo your tests.

I did those before OpenWRT. I used Linksys’s default os and did not have speed issues.

did the linksys default os have passwall too ?

no. do you know what a PASSWALL is?

so you're comparing apples and bananas, awesome ...

do you know what APPLES and BANANAS are ?

2 Likes

LAMO, man I believe there must be a special config that I must set on my OpenWRT and it will fix the issue. If you don’t know that, why bother me?

Pushing your misconceptions will not lead you anywhere.
Can you repeat your slownesstest without any p?sswall?
Post

ubus call system board
cat /etc/config/network
cat /etc/config/firewall

And speedtests (precise links to results) obtained via https://www.waveform.com/tools/bufferbloat

While the tone in this thread is not as friendly as it arguable should be, the point is that when diagnosing issues like yours, it really helps to try to isolate the issue first.
If passwall does what I assume it does this is something that you should disable for initial tests. It is well possible that your passwall is innocent and has nothing to do with the issue, but the quickest way to assure that is to do one of your tests with and without passwall.

In general posting data from your tests would help. Not sure about the availability in your region, but generally the following tests work well with cloudflare's CDN:

https://www.waveform.com/tools/bufferbloat

Maybe disable passwall and then run 3 tests each with:

  1. macbook wired to huawei
  2. macbook wired to linksys wired to huawei
  3. macbook WiFi to linksys wired to huawei
    and post screenshots to this thread, thanks in advance.
2 Likes

OK

ubus call system board
{
        "kernel": "5.15.150",
        "hostname": "OpenWrt",
        "system": "ARMv7 Processor rev 5 (v7l)",
        "model": "Linksys MR8300 (Dallas)",
        "board_name": "linksys,mr8300",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05.3",
                "revision": "r23809-234f1a2efa",
                "target": "ipq40xx/generic",
                "description": "OpenWrt 23.05.3 r23809-234f1a2efa"
        }
}

and

iwinfo
phy0-ap0  ESSID: "malwareDotExe"
          Access Point: C6:41:1E:0E:56:C3
          Mode: Master  Channel: 136 (5.680 GHz)  HT Mode: VHT80
          Center Channel 1: 138 2: unknown
          Tx-Power: 24 dBm  Link Quality: 26/70
          Signal: -84 dBm  Noise: -102 dBm
          Bit Rate: 370.0 MBit/s
          Encryption: WPA3 SAE (CCMP)
          Type: nl80211  HW Mode(s): 802.11ac/n
          Hardware: 168C:0056 0000:0000 [Qualcomm Atheros QCA9886]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy0

AND

cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd0b:5608:6e1b::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config device
        option name 'lan1'
        option macaddr 'c4:41:1e:0e:56:c0'

config device
        option name 'lan2'
        option macaddr 'c4:41:1e:0e:56:c0'

config device
        option name 'lan3'
        option macaddr 'c4:41:1e:0e:56:c0'

config device
        option name 'lan4'
        option macaddr 'c4:41:1e:0e:56:c0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'wan'
        option macaddr 'c4:41:1e:0e:56:bf'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'

config interface 'testwwan'
        option proto 'dhcp'

AND

cat /etc/config/firewall

config defaults
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option synflood_protect '1'
        option flow_offloading '1'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        list network 'wan'
        list network 'wan6'
        list network 'testwwan'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'
config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'
config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config include 'passwall2'
        option type 'script'
        option path '/var/etc/passwall2.include'
        option reload '1'

config include 'passwall2_server'
        option type 'script'
        option path '/var/etc/passwall2_server.include'
        option reload '1'

Add

option enabled '0'

to these both sections and redo test with exactly waveform.

2 Likes

Indeed, you are correct. The issue lies with the Passwall. Could you kindly advise me on the appropriate steps to address this situation?

LOL, might want to readd it to the text again ...

:))) OK MAN. you won!

Ask where you got broken software from? Nothing to do with OpenWRT.

This is the repo

Since this package did not come from OpenWr, please ask the maintainer (xiaorouji) or the user community for that package on their respective forums. Help is not available for this package here.

1 Like