Openwrt snapshot and 22.03.0-rc4 boot issue on Netgear WNDR4700

Hi, is anyone else having issues flashing RC4 or snapshot builds on the Netgear WNDR4700? After I tried snapshot and RC4 the router went into TFTP mode and I had to revert back to stock and reinstall with Openwrt 21.02.3. This seems to be the last version that successfully flashes from stock.

I also saw this:

Anyone know what the change was?


Have you tried the troubleshooting steps suggested by the developer in that bug report?

Did you brick your device by sysupgrading from 21.02? Or did you flash a factory image through TFTP?

1 Like

I haven't tried serial console yet, will do that later. I see in the dev's notes there's a setenv bootcmd. Wouldn't that be set by the openwrt factory image?

The device bricks going from stock to openwrt factory image for snapshot and RC4. It also bricks when sysupgrading from 21.02 to snapshot.

No, OpenWrt by default does not touch the bootloader. You wouldn't be able to revert to stock anymore that way either, probably.

I see. Thanks Borromini. I also read Chunkeey's notes here and it explains exactly why the WNDR4700 is hanging on boot with these newer builds.

I will definitely make the change in the serial console and report back.


Running the following serial console commands from Chunkeey worked!

0. Power-off the WNDR4700

  1. Connect the serial interface (you need to open the WNDR4700)
  2. Power-up the WNDR4700
  3. Monitor the boot-sequence and hit "Enter"-key when it says:

"Hit any key to stop autoboot" (Be quick, you have a ~2 second window)

  1. in the Prompt enter the following commands (copy & paste)
setenv bootcmd "if loadn_dniimg 0 0x180000 0xae0000 && chk_dniimg 0xae0000; then bootm 0xb00000 - 0xae0040;else fw_recovery; fi"
run bootcmd

Thanks to Chunkeey and Borromini for the help!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.