OpenWrt router & isp gateway config

Ive been troubleshooting using openwrt router instead of isp gateway for over a week now. Unable to find tutorials on configuration, only flashing. Links on openwrt site proved to be unhelpful. Can anyone either send a link or assist in basic setup. Gateway bridged. No access to outside network. Can't get online. I want detailed step by step instructions to be able to use router. Lan and wan interface config as well as anything necessary to establish a viable connection. Thanks in advance.

First question, what settings did the isp require you to use with the gateway

None what so ever. Called isp (Cox) got it plaaced in bridge mode but thats it.

It might be just dhcp on the Wan in that case , just follow the steps here https://smallbusiness.chron.com/getting-linksys-router-work-cox-38427.html
Upto step 6.

Just use the default openwrt settings to start. Reset your settings if you have made changes that might effect your internet connection

1 Like

followed instructions. no luck. restored settings. awainting further instruction

If this is a cable/DOCSIS link, make sure to both reboot the modem and the router, as docsilis mandates that the modem will only allow DHCP to devices on its LAN side in a short time window after starting up.

This is why the instruction mbo2o linked propose this dance with unplugging and replugging modem and router.

ive heard that. whats the window duration and start/stop time? also gateway has routers address as static. and dmz host. an plugged into port 1 of gateway

also modem dhcp server is off. hopefully that isnt the problem. couldnt find info on that question

No idea, I believe the DOCSIS standards, available at the cablelabs website should have more information. My first hand docsis experience ended 2013, so excuse my approximateness...

That seems wrong to me, if the modem truely in in bridge mode then this should not be necessary. Did you do this or was this the result of cox switching you to "bridge" mode? In the latter case it might be okay, in the first case you might want to try without...

Good question, with a true bridge mode it should not matter, but who knows what cox calls "bridge" here...

i configured it that way. ill restore gateway settings and try again. one moment

1 Like

resetted everything. upon reconfiguration realized dmz host only would pass wan address to router. dhcp server disabled. thanks for all your help

Could you please explicitly tell the solution to your issue? That way this thread might be helpful to other's in a similar situation. Also you might want to mark this thread as solved....

Dhcp server on or off didn't matter. Tried no luck. set as dmz host in gateway and worked.

So you basically removed the router address as static?

Yes. After resetting everything to defaults

Did you have a look at this?
https://openwrt.org/docs/guide-user/network/wan/isp-configurations?s[]=te%20data

This is likely the issue.

  • How do you expect the OpenWrt device to get an IP address?
  • Have you enabled use of the broadcast flag to test?

Screenshot%20from%202019-03-27%2009-50-43

No didn't enable broadcast flag. And I'm also sure ship server should be up. Dmz host settings more than likely assigned ip address. Works now and I'm not messing with it. This was an arris tg1682g from cox and a router with chaos calmer 15.05 luci. Have a good day everyone. Thanks for the assistance

1 Like