OpenWrt router as a tracker in Home Assistant - Problem: empty ARP table

Hello all,

I use "TP-Link Archer C7 v2" router with OpenWrt 19.07.5 r11257-5090152ae3 / LuCI openwrt-19.07 branch git-20.341.57626-51f55b5
I have 2 SSID set up on 2 different VLAN.
I would like to use my OpenWRT router as a tracker in Home Assistant for 1 SSID (https://www.home-assistant.io/integrations/luci/).

But, I have a problem. The router ARP table doesn't seem to update.

In the ARP table, I only see the mac of the pfsense gateway :

root@OpenWrt:~# arp
IP address       HW type     Flags       HW address            Mask     Device
XXX.XXX.XXX.X    0x1         0x2         XX:XX:XX:XX:XX:XX     *        br-lan

My configuration :

Since the router doesn't deliver DHCP, it may be normal but I have my doubts. And I think there might be an alternative...
Do you have an idea ?

My configuration :

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd49:2e10:9022::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth1.1'
        option proto 'static'
        option netmask 'XXX.XXX.XXX.XXX'
        option ipaddr 'XXX.XXX.XXX.X'
        option gateway 'XXX.XXX.XXX.X'
        list dns 'XXX.XXX.XXX.X'
        list dns 'XXX.XXX.XXX.XXX'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 2 3 4 5'
        option vid '1'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '1 6t'
        option vid '2'

config switch_vlan
        option device 'switch0'
        option vlan '3'
        option ports '0t 2t'
        option vid '20'

config interface 'SSID_1'
        option ifname 'eth1.20'
        option type 'bridge'
        option proto 'none'

config switch_vlan
        option device 'switch0'
        option vlan '4'
        option ports '0t 2t'
        option vid '10'

config interface 'SSID_2'
        option proto 'none'
        option type 'bridge'
        option ifname 'eth1.10'

Thanks & regards,

Check here, it has been discussed before.

1 Like

Hello trendy,

Thanks for your response.
I tried to untick "Filter private" in the Advanced Settings under the Network >> DHCP and DNS but no change.

In the ARP table, I still have only one MAC (the MAC of the pfsense gateway).
I think that's my problem and that's why Home Assistant doesn't have the information.

root@OpenWrt:~# arp
IP address       HW type     Flags       HW address            Mask     Device
XXX.XXX.XXX.X    0x1         0x2         XX:XX:XX:XX:XX:XX     *        br-lan

I don't know why the ARP table doesn't list the MAC addresses of the devices and even of my "lan" interface. Is it normal? How can I do it ?

Thanks and regards.

Unless a client requests a layer 3 connection with the kernel in the AP, an ARP will not be performed. Ordinarily a dumb AP bridges all clients direct to the main router at layer 2.

That is done with a sort of virtual unmanaged switch that only looks at the MAC address of the packets. It never considers IP addresses. The ARP table which is an index of IP to MAC is not involved.

Read the whole topic, the filter private was not the solution. You need to make the access point communicate with the wireless hosts. An ping-swipe is described in the topic, or you can look for solutions like fping.

Hello @trendy @mk24,

Thanks for your response !
I don't really understand the end of the topic. So, I think that I will try another tracker directly in Home Assistant like NMAP. If I use a solution like fping on the OpenWRT router and then send the result back to Home Assistant it will make the process more cumbersome.

Thanks & regards !