OpenWrt relay proxy athentication to VPN

In order to access the internet on my device I use a custom Mullvad OpenVPN script that authenticates a proxy before running on port 8080 .

Lately I've been trying to run an Android/Chrome OS variation of the script on a router as per the Mullvad router guide. After uploading the config created a file at /etc/openvpn/key containing my proxy username and password and turning off 'Use DNS servers advertised by peer' it still failed to run. I've attempted to authenticate with the following snippets but they all give errors in system log.

http-proxy [proxy ip] 8080 key ntlm

ERROR: unknown HTTP authentication method: 'ntlm'
http-proxy [proxy ip] 8080 key auto

ERROR: unknown HTTP authentication method: 'auto'
http-proxy [proxy ip] 8080 auto

Note: option tun-ipv6 is ignored because modern operating systems do not need special IPv6 tun handling anymore.
DEPRECATED OPTION: --cipher set to 'AES-256-CBC' but missing in --data-ciphers (AES-256-GCM:AES-128-GCM). Future OpenVPN version will ignore --cipher for cipher negotiations. Add 'AES-256-CBC' to --data-ciphers or change --cipher 'AES-256-CBC' to --data-ciphers-fallback 'AES-256-CBC' to silence this warning.
OpenVPN 2.5.7 mipsel-openwrt-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [MH/PKTINFO] [AEAD]
library versions: OpenSSL 1.1.1s  1 Nov 2022, LZO 2.10
NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
TCP/UDP: Preserving recently used remote address: [AF_INET][proxy ip]:8080
Socket Buffers: R=[131072->360448] S=[16384->360448]
Attempting to establish TCP connection with [AF_INET][proxy ip]:8080 [nonblock]
TCP connection established with [AF_INET][proxy ip]:8080
Send to HTTP proxy: 'CONNECT [ip]:8080 HTTP/1.0'
Send to HTTP proxy: 'Host: [ip]'
HTTP proxy returned: 'HTTP/1.0 407 Proxy authentication required'
Proxy requires authentication
HTTP proxy: do not recognize the authentication method required by proxy
SIGUSR1[soft,init_instance] received, process restarting
Restart pause, 5 second(s)

Is there any reason why it might not be working on OpenWrt?

How are you trying to authenticate with the proxy?
Like in ?

Yes. I've tried the method mentioned in the article and while it works on my local device, it fails on the router.