Openwrt qca9880 ap+sta, bt home 5a, openwrt 22.03.5

openwrt qca9880 ap+sta, bt home 5a, openwrt 22.03.5

hello everyone, I would like some help, I configure ap + sta, in this router for wifi: qca9880 , only works sta or only works ap.

Has anyone had success in setting this parameter "ap + sta" on this hardware?

...
config wifi-device 'radio0'
	option type 'mac80211'
	option path 'pci0000:01/0000:01:00.0/0000:02:00.0'
	option channel 'auto'
	option hwmode '11a'
	option htmode 'VHT80'
	option require_mode 'n'
	option txpower '23'
	option cell_density '0'
...

config wifi-iface 'wifinet2'
	option device 'radio0'
	option mode 'ap'
	option ssid 'HOUSE'
	option encryption 'psk2'
	option key '1passwords2'
	option network 'lan'

config wifi-iface 'wifinet4'
	option device 'radio0'
	option mode 'sta'
	option ssid 'ISPINTERNET'
	option encryption 'psk2+ccmp'
	option key 'ZAQ!@WSXCDE#'
	option network 'wwan2'

I changed the essid and password data to paste what I have configured, everything else is a last minute copy of this interface.

In this configuration, it only connects to the ISPINTERNET router but does not propagate the internal ESSID of my AP.

root@OpenWrt:~# dmesg
[ 6181.546258] device wlan0-1 left promiscuous mode
[ 6181.549828] br-lan: port 5(wlan0-1) entered disabled state
[ 6181.784290] wlan0: deauthenticating from 14:49:bc:27:53:f8 by local choice (Reason: 3=DEAUTH_LEAVING)
[ 6181.827332] ath10k_pci 0000:02:00.0: mac flush vdev 1 drop 1 queues 0x2 ar->paused: 0x0 arvif->paused: 0x0
[ 6181.836004] ath10k_pci 0000:02:00.0: mac flush vdev 1 drop 0 queues 0x2 ar->paused: 0x0 arvif->paused: 0x0
[ 6181.847810] ath10k_pci 0000:02:00.0: mac flush vdev 1 drop 0 queues 0x2 ar->paused: 0x0 arvif->paused: 0x0
[ 6181.864784] ath10k_pci 0000:02:00.0: mac flush null vif, drop 0 queues 0xffff
[ 6185.383845] ath10k_pci 0000:02:00.0: 10.1 wmi init: vdevs: 16 peers: 127 tid: 256
[ 6185.399134] ath10k_pci 0000:02:00.0: wmi print 'P 128 V 8 T 410'
[ 6185.403743] ath10k_pci 0000:02:00.0: wmi print 'msdu-desc: 1424 sw-crypt: 0 ct-sta: 0'
[ 6185.412507] ath10k_pci 0000:02:00.0: wmi print 'alloc rem: 24984 iram: 38672'
[ 6185.478060] ath10k_pci 0000:02:00.0: pdev param 0 not supported by firmware
[ 6185.491950] ath10k_pci 0000:02:00.0: rts threshold -1
[ 6185.505033] br-lan: port 5(wlan0-1) entered blocking state
[ 6185.509297] br-lan: port 5(wlan0-1) entered disabled state
[ 6185.515416] device wlan0-1 entered promiscuous mode
[ 6186.852391] ath10k_pci 0000:02:00.0: rts threshold -1
[ 6203.141557] wlan0: authenticate with 14:49:bc:27:53:f8
[ 6203.153145] wlan0: send auth to 14:49:bc:27:53:f8 (try 1/3)
[ 6203.188551] wlan0: authenticated
[ 6203.197504] wlan0: associate with 14:49:bc:27:53:f8 (try 1/3)
[ 6203.241073] wlan0: RX AssocResp from 14:49:bc:27:53:f8 (capab=0x131 status=0 aid=2)
[ 6203.248517] ath10k_pci 0000:02:00.0: pdev param 0 not supported by firmware
[ 6203.254279] ath10k_pci 0000:02:00.0: failed to enable peer stats info: -122
[ 6203.262273] wlan0: associated
[ 6203.294627] wlan0: Limiting TX power to 20 (20 - 0) dBm as advertised by 14:49:bc:27:53:f8
[ 6203.408680] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready

root@OpenWrt:~# dmesg
[ 6181.546258] device wlan0-1 left promiscuous mode
[ 6181.549828] br-lan: port 5(wlan0-1) entered disabled state
[ 6181.784290] wlan0: deauthenticating from 14:49:bc:27:53:f8 by local choice (Reason: 3=DEAUTH_LEAVING)
[ 6181.827332] ath10k_pci 0000:02:00.0: mac flush vdev 1 drop 1 queues 0x2 ar->paused: 0x0 arvif->paused: 0x0
[ 6181.836004] ath10k_pci 0000:02:00.0: mac flush vdev 1 drop 0 queues 0x2 ar->paused: 0x0 arvif->paused: 0x0
[ 6181.847810] ath10k_pci 0000:02:00.0: mac flush vdev 1 drop 0 queues 0x2 ar->paused: 0x0 arvif->paused: 0x0
[ 6181.864784] ath10k_pci 0000:02:00.0: mac flush null vif, drop 0 queues 0xffff
[ 6185.383845] ath10k_pci 0000:02:00.0: 10.1 wmi init: vdevs: 16 peers: 127 tid: 256
[ 6185.399134] ath10k_pci 0000:02:00.0: wmi print 'P 128 V 8 T 410'
[ 6185.403743] ath10k_pci 0000:02:00.0: wmi print 'msdu-desc: 1424 sw-crypt: 0 ct-sta: 0'
[ 6185.412507] ath10k_pci 0000:02:00.0: wmi print 'alloc rem: 24984 iram: 38672'
[ 6185.478060] ath10k_pci 0000:02:00.0: pdev param 0 not supported by firmware
[ 6185.491950] ath10k_pci 0000:02:00.0: rts threshold -1
[ 6185.505033] br-lan: port 5(wlan0-1) entered blocking state
[ 6185.509297] br-lan: port 5(wlan0-1) entered disabled state
[ 6185.515416] device wlan0-1 entered promiscuous mode
[ 6186.852391] ath10k_pci 0000:02:00.0: rts threshold -1
[ 6203.141557] wlan0: authenticate with 14:49:bc:27:53:f8
[ 6203.153145] wlan0: send auth to 14:49:bc:27:53:f8 (try 1/3)
[ 6203.188551] wlan0: authenticated
[ 6203.197504] wlan0: associate with 14:49:bc:27:53:f8 (try 1/3)
[ 6203.241073] wlan0: RX AssocResp from 14:49:bc:27:53:f8 (capab=0x131 status=0 aid=2)
[ 6203.248517] ath10k_pci 0000:02:00.0: pdev param 0 not supported by firmware
[ 6203.254279] ath10k_pci 0000:02:00.0: failed to enable peer stats info: -122
[ 6203.262273] wlan0: associated
[ 6203.294627] wlan0: Limiting TX power to 20 (20 - 0) dBm as advertised by 14:49:bc:27:53:f8
[ 6203.408680] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 6685.778088] wlan0: deauthenticated from 14:49:bc:27:53:f8 (Reason: 3=DEAUTH_LEAVING)
[ 6685.864577] ath10k_pci 0000:02:00.0: mac flush vdev 1 drop 0 queues 0x2 ar->paused: 0x0 arvif->paused: 0x0
[ 6685.909467] ath10k_pci 0000:02:00.0: mac flush null vif, drop 0 queues 0xffff
[ 6686.375837] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0-1: link becomes ready
[ 6686.381297] br-lan: port 5(wlan0-1) entered blocking state
[ 6686.387511] br-lan: port 5(wlan0-1) entered forwarding state
[ 6691.038805] wlan0: authenticate with 14:49:bc:27:53:f8
[ 6691.044889] ath10k_pci 0000:02:00.0: mac flush null vif, drop 0 queues 0xffff
[ 6691.051492] br-lan: port 5(wlan0-1) entered disabled state
[ 6692.499926] br-lan: port 5(wlan0-1) entered blocking state
[ 6692.503990] br-lan: port 5(wlan0-1) entered forwarding state
[ 6696.158601] wlan0: authenticate with 14:49:bc:27:53:f8
[ 6696.164898] br-lan: port 5(wlan0-1) entered disabled state
[ 6696.166306] ath10k_pci 0000:02:00.0: mac flush null vif, drop 0 queues 0xffff
[ 6698.570160] br-lan: port 5(wlan0-1) entered blocking state
[ 6698.574229] br-lan: port 5(wlan0-1) entered forwarding state
[ 6701.458778] wlan0: authenticate with 14:49:bc:27:53:f8
[ 6701.465042] ath10k_pci 0000:02:00.0: mac flush null vif, drop 0 queues 0xffff
[ 6701.471547] br-lan: port 5(wlan0-1) entered disabled state
[ 6704.591163] br-lan: port 5(wlan0-1) entered blocking state
[ 6704.595300] br-lan: port 5(wlan0-1) entered forwarding state
[ 6711.929428] wlan0: authenticate with 14:49:bc:27:53:f8
[ 6711.937157] br-lan: port 5(wlan0-1) entered disabled state
[ 6711.943183] ath10k_pci 0000:02:00.0: mac flush null vif, drop 0 queues 0xffff
[ 6716.615209] br-lan: port 5(wlan0-1) entered blocking state
[ 6716.619276] br-lan: port 5(wlan0-1) entered forwarding state
[ 6726.748160] device wlan0-1 left promiscuous mode
[ 6726.751623] br-lan: port 5(wlan0-1) entered disabled state
[ 6726.793497] ath10k_pci 0000:02:00.0: mac flush null vif, drop 0 queues 0xffff
[ 6730.173579] ath10k_pci 0000:02:00.0: 10.1 wmi init: vdevs: 16 peers: 127 tid: 256
[ 6730.188760] ath10k_pci 0000:02:00.0: wmi print 'P 128 V 8 T 410'
[ 6730.193342] ath10k_pci 0000:02:00.0: wmi print 'msdu-desc: 1424 sw-crypt: 0 ct-sta: 0'
[ 6730.202571] ath10k_pci 0000:02:00.0: wmi print 'alloc rem: 24984 iram: 38672'
[ 6730.264926] ath10k_pci 0000:02:00.0: pdev param 0 not supported by firmware
[ 6730.278558] ath10k_pci 0000:02:00.0: rts threshold -1
[ 6730.289312] br-lan: port 5(wlan0) entered blocking state
[ 6730.293255] br-lan: port 5(wlan0) entered disabled state
[ 6730.299338] device wlan0 entered promiscuous mode
[ 6747.756162] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 6747.761601] br-lan: port 5(wlan0) entered blocking state
[ 6747.766502] br-lan: port 5(wlan0) entered forwarding state
[ 6835.054591] br-lan: port 6(wlan1-1) entered disabled state
[ 6835.433720] br-lan: port 6(wlan1-1) entered blocking state
[ 6835.437865] br-lan: port 6(wlan1-1) entered forwarding state
[ 6835.498705] wlan1: authenticate with 16:49:bc:47:53:f8
[ 6835.508795] wlan1: send auth to 16:49:bc:47:53:f8 (try 1/3)
[ 6835.603357] wlan1: authenticated
[ 6835.614581] wlan1: associate with 16:49:bc:47:53:f8 (try 1/3)
[ 6835.654069] wlan1: RX AssocResp from 16:49:bc:47:53:f8 (capab=0x431 status=0 aid=1)
[ 6835.660843] wlan1: associated
[ 7458.887782] device wlan0 left promiscuous mode
[ 7458.891124] br-lan: port 5(wlan0) entered disabled state
[ 7459.269791] ath10k_pci 0000:02:00.0: mac flush null vif, drop 0 queues 0xffff
[ 7461.419803] ath10k_pci 0000:02:00.0: 10.1 wmi init: vdevs: 16 peers: 127 tid: 256
[ 7461.434979] ath10k_pci 0000:02:00.0: wmi print 'P 128 V 8 T 410'
[ 7461.439560] ath10k_pci 0000:02:00.0: wmi print 'msdu-desc: 1424 sw-crypt: 0 ct-sta: 0'
[ 7461.448078] ath10k_pci 0000:02:00.0: wmi print 'alloc rem: 24984 iram: 38672'
[ 7461.511427] ath10k_pci 0000:02:00.0: pdev param 0 not supported by firmware
[ 7461.524592] ath10k_pci 0000:02:00.0: rts threshold -1
[ 7464.784234] wlan0: authenticate with 14:49:bc:27:53:f8
[ 7464.795489] wlan0: send auth to 14:49:bc:27:53:f8 (try 1/3)
[ 7464.805778] wlan0: authenticated
[ 7464.810600] wlan0: associate with 14:49:bc:27:53:f8 (try 1/3)
[ 7464.886575] wlan0: RX AssocResp from 14:49:bc:27:53:f8 (capab=0x131 status=0 aid=2)
[ 7464.895432] ath10k_pci 0000:02:00.0: pdev param 0 not supported by firmware
[ 7464.901231] ath10k_pci 0000:02:00.0: failed to enable peer stats info: -122
[ 7464.908051] wlan0: associated
[ 7464.961196] wlan0: Limiting TX power to 20 (20 - 0) dBm as advertised by 14:49:bc:27:53:f8
[ 7465.072257] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 7561.380226] wlan0: deauthenticating from 14:49:bc:27:53:f8 by local choice (Reason: 3=DEAUTH_LEAVING)
[ 7561.420019] ath10k_pci 0000:02:00.0: mac flush vdev 0 drop 1 queues 0x1 ar->paused: 0x0 arvif->paused: 0x0
[ 7561.428514] ath10k_pci 0000:02:00.0: mac flush vdev 0 drop 0 queues 0x1 ar->paused: 0x0 arvif->paused: 0x0
[ 7561.470036] ath10k_pci 0000:02:00.0: mac flush vdev 0 drop 0 queues 0x1 ar->paused: 0x0 arvif->paused: 0x0
[ 7561.503283] ath10k_pci 0000:02:00.0: mac flush null vif, drop 0 queues 0xffff
[ 7563.909723] ath10k_pci 0000:02:00.0: 10.1 wmi init: vdevs: 16 peers: 127 tid: 256
[ 7563.924970] ath10k_pci 0000:02:00.0: wmi print 'P 128 V 8 T 410'
[ 7563.929600] ath10k_pci 0000:02:00.0: wmi print 'msdu-desc: 1424 sw-crypt: 0 ct-sta: 0'
[ 7563.939230] ath10k_pci 0000:02:00.0: wmi print 'alloc rem: 24984 iram: 38672'
[ 7564.002343] ath10k_pci 0000:02:00.0: pdev param 0 not supported by firmware
[ 7564.014876] ath10k_pci 0000:02:00.0: rts threshold -1
[ 7568.285368] wlan0: authenticate with 14:49:bc:27:53:f8
[ 7568.297757] wlan0: send auth to 14:49:bc:27:53:f8 (try 1/3)
[ 7568.312928] wlan0: authenticated
[ 7568.320577] wlan0: associate with 14:49:bc:27:53:f8 (try 1/3)
[ 7568.393710] wlan0: RX AssocResp from 14:49:bc:27:53:f8 (capab=0x131 status=0 aid=2)
[ 7568.404379] ath10k_pci 0000:02:00.0: pdev param 0 not supported by firmware
[ 7568.410100] ath10k_pci 0000:02:00.0: failed to enable peer stats info: -122
[ 7568.417354] wlan0: associated
[ 7568.487113] wlan0: Limiting TX power to 20 (20 - 0) dBm as advertised by 14:49:bc:27:53:f8
[ 7568.571469] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 7612.221262] wlan0: deauthenticating from 14:49:bc:27:53:f8 by local choice (Reason: 3=DEAUTH_LEAVING)
[ 7612.259753] ath10k_pci 0000:02:00.0: mac flush vdev 0 drop 1 queues 0x1 ar->paused: 0x0 arvif->paused: 0x0
[ 7612.268458] ath10k_pci 0000:02:00.0: mac flush vdev 0 drop 0 queues 0x1 ar->paused: 0x0 arvif->paused: 0x0
[ 7612.299761] ath10k_pci 0000:02:00.0: mac flush vdev 0 drop 0 queues 0x1 ar->paused: 0x0 arvif->paused: 0x0
[ 7612.343878] ath10k_pci 0000:02:00.0: mac flush null vif, drop 0 queues 0xffff
[ 7615.066902] ath10k_pci 0000:02:00.0: 10.1 wmi init: vdevs: 16 peers: 127 tid: 256
[ 7615.082118] ath10k_pci 0000:02:00.0: wmi print 'P 128 V 8 T 410'
[ 7615.086702] ath10k_pci 0000:02:00.0: wmi print 'msdu-desc: 1424 sw-crypt: 0 ct-sta: 0'
[ 7615.095944] ath10k_pci 0000:02:00.0: wmi print 'alloc rem: 24984 iram: 38672'
[ 7615.159170] ath10k_pci 0000:02:00.0: pdev param 0 not supported by firmware
[ 7615.172421] ath10k_pci 0000:02:00.0: rts threshold -1
[ 7620.424152] wlan0: authenticate with 14:49:bc:27:53:f8
[ 7620.435383] wlan0: send auth to 14:49:bc:27:53:f8 (try 1/3)
[ 7620.451578] wlan0: authenticated
[ 7620.460448] wlan0: associate with 14:49:bc:27:53:f8 (try 1/3)
[ 7620.532315] wlan0: RX AssocResp from 14:49:bc:27:53:f8 (capab=0x131 status=0 aid=2)
[ 7620.541769] ath10k_pci 0000:02:00.0: pdev param 0 not supported by firmware
[ 7620.547437] ath10k_pci 0000:02:00.0: failed to enable peer stats info: -122
[ 7620.555463] wlan0: associated
[ 7620.640517] wlan0: Limiting TX power to 20 (20 - 0) dBm as advertised by 14:49:bc:27:53:f8
[ 7620.680882] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 7808.528547] ath10k_pci 0000:02:00.0: mac flush vdev 0 drop 0 queues 0x1 ar->paused: 0x0 arvif->paused: 0x0
[ 7808.572081] ath10k_pci 0000:02:00.0: mac flush null vif, drop 0 queues 0xffff
[ 7812.089110] br-lan: port 6(wlan1-1) entered disabled state
[ 7812.514955] wlan1: authenticate with 16:49:bc:47:53:f8
[ 7812.544418] wlan1: send auth to 16:49:bc:47:53:f8 (try 1/3)
[ 7812.636439] wlan1: authenticated
[ 7812.648597] wlan1: associate with 16:49:bc:47:53:f8 (try 1/3)
[ 7812.686970] wlan1: RX AssocResp from 16:49:bc:47:53:f8 (capab=0x431 status=0 aid=1)
[ 7812.693691] wlan1: associated
[ 7812.854433] br-lan: port 6(wlan1-1) entered blocking state
[ 7812.858561] br-lan: port 6(wlan1-1) entered forwarding state
[ 7821.128529] br-lan: port 6(wlan1-1) entered disabled state
[ 7821.474968] wlan1: authenticate with 16:49:bc:47:53:f8
[ 7821.506457] wlan1: send auth to 16:49:bc:47:53:f8 (try 1/3)
[ 7821.566400] wlan1: authenticated
[ 7821.578471] wlan1: associate with 16:49:bc:47:53:f8 (try 1/3)
[ 7821.616713] wlan1: RX AssocResp from 16:49:bc:47:53:f8 (capab=0x431 status=0 aid=1)
[ 7821.623455] wlan1: associated
[ 7821.784268] br-lan: port 6(wlan1-1) entered blocking state
[ 7821.788403] br-lan: port 6(wlan1-1) entered forwarding state
[ 7841.329720] ath10k_pci 0000:02:00.0: 10.1 wmi init: vdevs: 16 peers: 127 tid: 256
[ 7841.344846] ath10k_pci 0000:02:00.0: wmi print 'P 128 V 8 T 410'
[ 7841.349564] ath10k_pci 0000:02:00.0: wmi print 'msdu-desc: 1424 sw-crypt: 0 ct-sta: 0'
[ 7841.357939] ath10k_pci 0000:02:00.0: wmi print 'alloc rem: 24984 iram: 38672'
[ 7841.433124] ath10k_pci 0000:02:00.0: pdev param 0 not supported by firmware
[ 7841.445928] ath10k_pci 0000:02:00.0: rts threshold -1
[ 7844.784044] wlan0: authenticate with 14:49:bc:27:53:f8
[ 7844.795466] wlan0: send auth to 14:49:bc:27:53:f8 (try 1/3)
[ 7844.835336] wlan0: authenticated
[ 7844.848388] wlan0: associate with 14:49:bc:27:53:f8 (try 1/3)
[ 7844.885876] wlan0: RX AssocResp from 14:49:bc:27:53:f8 (capab=0x131 status=0 aid=2)
[ 7844.900094] ath10k_pci 0000:02:00.0: pdev param 0 not supported by firmware
[ 7844.905895] ath10k_pci 0000:02:00.0: failed to enable peer stats info: -122
[ 7844.913345] wlan0: associated
[ 7844.967174] wlan0: Limiting TX power to 20 (20 - 0) dBm as advertised by 14:49:bc:27:53:f8
[ 7845.080656] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 7992.941229] wlan0: deauthenticating from 14:49:bc:27:53:f8 by local choice (Reason: 3=DEAUTH_LEAVING)
[ 7992.967536] ath10k_pci 0000:02:00.0: mac flush vdev 0 drop 1 queues 0x1 ar->paused: 0x0 arvif->paused: 0x0
[ 7992.976519] ath10k_pci 0000:02:00.0: mac flush vdev 0 drop 0 queues 0x1 ar->paused: 0x0 arvif->paused: 0x0
[ 7993.007493] ath10k_pci 0000:02:00.0: mac flush vdev 0 drop 0 queues 0x1 ar->paused: 0x0 arvif->paused: 0x0
[ 7993.053017] ath10k_pci 0000:02:00.0: mac flush null vif, drop 0 queues 0xffff
[ 7998.244382] ath10k_pci 0000:02:00.0: failed to receive initialized event from target: 00000000
[ 7998.251684] ath10k_pci 0000:02:00.0: failed to wait for target init: -145
[ 7998.259070] ath10k_pci 0000:02:00.0: failed to warm reset attempt 1 of 3: -145
[ 7999.227530] ath10k_pci 0000:02:00.0: 10.1 wmi init: vdevs: 16 peers: 127 tid: 256
[ 7999.242712] ath10k_pci 0000:02:00.0: wmi print 'P 128 V 8 T 410'
[ 7999.247392] ath10k_pci 0000:02:00.0: wmi print 'msdu-desc: 1424 sw-crypt: 0 ct-sta: 0'
[ 7999.255740] ath10k_pci 0000:02:00.0: wmi print 'alloc rem: 24984 iram: 38672'
[ 7999.319719] ath10k_pci 0000:02:00.0: pdev param 0 not supported by firmware
[ 7999.333194] ath10k_pci 0000:02:00.0: rts threshold -1
[ 7999.343484] br-lan: port 5(wlan0-1) entered blocking state
[ 7999.347779] br-lan: port 5(wlan0-1) entered disabled state
[ 7999.354181] device wlan0-1 entered promiscuous mode
[ 8000.631833] ath10k_pci 0000:02:00.0: rts threshold -1
[ 8016.912110] wlan0: authenticate with 14:49:bc:27:53:f8
[ 8016.923310] wlan0: send auth to 14:49:bc:27:53:f8 (try 1/3)
[ 8016.930856] wlan0: authenticated
[ 8016.937969] wlan0: associate with 14:49:bc:27:53:f8 (try 1/3)
[ 8017.011393] wlan0: RX AssocResp from 14:49:bc:27:53:f8 (capab=0x131 status=0 aid=2)
[ 8017.020484] ath10k_pci 0000:02:00.0: pdev param 0 not supported by firmware
[ 8017.026157] ath10k_pci 0000:02:00.0: failed to enable peer stats info: -122
[ 8017.034264] wlan0: associated
[ 8017.100061] wlan0: Limiting TX power to 20 (20 - 0) dBm as advertised by 14:49:bc:27:53:f8
[ 8017.188645] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 8017.370290] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0-1: link becomes ready
[ 8017.375806] br-lan: port 5(wlan0-1) entered blocking state
[ 8017.381604] br-lan: port 5(wlan0-1) entered forwarding state

root@OpenWrt:~# opkg list-installed | grep ath10k
ath10k-board-qca988x - 20220411-1
ath10k-firmware-qca988x-ct - 2020-11-08-1
kmod-ath10k-ct - 5.10.176+2022-05-13-f808496f-1

"ath10k-firmware-qca988x-ct"

I don't suppose it will help, but have you tried swapping to the non -ct firmware and driver, on the off-chance it might be an issue with the Candela Tech firmware. Requires a reboot after installing.

(I've not tried either with AP + STA mode, I only swapped to the OEM firmware so that I could use mesh)

2 Likes

It did help on MikroTik RouterBOARD wAP G-5HacT2HnD

opkg remove ath10k-firmware-qca988x-ct-full-htt
opkg remove ath10k-firmware-qca988x-ct
opkg remove kmod-ath10k-ct-smallbuffers

reboot

opkg update
opkg install ath10k-firmware-qca988x
opkg install kmod-ath10k-smallbuffers

reboot

0 opkg remove ath10k-firmware-qca988x-ct-full-htt
1 opkg remove ath10k-firmware-qca988x-ct
2 opkg remove kmod-ath10k-ct
3 opkg update
4 opkg install ath10k-firmware-qca988x
5 opkg install kmod-ath10k-smallbuffers
6 opkg install mesh11sd
7 opkg remove wpad-basic-wolfssl
8 opkg install wpad-mesh-wolfssl

  • ath10k modulesPermalink

  • I’ve noticed that radio devices that use the ath10k module and more specifically, the ones using ath10k-firmware-qca988x-ct, are not able to operate in mesh point mode by default. If you check the syslog (logread), you’ll notice that there will be a few messages stating that the ath10k module must be loaded with rawmode=1 to allow mesh. However, I’ve tried that before without much success. Instead, my current recommendation to get mesh point working with any of the QCA988x hardware is the following (Internet connection required to download packages via opkg):

Even with the process above, I was unable to STA+AP on 5G ...

https://openwrt.org/toh/bt/homehub_v5a
Upgrade for : 23.05.2

cd /tmp
opkg update
opkg download wpad-mesh-openssl wpad-mesh-openssl hostapd-common libopenssl1.1
opkg download ath10k-firmware-qca988x kmod-ath10k-smallbuffers

opkg install mesh11sd

opkg remove ath10k-firmware-qca988x-ct-full-htt
opkg remove ath10k-firmware-qca988x-ct
opkg remove kmod-ath10k-ct
opkg remove wpad-basic-wolfssl

opkg install coreutils-nohup

nohup sh -c "opkg install --cache /tmp /tmp/*.ipk ; reboot -f " &

After mesh (without criptografy) work and master ssid in 5ghz

Internet i changed for wan interface (rede)

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'pci0000:01/0000:01:00.0/0000:02:00.0'
	option band '5g'
	option htmode 'VHT80'
	option cell_density '0'
	option log_level '2'
	option txpower '23'
	option channel '36'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option key 'mywifi'
	option encryption 'psk-mixed+ccmp'
	option ieee80211r '1'
	option nasid 'AAAAAAAA0001'
	option mobility_domain '0001'
	option ft_over_ds '0'
	option ft_psk_generate_local '1'
	option pmk_r1_push '1'
	option ieee80211k '1'
	option bss_transition '1'
	option ssid 'MY WIFY'
	option wnm_sleep_mode '1'
	option wnm_sleep_mode_no_keys '1'
	option proxy_arp '1'

config wifi-iface 'wifinet4'
	option device 'radio0'
	option mode 'mesh'
	option encryption 'none'
	option mesh_id 'mywifi'
	option mesh_fwding '1'
	option mesh_rssi_threshold '0'
	option network 'lan'
	option ifname 'm-11s-0'
	option bss_transition '1'
	option proxy_arp '1'

placed 3 routers, they worked correctly

@zagi-tng and @mjs , thanks , Your tip solved my problem 100%.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.