OpenWrt proposed by Daniel Petre under the name of SuperWrt for wrt32x wrt3200acm wrt1900acs wrt1200ac[Solved]

it's not a wifi connectiojn problem. client connect to wifi fine.
it'sa problem between the wl0 / wl1 interfaces and the lan interface internal to the router. the wireless and lan ports are supposed to be on the same 'bridge' but there is no bridge controller since DSA.

I have no problems on the wire with wrt1900acs v2, make public the problem with the logs you have generated by the system ...!

New updates https://superwrt.download/!

New updates https://superwrt.download/ .

.

I obtained the above results after I modified Fragmentation Threshold and
RTS / CTS Threshold:


For those who want the theme of @solidus1983, it works well on Daniel version, I installed it directly from the web interface!
https://github.com/DevOpenWRT-Router/luci-theme-opentomato/raw/master/luci-theme-opentomato_git-20.151.00701-55615d7_all.ipk

It should also be included in OpenWrt official sources!


Stock mwlwifi settings, no traffic shapers, distance between devices = ~10 meters. Your connection jitter is quite high at 8 ms.

nitroshift

@oli Where can one find the source code of SuperWrt?

As far as I know, he does not include external source code patches in the compiling process but feel free to disassemble a firmware image and check the modifications, it's just an up-to-date version of OpenWrt from OpenWrt official sources ....
You can get all the information from Daniel on discord.

You can't get the code from disassembling a firmware image.

nitroshift

If that would be true, then there would be no need for this SuperWRT.

From that I read: SuperWRT = OpenWrt + script

Since the source code is not easily available, nobody knows what exactly that script does. Not exactly inspiring confidence...

1 Like

If you really want to know more details talk to Daniel here, I can't help you with all the information.


To be clear, I respect everyone's work, I just wanted to make his work known, I have been using his compilations for more than 10 years and i had no problems!

all the best

1 Like

New updates https://superwrt.download/
driver name: mwlwifi
chip type: 88W8864
hw version: 7
driver version: 10.3.8.0-20181210

hi,
maybe odd question but who is Daniel Petre and what benefit is there comparing to vanila openwrt running on my wrt1900ac v1? thanks

1 Like

If you want to have good performance on 5Ghz use the following settings!
Below you will find some tests made with WRT1900acs v2 with the latest version of OpenWrt proposed by Daniel Petre!

Software flow offloading-ON !!!

if you want to be able to see this demonstration use the microsoft edge browser!

http://s.go.ro/5xzsjno0

   |.-----.-----.-----.|  |  |  |.----.|  |_
|   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 SuperWRT SNAPSHOT, r15220-05a1b11c71
 -----------------------------------------------------
root@swrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
        option htmode 'VHT80'
        option disabled '0'
        list ht_capab 'SHORT-GI-20'
        list ht_capab 'SHORT-GI-40'
        option country 'RO'
        option cell_density '0'
        option channel '48'
        option legacy_rates '1'
        option frag '2346'
        option rts '2347'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option macaddr '1'
        option ssid 'superwrt 5Ghz'
        option key ''
        option encryption 'psk2'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11g'
        option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
        option disabled '0'
        option noscan '1'
        option htmode 'HT40'
        list channels '1'
        list channels '6'
        list channels '11'
        list ht_capab 'SHORT-GI-20'
        list ht_capab 'SHORT-GI-40'
        option country 'RO'
        option cell_density '0'
        option channel '9'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option macaddr ''
        option ssid 'superwrt'
        option key ''
        option encryption 'psk2'

root@swrt:~# cat /sys/kernel/debug/ieee80211/phy1/mwlwifi/info

driver name: mwlwifi
chip type: 88W8864
hw version: 7
driver version: 10.3.8.0-20181210
firmware version: 0x0702091a
power table loaded from dts: no
firmware region code: 0x30
mac address: 06
2g: enable
5g: disable
antenna: 4 4
irq number: 74
ap macid support: 0000ffff
sta macid support: 00010000
macid used: 00000001
radio: enable
iobase0: 559f5583
iobase1: 11d7e379
tx limit: 768
rx limit: 64
qe trigger number: 6877210

root@swrt:~# cat /sys/kernel/debug/ieee80211/phy1/mwlwifi/sta

mac address: a
aid: 1
ampdu: true
amsdu: false
wds: false
ba_hist: disable
ht_cap: 0x1020, ampdu: 02, 06
rx_mask: 0xff, 00, 00, 00
rx_bw: 0, rx_nss: 1
tdls: 0, tdls_init: 0
wme: 1, mfp: 0
IV: 000000071dc3

@oli is it for openwrt vanila or for superwrt?

1 Like

SuperWrt =OpenWrt!
Don't be upset but it means you didn't read anything I wrote here..
SuperWrt-it's just Daniel's personalization with names...

SuperWRT it is compiling (at least once a month) from OpenWrt official sources and provide you for free with the files at https://superwrt.download/ AS IS. SuperWRT not compile in stuff from outside OpenWrt feeds.
SuperWRT is OpenWrt. So everything you need - you can find on OpenWrt forums.

I have the last build, 19.07.5, so I guess I can load the super wrt directly form my current build?

yes sure, but don't keep the settings!

finaly I was not sure so I started from scratch from oem linksys firmware, everything is ok but with this buils impossible to use my brave browser as usual, I have to use chrome, firefox.. And yesterday with the 19.07.5 or david's Build I used Brave... and the web pages are slower.

Also, any dns leak test that I try to do, its impossible to open the webpage on any browser..

I will have to flash again and upload another build ..