Openwrt problems and configurations help

Hi,

I was thinking to open one thread only for different problems I have with openwrt on different hardwares.

  1. I have a WL-330N3G v1.20 Asus mobile usb router which wasn't updated since 2015 so I decided to update with latest (the .1 version) openwrt with tftp and after difficult try finding the exact moment when you've to put the firmware during boot, I ended correctly updating it. At the next reboot the firmware was lodaded correctly, the gui was running, everything seems to work as it should. But after some test when I disconnected the router from power supply and the day later powered it again, it seems to have problems. The 192.168.1.1 isn't found by ping again (I set the .20 address as the guide say and as I uploaded the firmware) and the ethernet led sometimes is on sometimes is off even if connected. The interface seems seen by the pc but something seems wrong and I can't upload the firmware again. And I can't know if the router is running or crashed sometime at the boot or whatever only the power led is on but who knows what it's waiting. Do I have to build the serial cable and solder it to the mainboard for another upload?

  2. Then I switched to a Raspberry Pi 1 B+ v1.2, latest openwrt firmware, everything's ok, downloaded and uploaded offline the various packages to make my DWR-730 (mt6280) 3g router working as cdc_ether connection and after some difficult config the gui sees the eth1 and mac address! Great. But now how can I make the ethernet input connection of the raspberry connecting to the usb-ethernet cdc_ether 192.168.0.1 that will talk to the internal modem router? Cause the interface of the openwrt will be .1.1 and I imagine some sort of bridging or whatever must be configured for a pc to enter the raspberry ethernet eth0 and goes out to to the cdc_ether/3G autoconnected/powered modem.
    UPDATE (for problem n.2): I got to connect to internet with the firewall settings -> edit wan zone -> selecting the cdc_ether/3g/eth1 interface and enabling "Allow forward from source zones : LAN/eth0". Is this the right option to connect only TO the wan FROM the request at the rapsberry physical lan ethernet that come from my pc???

For now these are the problems, also later I'd like to ask how to config the firewall.
Thank
Bye

For WL-330N3G I don't think it is worthy to spend time for a device with 4MB flash and 16MB ram. If it was working properly I would advise to make it a dumb AP. With such an unpredictable behavior, better recycle.

It is the default to have LAN->WAN forwarding. Most likely you didn't have the WAN zone in the firewall because Raspi has only one ethernet interface.

1 Like

You're on the right track to make the modem the WAN. Generally these modems act as a router and will serve a DHCP (private) address which you should use.

The /etc/config/firewall is the same for every device even those with only one Ethernet port, and sets up typical NAT and routing from LAN to WAN. The WAN network just isn't used in those but you can add it.

1 Like