OpenWrt - Problem with voip

I have problem with my Voip gateway (Cisco SPA112) and my OpenWRT router (GL.iNet GL-B1300).
I setuped my voip gateway, but I can make calls only in one direction (from voip phone, but not to voip phone).
When I try to call on my voip phone I hear that call can't be realised.

I am getting internet from ONT using VLAN 35 and PPPoE, internet works. I tried port forwarding, doesn't help. Voip gateway works without problem on my ISP router.
Anyone has idea how to fix this?
Now I am using GL.iNet OpenWRT.
I had same problem on openwrt from

[SOLVED] Incoming calls not reaching hosts on the network - #2 by vgaetera

I've forgot to mention, I've tried this too.
Zoiper also can't receive calls on openwrt router, while on ISP Box works fine.

Also tried this, only made things worse:

1 Like

Got problem solved, QSDK "pure" OpenWRT from GL.iNet site works fine with voip. What I've noticed is that on this build package 'kmod-nf-nathelper-extra' wasn't there.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.