Openwrt Plusnet Router Main Issues

How many more threads and posts do you need before you accept reality?

Until I get a solution
This wireless adapter can get 200Mbps, the driver though seems to be maxing out the CPU, I have installed the unofficial speedtest from opkg so the other radio is not being used

full cpu load just from the USB adapter
but there could be some more optimized driver somewhere

I would have given up by now, if I didn't think this was possible

would the raspberry pi zero I have be able to run the STA, then with a usb ethernet adapter, connect it to the plsunet router with just the AP
then I am limited to 480Mbps shared between the ethernet and usb adapter
240Mbps each then

does openwrt support USB ethernet as I could connect the raspberry pi zero to the router USB, have a network connection though that between then,
and have the USB adpter connected to the Raspberry Pi Zero

found an apple iPhone USB Ethernet driver
Does openwrt support it with the raspberry pi zero, like raspberry pi OS does

You think it's possible. Over almost endless threads you've had umpteen OpenWRT experts try to guide you towards the fact that it isn't, with the equipment you have.
You either have to use a wired network connection or spend some money, but you can't (there are always ways to run cables) and you can't or won't.

You can choose to not accept guidance, sure, but don't expect further help from those people when you repeatedly don't. As I said in one of your earlier threads, this is a community forum. People choose whether or not to involve themselves.

And with that, I bid you farewell. I'm out.

1 Like

I think I would have more chance having the plusnet router as the STA and raspberry pi 4 for the AP with the usb adapter or the other way around
only problem there is the raspberry pi 4 is being used for backups

I have accepted what has been said, just keep having new ideas that might work

Looks like I will be sorting out this idea myself then

I just need to know about USB ethernet gadget or I will need to buy a ethernet adapter and it would be on usb 2.0

as I want to try a raspberry pi zero before the raspberry pi 4

I don't think @brada4 meant to close your thread.
That's something only you or an administrator can do.

It's just, when everybody else is fed up and won't reply to you this thread is more or less dead because you're the only one who writes in it without getting any more answers.

FWIW, a few years ago i tried to connect two rooms (which are only 5m apart) via a wireless bridge. After many fruitless tries i had to accept that i won't ever get a stable and fast connection between them using this way.
I found another solution, but as you wrote before that won't happen at your location.

I think an moderator should be the only one who can mark solved as well
I am not closing this
had the argument many times with moderators, I get told I have 1000 threads, I am have a load of threads because they all get closed before I say
it annoys me, and give me nothing to do for the rest of the day, and it makes me stressed

I understand that, but give people time to reply, its not even been a day yet

abbreviations again

FWIW stands for "for what it's worth"

Its stable and fast to other devices, its just driver processing that is causing high cpu usage, if the router was slightly more powerful, I would achieve my goals
there you go everyone, that's what happens when I don't think and just type
that was always at the back of my mind

Powerline?
thats a nightmare here as well
I moved the router away from the fibre modern, and had a load of interference
its fixed now but adding more is going to cause my problems, I expect and is two units go back to one at the router(which would have to go back next to the modern), the would probably be halved

I will find a way of doing this, I will never give up

I am ranting again, Sorry everyone

Raspberry Pi 4 for STA
Plusnet router for AP
if that does not work nothing will

if anyone knows how to do this with just the plusnet router please post today
I will be marking a solution tomorrow after I have tested it
you have until 7PM BST(GMT +01:00 / UTC +01:00) unless a moderator closes it sooner

how is the plusnet router, bad at even just dumb AP

I have an error with the Raspberry Pi 4, I know its unelated here, but I am linked it over ethernet to the plusnet router

its like the driver is crashing under load or something

unfortunately because I can not work out a fix for this I am back to only the plusnet router

can we lower its CPU usage, both cores were nearly at 100% with it just being used as an AP without the STA

so with the STA is has verry little CPU to use

would it be possible to bind the AP and STA to different cores

this thread is dead but I am not allowed any more, so what do I do

Surely we can even out the CPU usage so the STA or AP are not using it all, make it 50% STA 50% AP 1 core each or something

What's the other router you're connecting to? Does it have more CPU power? You could try using that other one for STA.

You basically need:

  • One router in AP mode
  • Another router in AP mode on a different wifi channel than the first one.
  • A USB stick configured for STA mode

It doesn't matter if you add the USB stick to the first router or to the second. You will suffer from additional CPU utilization, no matter what. USB will cause CPU utilization, and having two wifi devices involved in one traffic flow will cause even more CPU utilization. That's two additional steps causing CPU utilization on one device: The one you're adding your USB wifi stick to.

So it makes sense to add the USB stick to the router with more CPU cores and/or more speed per core.

thats exactly what I was doing, using the raspberry Pi 4 for the STA, but the usb adapter driver had issues

and the plusnet router was at 100% just running the AP
thats seems wrong that it was at 100% for just the AP

but the raspberry pi 4 is needed for backups, I could swap it to my raspberry pi 3, but then my backups would be slower

this is the issue I had

see the image

Per the OP's desired closing time, it is now 7:20PM BST, and this thread is now closed.

2 Likes