OpenWrt One using eth0 WAN as LAN

I have 2 OpenWrt One on my network.

  • The 1st one is the master (working well)
  • The 2nd one, as a Dumb AP which I am trying to configure.

on the Dumb AP, I have the lan cable connected on eth1 but would like to use eth0 to extend my lan further.
Based on the post How to connect switch to 2.5G port (OpenWRT One) I thought I just needed to edit /etc/config/network as described:

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'
	list ports 'eth1'

but when I do so, and I connect a computer to the eth0 port I have an IP in 169.254.14.x and I am expecting it top be 169.168.7.x

My console out put is:

[   26.510197] br-iot: port 1(phy0-ap2) entered blocking state
[   26.515782] br-iot: port 1(phy0-ap2) entered forwarding state
[   27.112761] br-lan: port 3(phy1-ap0) entered blocking state
[   27.118346] br-lan: port 3(phy1-ap0) entered forwarding state
[   27.502563] mtk_soc_eth 15100000.ethernet eth0: Link is Up - 1Gbps/Full - flow control rx/tx
[   27.503169] br-lan: port 1(eth0) entered blocking state
[   27.516227] br-lan: port 1(eth0) entered forwarding state
[   27.530068] mtk_soc_eth 15100000.ethernet eth1: Link is Up - 1Gbps/Full - flow control rx/tx
[   27.530118] br-lan: port 2(eth1) entered blocking state
[   27.543736] br-lan: port 2(eth1) entered forwarding state

and my /etc/config/network file is :


config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd73:6c5b:50b4::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'
        list ports 'eth1'

config interface 'lan'
        option device 'br-lan.76'
        option proto 'dhcp'
   option type 'bridge'
        option name 'br-guest'

config interface 'guest'
        option proto 'dhcp'
        option device 'br-guest.12'

config bridge-vlan
        option device 'br-guest'
        option vlan '12'

config device 'iot_dev'
        option type 'bridge'
        option name 'br-iot'

config interface 'iot'
        option proto 'dhcp'
config bridge-vlan
        option device 'br-iot'
        option vlan '6'

config bridge-vlan
        option device 'br-lan'
        option vlan '76'
        list ports 'eth1:u*'

and I am unable to connect from the lan.
But if I comment out the line eth0:

config device
        option name 'br-lan'
        option type 'bridge'
#       list ports 'eth0'
        list ports 'eth1'

everything is back to normal (without eth0 working on the lan)

Sorry to say it, but your network configuration is a complete mess.

For starters, remove the wrong guest and iot VLANs/interfaces and make the lan work as you want it. Since you have set VLAN(s), eth0 needs to be added to the bridge vlan filtering section.

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd73:6c5b:50b4::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'
        list ports 'eth1'

config bridge-vlan
        option device 'br-lan'
        option vlan '76'
	    list ports 'eth0'
        list ports 'eth1'

config interface 'lan'
        option device 'br-lan.76'
        option proto 'dhcp'

Don't be sorry, I am trying to learn, so thank you for pointing it out.

I did that. Now I can connect my lan cable coming from the main router to either port and it does work.I get an IP address as a DHCP client.

However when connecting a laptop to the 2nd port, I get an ip via DHCP that is in the wrong subnet (192.254.14.x instead of 19.168.7.x) and have no internet connection from this port.

Any idea why and how to fix it (and sorry for my ignorance)?

Sorry last message was apparently an issue on the laptop. all fixed.

1 Like

Glad it is now working as expected.

If you need help on how to extend the Guest and IoT networks, feel free to ask and we will do our best to help you.

3 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.