OpenWrt on xiaomi-4a-gigabit will infinite restart

there is nothing on it :joy:

ok,i look forward to the update :sob: :sob: :sob:

It doesn't seem to be very clear, I will take pictures tomorrow when I take it apart.


please check the IC p/n.

As pointed out by @123serge123 , it would appear the chip ID 1c7118 is for the EN25QX128A.

Known issue appearing in very latest chinese language model R4AG, and R4C devices.
Issue 9442

BTW you can (and I think have to) update breed without solder iron.
breed support to start new breed version from memory.
Connect to breed with telnet do execute commands:

boot breed 0x80001000

Than make sure that flash is recognized in Web-interface and upgrade bootloader as usual.

i open again,the photo is too blurry,but it is QX128A

@EpicDogger, did you try to flash my build? here:

1 Like

Not yet, can this be swiped directly in Breed?

I'm not sure. If Breed could flash openwrt ......-sysupgrade.bin code, then ok.
Otherwise, you have to back to stock fw first.....

I tried so many builds to flash and this is the one that finally worked. Are you able to let me know what's different on this build? Also, I set this up with mesh and I'm getting pretty slow speeds and wondering if you've experienced this and thanks for the build!

It's kernel un-supported new flash IC EN25QX128A issue.

I met this on my 4C, refer to here:

Also here:

Then, I try to add a PR for the issue, not success:

The issue / my solution, not related mesh function, and I do not know how to use mesh, cannot help.

You didn't implement the requested changes. socram8888 mentions that you should remove SECT_4K from the changes, because the chip supports SFDP.

SFDP is small amount of information within the chip itself that tells the system what features it supports, so manually specifying SECT_4K is redundant. If the chip supports 4K-sectors, that information will be in the SFDP and the system will use the feature automatically.

If you just make the changes socram8888 wanted, maybe they'll approve the PR.

Thanks. My problem is I'm not use my "real name" but my nick name, and I had tried to use my real name login, still can not pass the auto-check. That means my account not suitable for openwrt PR ever. I hope someone could help on this in future.

EN25QX128A IC, basically supports SECT_4K, simply added a similar line in PR is ok, and I have tested on this.
For the new feature SFDP, needs someone test it carefully, maybe it's not must.

You've misunderstood. No one is saying SFDP is "a must" for the chip to work, but that using SFDP is better than specifying the features manually.

If you're just using Github's web-interface, yeah, fixing things can be a hassle. That said, you're not really even supposed to use the web-interface for anything other than quick adjustments or such.

I use WereCatf on Github as well, yet my pull-requests use my real name. How? Because I use real tools, not Github's web-interface. With the command-line git it's pretty easy to set one's real name:

These forums are the wrong place for a full-blown tutorial on how to use the command-line or e.g. VSCode and git, but Google is your friend.

Thanks, in the last, I already use github-desktop software and my real-name, everything seems ok, but still got the real-name issue.

Ah that makes sense. Thanks again, at least there's a build that works. :+1:

Thanks, if you could open the case of router, please make sure the flash IC is using EN25QX128A.

Here you go...

Thanks, this is the first time confirmed my build with the patch is ok on 4A gigabit (my device is old Flash).

1 Like