OpenWrt on x86 as AP with AR9382

Hi all,
It's my first post here so please be gentle :slight_smile:

I've got OpenWRT x86 with wireless Atheros WPEA-121N which has AR9382 inside but I cannot set it up as Access Point.
I have installed ath9k but in LUCI -> Network -> Wireless I can see "Generic MAC80211 802.11an" so I guess something is missing, also cannot setup encryption like WPA2 even though in openwrt 21.02.3 already was installed the required hostapd-common.

I can see plenty of wifi in my neighborhood when I press the "scan" button.
iw list - shows that card have AP and even Mesh, but for some reason when starting "SSID: OpenWrt | Mode: Master" it says "Wireless is not associated"
I think that Radio0 should show "Atheros something" but it's not.

I tried a few configurations from documentation, but it seems that some changes were mede in 21.02.3 and those configs no longer apply.

I have tried USB Live CD with Linux Mint on which I have created AP and it's working fine, I can connect to it so the card definitely supports it.
Then compared a few things to OpenWRT - all seem to be alike:

mint@mint:~$ lsmod|grep -i ath
ath9k                 155648  0
ath9k_common           36864  1 ath9k
ath9k_hw              475136  2 ath9k_common,ath9k
ath                    36864  3 ath9k_common,ath9k,ath9k_hw
mac80211              847872  1 ath9k
cfg80211              708608  4 ath9k_common,ath9k,ath,mac80211

mint@mint:~$ lspci |grep -i net
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 0c)
02:00.0 Network controller: Qualcomm Atheros AR93xx Wireless Network Adapter (rev 01)

mint@mint:~$ dmesg|grep -i ar9
[   24.651903] ieee80211 phy0: Atheros AR9300 Rev:3 mem=0xffffae1d81b40000, irq=39

Do you know what could be missing or how to configure wifi to act as AP?

That is normal when an AP is running but no stations are connected to it.

The package wpad-wolfssl or wpad-openssl should be installed to support all encryption modes. These are the full build suitable for hardware like x86 where there is plenty of memory.

That is not important. Many radios list as generic. If your driver was not working it wouldn't show any radio.


Thanks mk24 for a quick reply.

I'd be happy to connect to this AP but it simply doesn't show up - cannot see OpenWRT on my laptop or mobile :confused:
I checked if it's visible after every config change and/or reboot, this AP is not there.

As per wpad, I have just installed wpad-wolfssl and it helped with encryption, I can see WPA2 and WPA3 plus some variations - thank you for this one :wink:

So the only thing is that AP is not working or at least it appears to be so.
Maybe there are some settings I need to apply?
I have added only country code, did not specify encryption so far just to see if AP is working and I will add it later.
Maybe I have to configure "Network" from below image to something else?

Holly crap, mk24 you made it.

I just wanted to test if adding WPA2 would help and it did - suddenly I could see my AP and connect to it :smiley:
So it seems that (possibly due to security reasons) AP is not showing up unless you specify encryption?
Or maybe this package wpad-wolfssl helped, I'll check and report back.

Anyway, thank you so much!!!

Please mark it solved

I wanted to reply with information but it seems new joiners cannot write too much.
It seems that there is no way to close this post and it will auto close withing 10 days.
Thank you mk24 !!!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.