OpenWrt on WRT1900ACS -- can't get WAN-side IP address assigned

I've been through the handful of troubleshooting guides here, but can't seem to resolve my problem. I'm running a WRT1900ACSv1 > Arris Surfboard modem that's connected to Comcast/Xfinity.

The router has no problem getting an IP address on the WAN port from Comcast when the LinkSys firmware is running on the box.

But when I flash to OpenWrt I lose my ability to get an IP on the WAN port. I've tried altering the MAC address no avail. I'm only trying to get an IPv4 address -- I have IPv6 off on the LAN and WAN sides of my network when running the LinkSys firmware.

The only unusual pieces of the setup are I'm running on IP space on the LAN side and I'm not using the router for DHCP and DNS (I have a pi-hole box for that).

Installation is otherwise very smooth and configuration seems straightforward.

Anyone gone through a firmware switch on an already running WRT1900ACS like this? Is there something I need to do Comcast/Xfinity-side to get the WAN to work after the upgrade?


Do you reboot the cable modem after flashing?

Did you configure OpenWrt to the same subnet after flashing?
OpenWrt uses by default.

Do you reboot the cable modem after flashing?

Yes. I powered the modem down for 10 minutes on the off chance that might help. But no, it didn't. The router was also powered off at this time and the startup sequence was: modem (waiting for status lights to indicate it'd reconnected) followed by the router.

Did you configure OpenWrt to the same subnet after flashing?

Yes. The LAN was functioning fine. Clients were communicating, WiFi radios were working great. It was just the WAN that failed to go green.

Have you enabled the Broadcast Flag for DHCP (sometimes needed for Cable connections)?


Yes. Tried that. No luck. I did a modem and router restart after enabling it.

Is there any relevant message in the logs?

1 Like

I can re-flash and check. Where in the logs should I be looking?

Have you contacted Comcast Tech support, as it sounds like the issue is with the modem assigning a WAN IP to the WAN interface?

I didn't this past weekend because of the long weekend. But I'll have another run at this on Friday and call Comcast if I can't get an IP.

Appreciate all the troubleshooting tips everyone! Thank you!

1 Like

Did you manage to resolve it ?
I currently have same problem on multiple devices running openwrt

Comcast seems to “refuse” to give DHCP leases to a new MAC on the same subscriber line for quite some time. Not sure which is longer, the lock-out period or their hold time for technical support that has any technical competence.

Its been a few days for me. not "quite some time".
Right now i can get dhcp lease from two linux desktops but cant get one with openwrt on two devices: r7800 and edgerouter.

hmm... actually right now i installed dhclient on r7800, made a copy of dhclient config from linux, rebooted modem and this gave me ip. after killing dhclient i could get it with udhcpc.

Unplug the router Ethernet, reboot modem, reboot router, then replug Ethernet once the router has been up for at least 30 seconds... Sometimes the switch chip leaks MACs on WAN and the modem latches on to some Mac other than your router


Your problem is very different as it seems to be about clients not getting an IP address, not the WAN interface of your OpenWrt device itself. Please search for your case. If you don’t find an answer on how to start (and you should find many threads on how to diagnose), please open your own thread.

It's about WAN interface of OpenWrt device(s) not getting IP address

  • Are you configuring any: Client ID, Vendor Class or spoofed MAC address - on the OpenWrt's WAN interface?
  • Are you rebooting both devices between equipment swaps?
  • No
  • Yes

Did you do my dance referenced above? those leaked MACs can be a serious problem.

Yeap, I tried. Tried even for hours.
But what I find strange it's that at the end of the day I did managed to get lease with desktop but not with openwrt devices (edgerouter x or r7800).
Only after I installed on r7800 isc-dhcp-client, made copy of config from workstation, it got ip. And after this udhcp on r7800 got ip. And then edgerouter managed to get lease.
So, right now it's working (this is after 4 days of no dhcp leases).
I been trying to get comcast to take a look at their side of wire (cmts) while at wasnt working, but it seems to be impossible to achieve, as i cant get to level of support that knows words DHCP and CMTS

Hello Musora,

I am having the same issue. Details are available in the thread WRT1900ACS No Wan IP - Help needed!.

Do you have any solution for this?. I didn't quite understand how you got it resolved.