Openwrt on TP Link MR6400v1 - WAN not working

I installed Openwrt on the MR6400 today. I have another router with which I connect to the internet.
I connected a lan port from that to the LAN/WAN port of the MR6400 and then my laptop through a LAN cable to a LAN port on the MR6400.

I have the default configuration and LAN is configured as bridge-lan and WAN as DHCP-client.

I don't have any internet connectivity on Openwrt. Pinging and both fail.
When I check the WAN port it doesn't have an IP address even though its set as DHCP-client. Restarting the interface doesn't change anything.

So I tried to reboot Openwrt.
If I reboot Openwrt with the internet router on the WAN port, the laptop gets its IP from the internet router instead of Openwrt.
If I enable WIFI on Openwrt and connect through that the laptop gets IP from the internet router.
In both instances above, I am unable to access Openwrt. The only way I can access Openwrt is if there is no connection on its WAN port.

How do I set up Openwrt to use the internet connection from existing router and act as a router itself for devices connected to Openwrt?

Chances are that your upstream router and your new openwrt router are using the same subnet for their lans. They must be different, otherwise routing doesn’t work.

If your upstream router issues addresses in the network, you need to change one of them to another subnet. For example (openwrt could use the lan address

I actually tried with two upstream routers. In one case the upstream router uses 192.168.101.X and in the other it used 192.168.1.X

For the second case I changed the Lan address to

Despite this in both cases the problem remained, no internet access on Openwrt and on reboot the internet router set the laptop's ip, not Openwrt.

I've used the firstboot command to reset Openwrt twice, but still stuck.

Another thing, MR6400 can also act as a mobile router if I put in a SIM card. But I don't want to use it like that. However when its running the 4G light is on indicating its status as a mobile router. How do I turn this off? Could this be messing with the routing and DHCP on Openwrt?