OpenWrt on tp link mr6400 v5

I tried flashing my mr6400 following instructions from officiall page:

didn't work, tried doing it on windows 10 and linux

I didn't see the router connecting to tftp server even though i set the servers ip to 192.168.0.255 as described in the instructions.

I'm new to openwrt any responses will be appreciated.

Common issues are firewalls blocking the TFTP server.

Make sure it has permissions.

You may also need to reduce the port speed on your network adapter to 100 Mbps, or use an unmanaged switch.

Thanks, I will definetly make sure it has neceseary priviledges then try flashing it again and let u know how it went.

Putting an unmanaged switch between device and your computer is always a good idea as well, as this avoids the link-down event and link training.

1 Like

Turned off the firewall and changed the router lan ip to 192.168.3.1 so that it is on different subnet and still nothing. I also get an error when trying to set the computers ip to 192.168.0.255, windows complains about subnet mask being invalid and when I change the subnet mask to 255.255.0.0 it lets me set the ip to 192.168.0.255. Thanks for giving me hints I'll make sure to reduce the adapter speed to 100 mbps and also try unmanaged switch if adapter speed reduction doesn't work.

Tried flashing on linux using tftpgui as tftp server checked the logs and there is no trace of router ever connecting to tftp server and requesting any file checked tftpd64 logs on windows and there it also seems like the router isn't connecting at all.

That's not what the TFTP instructions, in the link you posted say, read them again, and more carefully.

Hi

Did you turn off all Windows firewalls, domain, private and public?
Set your computer IP to 192.168.0.225 with subnet mask 255.255.255.0.

  1. Power off router
  2. Connect router to your TFTP server
  3. Press WPS/RESET while you power on router, keep pressed for 10s
  4. TFTP loading should now start
  5. Wait until router has restarted
  6. Log in with browser to 192.168.1.1

Yes turned off private and public firewall on windows, but setting ip to 192.168.0.255 with subnet mask 255.255.255.0 is impossible in my case even aften resetting network stack with netsh.

You are using wrong IP-address. You shall use 192.168.0.225.

Ok so that's most likely the problem sorry for the whole thing I really should be reading those instruction more carefully thank you for support. Of course I'll try flashing it with ip set to 192.168.0.225 and tell you how it went.

It worked! I have OpenWrt up and running already, Huge thanks for support.

Great!
I can recommend a modified version of uqmi if you have problems to setup your LTE modem, https://github.com/mrhaav/openwrt :wink:

there was a reason why you were told to reread them :wink:

I installed the uqmi and tried to configure the wan interface in Intenfaces tab but it's not working and i get no wan connection is there anything I have to do specifically to get the lte modem working?

Paste your network.wwan config and the output from System Log, then I can take a look.

Here are the logs and configs:

/etc/config/network:


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdc7:b84b:347a::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.1'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option proto 'dhcp'
	option force_link '1'
	option broadcast '1'
	option peerdns '0'
	list dns '9.9.9.9'
	option hostname 'openwrt'
	option device 'wwan0'

config interface 'wan6'
	option proto 'dhcpv6'
	option device 'wwan0'
	option reqaddress 'try'
	option reqprefix 'auto'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 6t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '3 6t'


/etc/config/dhcp:


config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'
	option ednspacket_max '1232'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option dhcpv6 'server'
	option ra 'server'
	option ra_slaac '1'
	list ra_flags 'managed-config'
	list ra_flags 'other-config'

config dhcp 'wan'
	option interface 'wan'
	option master '1'
	list ra_flags 'none'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'


dmesg:

[    0.000000] Linux version 5.4.154 (builder@buildhost) (gcc version 8.4.0 (OpenWrt GCC 8.4.0 r16325-88151b8303)) #0 Sun Oct 24 09:01:35 2021
[    0.000000] Board has DDR2
[    0.000000] Analog PMU set to hw control
[    0.000000] Digital PMU set to hw control
[    0.000000] SoC Type: MediaTek MT7628AN ver:1 eco:2
[    0.000000] printk: bootconsole [early0] enabled
[    0.000000] CPU0 revision is: 00019655 (MIPS 24KEc)
[    0.000000] MIPS: machine is TP-Link TL-MR6400 v5
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x0000000000000000-0x0000000003ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x0000000000000000-0x0000000003ffffff]
[    0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x0000000003ffffff]
[    0.000000] On node 0 totalpages: 16384
[    0.000000]   Normal zone: 144 pages used for memmap
[    0.000000]   Normal zone: 0 pages reserved
[    0.000000]   Normal zone: 16384 pages, LIFO batch:3
[    0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
[    0.000000] pcpu-alloc: [0] 0 
[    0.000000] Built 1 zonelists, mobility grouping on.  Total pages: 16240
[    0.000000] Kernel command line: console=ttyS0,115200 rootfstype=squashfs,jffs2
[    0.000000] Dentry cache hash table entries: 8192 (order: 3, 32768 bytes, linear)
[    0.000000] Inode-cache hash table entries: 4096 (order: 2, 16384 bytes, linear)
[    0.000000] Writing ErrCtl register=00076e10
[    0.000000] Readback ErrCtl register=00076e10
[    0.000000] mem auto-init: stack:off, heap alloc:off, heap free:off
[    0.000000] Memory: 57444K/65536K available (5088K kernel code, 204K rwdata, 636K rodata, 1228K init, 205K bss, 8092K reserved, 0K cma-reserved)
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS: 256
[    0.000000] intc: using register map from devicetree
[    0.000000] random: get_random_bytes called from 0x805cda28 with crng_init=0
[    0.000000] CPU Clock: 580MHz
[    0.000000] timer_probe: no matching timers found
[    0.000000] clocksource: MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 6590553264 ns
[    0.000009] sched_clock: 32 bits at 290MHz, resolution 3ns, wraps every 7405115902ns
[    0.007571] Calibrating delay loop... 385.02 BogoMIPS (lpj=770048)
[    0.045455] pid_max: default: 32768 minimum: 301
[    0.050093] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.057114] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.070423] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 7645041785100000 ns
[    0.079851] futex hash table entries: 256 (order: -1, 3072 bytes, linear)
[    0.086504] pinctrl core: initialized pinctrl subsystem
[    0.094492] NET: Registered protocol family 16
[    0.125772] workqueue: max_active 576 requested for napi_workq is out of range, clamping between 1 and 512
[    0.139244] clocksource: Switched to clocksource MIPS
[    0.145165] thermal_sys: Registered thermal governor 'step_wise'
[    0.145576] NET: Registered protocol family 2
[    0.155721] IP idents hash table entries: 2048 (order: 2, 16384 bytes, linear)
[    0.163585] tcp_listen_portaddr_hash hash table entries: 512 (order: 0, 4096 bytes, linear)
[    0.171686] TCP established hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.179057] TCP bind hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.185852] TCP: Hash tables configured (established 1024 bind 1024)
[    0.192136] UDP hash table entries: 256 (order: 0, 4096 bytes, linear)
[    0.198463] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes, linear)
[    0.205487] NET: Registered protocol family 1
[    0.209723] PCI: CLS 0 bytes, default 32
[    0.218454] workingset: timestamp_bits=14 max_order=14 bucket_order=0
[    0.232812] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.238447] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.264046] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 252)
[    0.274429] mt7621_gpio 10000600.gpio: registering 32 gpios
[    0.280170] mt7621_gpio 10000600.gpio: registering 32 gpios
[    0.285804] mt7621_gpio 10000600.gpio: registering 32 gpios
[    0.291498] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[    0.300394] printk: console [ttyS0] disabled
[    0.304595] 10000c00.uartlite: ttyS0 at MMIO 0x10000c00 (irq = 28, base_baud = 2500000) is a 16550A
[    0.313320] printk: console [ttyS0] enabled
[    0.321730] printk: bootconsole [early0] disabled
[    0.332649] spi-mt7621 10000b00.spi: sys_freq: 193333333
[    0.348254] spi-nor spi0.0: en25qh64 (8192 Kbytes)
[    0.353239] 4 fixed-partitions partitions found on MTD device spi0.0
[    0.359704] Creating 4 MTD partitions on "spi0.0":
[    0.364579] 0x000000000000-0x000000020000 : "boot"
[    0.370578] 0x000000020000-0x0000007c0000 : "firmware"
[    0.379669] 2 tplink-fw partitions found on MTD device firmware
[    0.385743] Creating 2 MTD partitions on "firmware":
[    0.390798] 0x000000000000-0x0000001e81e1 : "kernel"
[    0.396958] 0x0000001e81e4-0x0000007a0000 : "rootfs"
[    0.403050] mtd: device 3 (rootfs) set to be root filesystem
[    0.411034] 1 squashfs-split partitions found on MTD device rootfs
[    0.417404] 0x000000510000-0x0000007a0000 : "rootfs_data"
[    0.424035] 0x0000007c0000-0x0000007d0000 : "config"
[    0.430232] 0x0000007d0000-0x000000800000 : "factory"
[    0.437244] libphy: Fixed MDIO Bus: probed
[    0.455150] rt3050-esw 10110000.esw: link changed 0x00
[    0.462384] mtk_soc_eth 10100000.ethernet eth0: mediatek frame engine at 0xb0100000, irq 5
[    0.472896] NET: Registered protocol family 10
[    0.482075] Segment Routing with IPv6
[    0.486007] NET: Registered protocol family 17
[    0.490614] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
[    0.503769] 8021q: 802.1Q VLAN Support v1.8
[    0.516411] VFS: Mounted root (squashfs filesystem) readonly on device 31:3.
[    0.530531] Freeing unused kernel memory: 1228K
[    0.535155] This architecture does not have kernel memory protection.
[    0.541686] Run /sbin/init as init process
[    1.143254] random: fast init done
[    1.557092] init: Console is alive
[    1.560922] init: - watchdog -
[    2.988781] kmodloader: loading kernel modules from /etc/modules-boot.d/*
[    3.165485] usbcore: registered new interface driver usbfs
[    3.171210] usbcore: registered new interface driver hub
[    3.176744] usbcore: registered new device driver usb
[    3.188876] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    3.197255] ehci-fsl: Freescale EHCI Host controller driver
[    3.204510] ehci-platform: EHCI generic platform driver
[    3.220192] phy phy-10120000.usbphy.0: remote usb device wakeup disabled
[    3.227004] phy phy-10120000.usbphy.0: UTMI 16bit 30MHz
[    3.232312] ehci-platform 101c0000.ehci: EHCI Host Controller
[    3.238197] ehci-platform 101c0000.ehci: new USB bus registered, assigned bus number 1
[    3.246371] ehci-platform 101c0000.ehci: irq 26, io mem 0x101c0000
[    3.267266] ehci-platform 101c0000.ehci: USB 2.0 started, EHCI 1.00
[    3.274636] hub 1-0:1.0: USB hub found
[    3.278989] hub 1-0:1.0: 1 port detected
[    3.288771] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[    3.296349] ohci-platform: OHCI generic platform driver
[    3.301982] ohci-platform 101c1000.ohci: Generic Platform OHCI controller
[    3.308970] ohci-platform 101c1000.ohci: new USB bus registered, assigned bus number 2
[    3.317155] ohci-platform 101c1000.ohci: irq 26, io mem 0x101c1000
[    3.388251] hub 2-0:1.0: USB hub found
[    3.392589] hub 2-0:1.0: 1 port detected
[    3.402651] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
[    3.420585] init: - preinit -
[    3.575380] usb 1-1: new high-speed USB device number 2 using ehci-platform
[    4.301632] random: procd: uninitialized urandom read (4 bytes read)
[    5.010571] random: jshn: uninitialized urandom read (4 bytes read)
[    5.102895] random: jshn: uninitialized urandom read (4 bytes read)
[    5.321310] urandom_read: 1 callbacks suppressed
[    5.321320] random: jshn: uninitialized urandom read (4 bytes read)
[    5.416417] random: jshn: uninitialized urandom read (4 bytes read)
[    5.831726] rt3050-esw 10110000.esw: link changed 0x00
[    9.286367] rt3050-esw 10110000.esw: link changed 0x02
[   10.261552] jffs2: notice: (480) jffs2_build_xattr_subsystem: complete building xattr subsystem, 48 of xdatum (0 unchecked, 36 orphan) and 56 of xref (13 dead, 29 orphan) found.
[   10.279694] mount_root: switching to jffs2 overlay
[   10.290881] overlayfs: upper fs does not support tmpfile.
[   10.303202] urandom-seed: Seeding with /etc/urandom.seed
[   10.440399] procd: - early -
[   10.444258] procd: - watchdog -
[   11.166293] procd: - watchdog -
[   11.171504] procd: - ubus -
[   11.313625] random: ubusd: uninitialized urandom read (4 bytes read)
[   11.350694] random: ubusd: uninitialized urandom read (4 bytes read)
[   11.361180] random: ubusd: uninitialized urandom read (4 bytes read)
[   11.374483] procd: - init -
[   12.496423] kmodloader: loading kernel modules from /etc/modules.d/*
[   12.547593] usbcore: registered new interface driver cdc_wdm
[   12.563959] Loading modules backported from Linux version v5.10.68-0-g4d8524048a35
[   12.571734] Backport generated by backports.git v5.10.68-1-0-ga4f9ba32
[   12.625915] usbcore: registered new interface driver usbserial_generic
[   12.632724] usbserial: USB Serial support registered for generic
[   12.678174] xt_time: kernel timezone is -0000
[   12.807130] mt76_wmac 10300000.wmac: ASIC revision: 76280001
[   12.943176] urngd: v1.0.2 started.
[   13.149794] random: crng init done
[   13.153286] random: 1 urandom warning(s) missed due to ratelimiting
[   13.845610] mt76_wmac 10300000.wmac: Firmware Version: 20151201
[   13.851704] mt76_wmac 10300000.wmac: Build Time: 20151201183641
[   13.891271] mt76_wmac 10300000.wmac: firmware init done
[   14.071337] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[   14.142854] PPP generic driver version 2.4.2
[   14.164146] NET: Registered protocol family 24
[   14.191579] qmi_wwan 1-1:1.4: cdc-wdm0: USB WDM device
[   14.208375] qmi_wwan 1-1:1.4 wwan0: register 'qmi_wwan' at usb-101c0000.ehci-1, WWAN/QMI device, 82:7f:a8:5e:cd:38
[   14.219395] usbcore: registered new interface driver qmi_wwan
[   14.348868] usbcore: registered new interface driver option
[   14.354695] usbserial: USB Serial support registered for GSM modem (1-port)
[   14.383488] kmodloader: done loading kernel modules from /etc/modules.d/*
[   22.342095] rt3050-esw 10110000.esw: link changed 0x00
[   25.827011] rt3050-esw 10110000.esw: link changed 0x02
[   29.820969] br-lan: port 1(eth0.1) entered blocking state
[   29.826535] br-lan: port 1(eth0.1) entered disabled state
[   29.832441] device eth0.1 entered promiscuous mode
[   29.837360] device eth0 entered promiscuous mode
[   29.868591] br-lan: port 1(eth0.1) entered blocking state
[   29.874144] br-lan: port 1(eth0.1) entered forwarding state
[   30.819797] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready

Will you use your LTE modem as the wan connection or do you have wan (internet) via cable?
If you are using your LTE modem as wan, then you have to add a new interface and use QMI as protocol. And then add APN settings and firewall zone.

I want to use the lte modem for wan.