OpenWrt on TP-Link EAP120 - Not recognised by router, no internet


#61

i can connect to the AP directly, and i can connect to it wirelessly when its connected to the router. but there is no internet connection when i do the latter.


#62

Yes, I understand that.

Let's put aside Internet for now, and look into the lower layers first. When you connect the switch to both the router and the PC, you can't access the router, right? I understand that it's unmanaged switch, so there is little it's supposed to be doing. If the switch is working, then we should probably suspect the cables.

There are no enough devices to come to be conclusive, but form what you say, with the exception of PC to router direct connection, any thing involving 100 mbps port isn't working. I don't know if that means anything, or if it's just a coincidence..


#63

maybe openwrt doesn't like having to deal with a 100mbps interface? :confused:


#64

No, it should be fine..

But again, put the AP side. Why the PC can't connect to the router via the switch?


#65

oh, the pc can connect to the router through the switch just fine. the switch is working perfectly.


#66

Well, I asked before if you can't ping anything when you have the switch, and you said yes


#67

oops, my bad. pc -> router works, ap -> anything does not.


#68

OK, did you do factory reset?

You know, without elaborating on what you do and what you tried, it's difficult for anyone to help.


#69

i've factory reset the AP several times.


#70

Did you reset using the commands above, or just the AP reset button?

Did you get any errors? Or was it successful? Did you have settings reverting to defaults after reset?

With AP connected to router, and you accessing AP wirelessly, could you send over images your LuCi pages:
Network > Interfaces
Network > Interfaces > LAN (including DHCP section)
Network > Switch (if you have it)
Network > Firewall


#71

Reset button. No errors. Settings all reverted to defaults.


#72

@mhegab any ideas?


#73

Well, my idea was to do factory reset. I bothered to go to the documentation, quote the line for factor rest, and also give you a link to the page about factory rest, but you pressed the reset button instead, and you said you did factory rest.

I'm not blaming and not complaining, and I am not even sure it will solve anything. It's just a trial. But what I m saying is that if you don't help people help you, then what's the point of sending here?

Anyway, I see form the images you want that there is a considerable amount of traffic on the LAN interface, and the receive is significantly more than the send. So I tend to think that the router might actually be connected to the AP.

instead of resetting, could you go to http://192.168.5.1/cgi-bin/luci/admin/network/diagnostics click Traceroute? Then change openwrt.org to 8.8.8.8 in the box above it and click Traceroute.


#74

Apologies. That wasn't my intention, but I see what you mean now.

Here are the results:


#75

I don't know, to be honest. I don't understand why it tries to go through 3 hops then come back to it's own IP. I would expect if there was no connection to the router that it would just say unreachable.

Could you remove the cable off the router and try again?


#76

Oops, I didn't have it plugged in earlier :expressionless:

Here it is plugged in (i think it's the same)


#77

And I imagine if you put 192.168.5.1 in the left box (ping), and choose ping you don't get any packets transmitted?


#78

Yeah, nothing.

image


#79

Well, I run out of ideas. If nobody else proposes another idea, I suggest you try the factory rest.


#80

Tried it - same as before. Thank you for your help anyway.