OpenWrt on TP-Link EAP120 - Not recognised by router, no internet


#41

Can you ping the AP if connected via cable or WiFi?


#42

yup, i have.


#43

yes, i can ping the AP from my computer over cable or wifi.


#44

I can't think of any thing else other than making sure that the cable between the router and the AP is gigabit cable.


#45

how would i tell?


#46

That would be Cat 5E or Cat 6.

It's a long shot since you are saying it was working earlier.


#47

Cable is cat5e :frowning:

I tried to install an older version of OpenWrt, but it would just error and say to use a compatible file. At this point the stock firmware would be fine too, but i can't see a way to install that.


#48

Don't give up just yet.

I have no other ideas, but maybe a more experienced user will come up with something.

May I suggest that you connect the AP to the switch, one PC access AP wireless and the other on the switch. Both PCs with static IP and see if they can communicate.


#49

That didn't work either.

I think it's some sort of misconfiguration of the LAN port of the AP.


#50

I understand you didn't change anything other than the IP and disabling the DHCP.

Anyway, you could try to reset

umount /overlay && firstboot && reboot now

More details here under Factory Reset
https://openwrt.org/docs/guide-user/troubleshooting/failsafe_and_factory_reset


#51

i've tried resetting it several times. but i'll give that a go.


#52

To be clear:

  • You configure the EAP120
  • You then plug it into the 192.168.5.1 device
  • Then you test WiFi in this configuration; and also wired - using another port on the 192.168.5.1 device

Correct?


#53

I can only test wifi that way. My router only has one ethernet port, so if i wanted to test wired it would have to be through my switch.


#54

Who is 192.168.5.1?


#55

My router (netgear dm200).


#56

Correct, I don't see why you're disconnecting anything.

  • The DM200 only has one LAN port
  • The EAP120 only has one LAN port

So you have the switch:

  • plugged into the LAN of the DM200
  • with the and EAP120 and PC

Correct?
Is this switch managed?


#57

Yes. The switch isn't managed.


#58

So to summarize:
PC <--> Router: Can ping
PC <--> AP: Can ping wired and wireless
PC <--> AP <--> Router: Can ping AP but can't ping router
PC <--> Switch <--> AP and Router: Can't ping anything?

All cables are Cat 5E
All ports are Gigabit?
PC has static IP
DHCP on AP is off?


#59

Yes, but all ports aren't gigabit. my router and switch are 100mbps.


#60

But you were saying that the system was working with stock firmware on the AP. Now if you connect to the router via the cable you have no connection even though this has nothing to do with the AP.