OpenWrt on Teltonika RUTxx/RUT955 with teltonikas new bootloader

Has anyone here managed to install any OpenWRT 21 stable or 22 RC on Teltonika RUT955 or any other devices that is shipped with their new bootloader (referenced here: Bootloader )

It seems it checks some hash of the firmware and fails to upload it unless its Teltonika stock firmware (RUTOS). It always worked with their legacy bootloader but now as their devices are shipped with the new bootloader I cannot seem to manage it.

Teltonika also does not release the bins for their legacy bootloader to downgrade.

I cannot either find any other way on how to downgrade to the legacy bootloader either, anyone has an idea on how to install OpenWrt their devices shipped with RUTOS and new bootloader?

1 Like

So the 'factory' images no longer work in their new bootloader? This used to work:

1 Like

Thanks for your response pepe2k

I will have to get back to you on the full output from the bootloader on the device but that is what is going on I believe.

I have tried using both OpenWrt 'factory' both 21 stable and 22 RC images as well as building my own with imagebuilder. Both used to work on the older bootloader but does not anymore.

If you need any information I can get out of the device please get back to me.

I have now tested on the real hardware and can confirm it no longer works with the bootloader.

I have tested both 21.02.3 and 22.03.0-rc6

However when I downgrade to the legacy firmware RUT9XX_R_00.06.09.2 I get the following info:

Are there any known workarounds, can I replace the bootloader somehow?


I have found a solution to the problem. It is possible to flash RUT955, and probably any Teltontika device via ssh

  1. Login
  2. Upload the image
  3. Use sysupgrade -F /tmp/IMAGENAME this will ignore the checksum function that the bootloader is using.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.