OpenWrt on raspberry PI 400 with 43456 firmware


I'm new to networking and I'm trying to use a Raspberry PI 400 work as a VPN router with OpenWrt,
I want the Raspberry to be connected by ethernet cable to my internet box, and use the Raspberry wifi interface as an access point, and have expressvpn installed/configured on openwrt on the raspberry

When I boot openwrt with the I don't see any /etc/config/wireless file,
When I run the wifi config OR wifi reconf nothing is happening (nothing displayed, wireless file still empty)

lspci says :
PCI bridge: Broadcom inc. and subsidiaries BCM2711 PCIe bridge (rev 20) USB controller VIA technologies VL805/806

When booting I see :
Direct firmware load for brcm/brcmfmac43456-sdio.raspberrypi,400.bin failed with error -2
falling back to sysfs fallback for brcmfmac43456-sdio.raspberry.400.bin
Direct firmware load for brcm/brcmfmac43456-sdio.bin failed with error -2

So I downloaded the firsmware from armbian and Rpi-Distro and tried to copy this files in the /lib/firmware/brcm directory

brcmfmac43456-sdio.raspberrypi,400.bin brcmfmac43456-sdio.raspberrypi,400.txt

Then I reboot

dmesg | grep -C2 brcmfmac shows :

brcmfmac: brcm_fw_alloc_request: using brcm/brcmfmac43456-sdio for chip BCM4345/9

But /etc/config/wireless still doesn't exist

And a wifi config OR wifi reconf doesn't change anything

Could someone help regarding producing a /etc/config/wireless file please ?

probably want to read Rpi4 < $(community_build)

1 Like

Just in general, the RPi internal SDIO brcmfmac wireless is not apt to be used seriously, performance, range and basic features (no concurrent dual-band) disqualify it for that. That doesn't imply that it shouldn't 'work', it's just considerably worse than cheap APs/ wireless routers from over a decade ago. It can be a very fast wired router or VPN endpoint, but is a disappointment in a wireless capacity.

1 Like

Hi, did you ever solve your issue? I am having the same problem on PI 400. Except I'm trying to connect the PI NIC to my wifi and PI ethernet to my PC.

I've not managed to solve this issue, being total newbie in that topic and having uege t need to have a vpn working, i decided to send the rpi 400 back and to buy an asus vpn device and install the expressvpn dedicated firmware

1 Like