OpenWrt on MR200 - Reboot resets modem config

Hi, one of the reasons that i've flashed my MR200 with OpenWrt was to run a script that checks every minute if a certain host is pingable"*", if the host failed to respond within a certain set pings, a reboot command is issued to reboot the router and hopefully get a better connection.

The script runs just fine via the scheduled tasks(crontab) on my other Outdoor router(Name of router) with OpenWrt running on it. However, on MR200 with the latest OEM firmware 180502, there after flashed with Openwrt 19.07.3-ramips, once the script is trigger and the reboot command is initiated, the router reboots and when the OpenWrt and modem interfaces comes online, i realized that the modem side(modem config) resets itself to the default settings, as if i pressed on reset to reset all of my router's setting. The same happens when i try to reboot the router via the software reboot button from within the OpenWrt interface, everything on the modem side resets itself and i have to re-configure the APN and all of the other different settings on the modem side.

Can someone please help me with this issue, as due to my unreliable ISP connection, the connection has to be checked periodically and i found that this script on my other router saved me the frustration of being allocated a bad connection slot.

Can the script maybe issue a different command other than "reboot", once the criteria is met ?

Thank you in advance for your help.

1 Like

Plus another issue is, that i have about three MR200's running the same OpenWrt version and has the same configuration. They are all connected to another OpenWrt router(TP-Link) which has mwan3 installed and set to do load balancing.

Having said that, when i connect the three MR200's flashed by OpenWrt, all of the three has the same modem ip address which is, so accordingly i have to set each one to a different subnet. If the modem config resets itself, they'll all default to the default modem ip address which will obviously cause conflict in the ip addresses.

Any assistance will be highly appreciated please.

I supposed this means your entire OpenWrt is reset to defaults at reboot. I've never heard of a "modem side config".

If so, try flashing your router a second time using the sysupgrade file.

Hi lleachii,

Sadly this router’s modem, runs on it’s own android operating system that is normally hidden in the OEM firmware. When OpenWrt is installed, the modem operating system is accessible via navigating to , so that we can set the apn and different ISP settings. At the same time, the OpenWrt interface is accessible via navigating to .

When you issue the reboot command from within the user interface or when you’re logged in to the router via ssh, all of the OpenWrt settings stays intact, while all modem settings (apn, dns... etc)reset itself.

I’ve been back and forth a couple of times with the firmwares and tried different versions, they’ve all caused the same reset of the interface.


I think i can use an ADB command to restart the mobile connection, but i'm not quite familiar with adb commands.

I tried the following different adb commands via ssh and yeld the following :

root@OpenWrt:~# adb devices -l
List of devices attached
593add8c067c device usb:1-1

when i issued adb reboot, i wasn't able to reattach the USB mobile device :

root@OpenWrt:~# adb reboot
root@OpenWrt:~# adb devices -l
List of devices attached


Tired the adb kill-server, and this is what happens :

root@OpenWrt:~# adb kill-server
root@OpenWrt:~# adb devices -l

  • daemon not running. starting it now on port 5037 *
  • daemon started successfully *
    List of devices attached


The only way to get the modem to reattach was to issue a reboot command for the whole router, where my modem settings doesn't survive and reset to default. P.S switching off the router from the mains and switching it back on seems to keep the modem settings but doing so renders the connection ping script useless.

Please any help towards this matter will be highly appreciated.

Hi, did you managed to persist modem config after restart?
Can somebody please advise how to persist modem config for this router accessible through
Thanks a lot

I think I have the same problem with my DIR-859, I posted a message in this forum