OpenWrt on Meraki MR42

sorry this maybe off topic, but is it possible to have MR42 server as the DHCP and DNS servers while still being a transparent ap? The ISP provided modem/router combo is required for service and is extremely limited in DHCP(max 25 fixed ips) and DNS(not configerable to use other DNS server at all) aspect. I see that DHCP server and DNS is enabled from a fresh flash on MR42, but when connected to it, client shows its ip as router/gateway. In addition it shows up in traceroute followed by the actual modem+router combo which i thought was weird, since i thought the bridged ap should be transparent at layer 3.

                --------------------lan port   --------
ONT -----------| modem+router combo|-----------| MR42 |
                --------------------           --------
           wan port


traceroute to (, 64 hops max, 52 byte packets
 1  openwrt-mr42-1.lan (  25.074 ms  3.701 ms  4.290 ms
 2 (  14.425 ms  4.688 ms  4.236 ms
 3 (  18.089 ms  6.376 ms  5.337 ms

compare to when not connected to the MR42

traceroute to (, 64 hops max, 52 byte packets
 1 (  32.612 ms  4.620 ms  4.045 ms
 2 (  12.207 ms  5.152 ms  7.657 ms

Hi I successed write the openwrt to MR42
I made a video of the work and will upload it here.


Hi everyone, I have successfully installed this on a few of the MR42's I have. Thank you!
The video Gasutar posted helped, along with the instructions in Github. I had to attempt the UART transfer several times - "error encountered, aborting". Could be my USB adapter but eventually it worked.

It seems stable enough for home use. Now I'm trying to figure out how to create multiple SSIDs and bind them to different VLANs. Does the MR42 hardware utilize DSA? I suspect not...

What would be the correct way to do this?
I've never dealt with VLANs in OpenWRT before - I've used literally everything Cisco for decades.
Searched through the forum and there seems to be a lot of different ways to accomplish what I'm trying to do depending on the hardware/software of the AP.

1 Like

What would be the point as it does not even feature any switch.

What's wrong with just following the regular guide?

Thank you Sumo, that document is why I asked about DSA. Regardless, I got it working.
Did this via LuCi:

Created device interface eth0.555 as 802.1q
Created device interface br-555 attached to eth0.555
Created new interface 555 attached to br-555
Created new SSID attached to interface 555

Works. Is this the appropriate method or is there a better (more correct?) way?

Again, a big thank you to everyone who made this port possible!

1 Like

Can't you just attach the SSID to br-555?

I think I tried that initially and it did not work which is why I went looking for other solutions.

I tried this too, but I'm getting interface errors.
Going to reset my config and start again.

After setting the gateway and dns I was able to run opkg-update, however in Luci, there are 101 packages that need updating. What is the best way to update it, download a later image?

EDIT: On my main router, I created a VLAN ID upstream of the MR42. Could not get any data to flow from a Wi-fi interface through a 'device interface' configured to talk to a eth0 bridge. Even tried directly to eth0. Have not set a VLAN filter on eth0 or a bridge, as that didn't seem right.

Like others, my ideal config dedicates an individual radio and SSID to each VLAN, but I'm trying to get just one operational first.

I didn't tag anything on the VLAN filter of the bridge, or eth0, as it seems that a seperate 802.1q interface config will handle this for each interface (radio) set to use it.

Read something about not using any non-VLAN traffic on the upstream network so will disable that and set eth0 on the MR42 to sit on its own 802.1q VLAN. Not sure how to set the AP to talk to its VLAN, maybe best to create a bridge for it and an 802.1q interface too.

With snapshots one basically does have to update every few days/weeks or at least when trying to install/update packages as there is no long-lived package stream available resp. the snapshot one is quite short-lived and may have expired.

Did you get VLANs working? Mine work without issue doing it the way I described.

Created device interface eth0.555 as 802.1q
Created device interface br-555 attached to eth0.555
Created new interface 555 attached to br-555
Created new SSID attached to interface 555

Thanks for asking; but unfortunately not. I tried to update inside LUCA using the latest snapshot .bin and wasn't careful enough, I think I nearly bricked it. Just get an orange flashing LED and ethernet doesn't come up.

Can boot openwrt via recovery mode, so next step is to write the original r16808-72755b7c3f image onto with nc. Then will try again, First step to get a management VLAN configured on the upstream gateway to link to the bridge to eth0 to get to LUCA, and another, to bring to bring up a radio/ssid as you suggest. If that routes traffic, I'll try with another VLAN and another radio, and return here with some detail. Been meaning to get back to it all week but no time, as ever.

Not sure why, but no VLAN I configured in the first place would route traffic. The interfaces were all green, and I could associate mobile devices to each SSID. Only LUCA worked over the main IP address with the default bridge config.

After failing for a long time and doing multiple config resets, I read in a post somewhere that when a device lacks an ethernet switch, you had to disable DHCP on the gateway's network, so that layer would remain down. If a management VLAN existed upstream, a bridge device configured to eth0 could pickup an address and work alongside other VLANs. (Something about the cpu needing to see the traffic on eth0 before it could route to the bridge created for each VLAN. Then and only then could you configure the VLANs to work)

The 802.1q device config doesn't make much sense to me. I'm a bit confused by the way these tabs in DSA describe the way the hardware should be configured and status reported.

Your post however makes me think this is not the case with MR42. VLANs should route traffic regardless of what network eth0 is connected to? How did you setup your management LAN? Am I right to think you didn't have to bother moving it to a seperate VLAN?

Thanks to all in this forum!

1 Like

Sorry for the very long delay in my reply, been busy.

You are correct about the management. I did not move it to a separate VLAN, I left it untagged.
I normally would not put traffic on the native VLAN for a device connected to a trunk, but in this case I figured it is safest to not mess with it and risk losing access to it if something didn't quite work right yet.

How is your switch port configured? As long as it is configured as a trunk and you have the appropriate VLANs I wouldn't expect any issues - the Wrt configuration is a little odd, but I would think having setup 4 of these MR42's myself without much hassle once I figured it out it should work for everyone too. There doesn't seem to be any technical issues with this build. Mine have been running very nicely other than issues with very cheap IOT devices on 2.4. I'm pushing 400-500Mbps reliably on 5GHz and 90Mbps on 2.4.

Did you try following these steps? Leave management on native. Substitute 555 for your VLAN of choice of course.

Created device interface eth0.555 as 802.1q (tagging)
Created device interface br-555 attached to eth0.555 (bridge)
Created new interface 555 attached to br-555 (unmanaged)
Created new SSID attached to interface 555 (SSID)

+1 thanks
A bit late here, but will likely update the 2 MR42s to development snapshot as you suggested! ... given I can find time :slight_smile:

Hello all,

I was able to perform all steps using diagnostics mode.
But in the end, after it downloading initramfs (I can see it being successfully transferred in the TFTP server log), the white light stays solid but I'm unable to access it via the web interface on or even through telnet.

I was trying to avoid UART since it seems possible to do it this way but I'm stuck.
Do you have any idea what it can be the issue?

ps: the MR42 and the PC are both connected to a switch, isolated from any other network

Today, albeit installing on a pristine MR52 I had Ethernet issues again which I was able to resolve by configuring that switch to 10 Mbps half-duplex. Could it be that you are facing a similar issue?

It's an unmanaged switch so the best I could try was to directly connect to the PC ethernet. Same result tho :confused:

And you ethtooled the PC to 10 half?

I just tried it.

The MR42 downloaded the firmware successfully, the white light stopped blinking and I still can't access the interface on

EDIT: I went to check and the firmware installation file was corrupted. Just re-flashed and I have access to the interface now. Many thanks to @sumo and @clayface!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.