OpenWrt Microtik: No connectivity on eth1

Hello.

I have MikroTik RouterBOARD 951Ui-2nD. I've been using it as a Wi-Fi hotspot connected to my second router as WAN (porth 0 on Microtik).

Now I decided that I want to do the same in reverse. I tried connecting that router to ports 1-4 and I have no connectivity whatsoever even with static IP. Strangely, I could connect to OpenWRT with my laptop connected to these ports with static IP only but since I disabled VLAN functionality it's not possible anymore (I disabled VLAN in "Switch" dialog and selected eth1 instead of eth1.1 in LAN interface list). I have no problems with WiFi.

What's the problem here?

My network config is long, from those only lan and e3372cdc are enabled.

I did try different cable.

How do I solve it?

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdc7:5cf7:c00d::/48'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.1.1'
        option force_link '0'
        option ifname 'eth1'

config interface 'wan'
        option ifname 'eth0'
        option proto 'dhcp'
        option auto '0'

config interface 'wan6'
        option ifname 'eth0'
        option proto 'dhcpv6'
        option auto '0'

config switch
        option name 'switch0'
        option reset '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 1 2 3 4'
        option vid '1'

config interface 'modem'
        option proto '3g'
        option dialnumber '*99#'
        option ipv6 'auto'
        option metric '1'
        option username 'gdata'
        option password 'gdata'
        option service 'umts_only'
        option apn 'internet.megafon.ru'
        option maxwait '60'
        option device '/dev/ttyUSB0'
        option auto '0'

config interface 'modem_megafon'
        option proto 'ppp'
        option device '/dev/ttyUSB0'
        option username 'gdata'
        option password 'gdata'
        option ipv6 'auto'
        option auto '0'

config interface 'mmm'
        option proto '3g'
        option auto '0'
        option device '/dev/bus/usb/001/004'
        option ipv6 'auto'

config interface 'H3372'
        option proto 'dhcp'
        option ifname 'eth2'
        option auto '0'

config interface 'E3372STICK'
        option proto '3g'
        option device '/dev/ttyUSB1'
        option apn 'internet'
        option username 'beeline'
        option password 'beeline'
        option ipv6 'auto'
        option service 'umts_only'
        option auto '0'

config interface 'E3372CDC'
        option proto 'ncm'
        option device '/dev/cdc-wdm0'
        option pdptype 'IP'
        option apn 'internet.beeline.ru'
        option username 'beeline'
        option password 'beeline'
        option ipv6 'auto'

config interface 'LANETHER'
        option proto 'static'
        option ifname 'eth1'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option auto '0'

firewall:

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option network 'lan LANETHER'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option masq '1'
        option mtu_fix '1'
        option forward 'REJECT'
        option network 'wan wan6 modem_megafon modem Yota H3372 E3372STICK E3372CDC'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'

config rule
        option enabled '1'
        option target 'ACCEPT'
        option src 'wan'
        option dest 'lan'

Sorry, what have you done with VLAN?

There is a tick in the "Switch" dialog of Luci.

Have you taken a look at https://openwrt.org/toh/mikrotik/rb951ui? Looks like it might need some specific lines in the config for the switch to operate.

Like the ones he unticked:

Your problem is fixed by re-enabling VLANs on the switch.

BTW, welcome to the community, @Alt_Bass!

Sorry for being dumb, yes, it fixed it.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

1 Like